ubisoft forums

Quick Suggestions

  • Ubi-Keo
    Ubisoft Support Staff 6336 posts

    @Blaue_Eminenz Can you confirm if you are still experiencing this issue after installing the latest update (1.3.2) that was recently released? If you are experiencing issues recording a video on your PC would you be able to use a mobile device to record it? We would just need to see you have the latest update installed and that Puca is not taking any damage.

    @norior2021 I'm sorry to hear that you are still experiencing this issue. Could you also provide a video that shows the following:

    • You have the latest Title Update installed on your platform. You can check this in the bottom right-hand corner of the main game menu.
    • That you are unable to defeat the Puca during "Into the Fog" as it can no longer be damaged.
    Official Response
  • Norior2021
    8 posts

    @ubi-keo Why? What good would it bring? I have already uploaded a video which shows my problem in an earlier post and the problem remains unchanged for months now. I also have the newest version installed. To be honest I don't have any more hope that the issue will be solved at all. I am just really frustrated and disappointed. But hey, at least there are new weapon and armor packs in the animus store. Yay! -.-

  • Ubi-MrM
    Ubisoft Support Staff 4540 posts

    This issue - whereby the Puca cannot be damaged or defeated - could not be reproduced by the development team as of TU 1.3.1, @norior2021. To continue the investigation into this issue, and confirm that it is still occurring on the most recent title update (1.3.2), we need to provide the team with evidence that this is the case.

    If you can provide us with a recent, up-to-date video showing that the issue persists for you, we can pass this forward and get the development team to look further into the issue. As is, for the moment, the issue has not been reproduced of late and this means that the team are not looking into the issue as closely.

    Please rest assured that the team are committed to resolving as many issues as they can that are reported, and any additional information or resources you can provide will greatly assist in this, and be appreciated.

    Thank you.

    Official Response
  • Boda990
    4 posts

    How do I find ten artifacts? I found ten artifacts, but the game says I only got nine artifacts. I can't get the platinum trophy. Please help

  • AtlasMoth8
    1 posts

    I'm on the newest update on PC; the Puca ist still invulnerable at 50% HP. If I cheat to kill him with one hit, it still does not continue to the next part. He just wallows, writhing on the ground. Doesn't matter if I reload a save or close and continue.

  • Sigvarde
    1 posts

    @atlasmoth8 I'm having the exact same problem - PC version, fully patched and I validated all of my game files.

  • UbiStorm
    Ubisoft Support Staff 721 posts

    Hey there @AtlasMoth8 and @Sigvarde . I'm sorry to hear that you're also encountering this issue as well. Would it be possible for you both to grab me a short video clip of this happening so that I can get it passed along to the Game Team?

    Official Response
  • carpetmonster88
    15 posts

    @atlasmoth8 @Sigvarde try to switch off all additional software connected to game. Any recordings, overlays. If you are using any cheats or trainers they can mess up this quest (causing problem with loading proper model for Puca and hanging quest).

  • Ubi-Borealis
    Ubisoft Support Staff 6074 posts

    Thanks for sharing those troubleshooting suggestions, @carpetmonster88! We'd definitely recommend that you disable any background applications as part of our basic troubleshooting, as these can conflict with game files and cause issues in-game.

    If you're still unable to progress in "Into the Fog" after disabling any background applications, please can you provide us with a video which shows the following:

    • You have the latest Title Update installed on your platform. You can check this in the bottom right-hand corner of the main game menu.
    • That you are unable to defeat the Puca in "Into the Fog" due to it no longer taking damage.

    I'd recommend uploading this video to a sharing platform, such as YouTube or Google Drive, as this will allow you to post a shareable link within this thread we can take a closer look at.

    Additionally, please ensure that you have an up-to-date save file uploading to the Cloud. You can check this by looking for a cloud icon on your most recent save file.

    Thanks! 😊

    Official Response
  • FireTigerisHere
    1 posts


    It's still not working (Into the fog), not sure what recording it will do it's exactly as everyone says.
    you do about 1/2 damage and drain all of its stamina and then it continues to fight but takes no damage

    CPU: AMD Ryaen 5 2600x (6 core)
    GPU: Raedon RX 580
    OS: Win 11 64 Pro
    Driver: "30.0.14011.3017"
    Graphics settings: High, V-Sync off.


    https://photos.app.goo.gl/LmEdX5z6eVHvEpLx7: (https://photos.app.goo.gl/LmEdX5z6eVHvEpLx7)

    This is the 10th reload, my DMG doesn't matter so I'm temp invincible just to be sure you can see it not work. (it fails when I take dmg too but it's harder to record).

    If you have access its "Manual Save 3, Into The fog" which is just before the Examine point that puts up the memory barrier and starts the attack.

    After trying again w/o invincibility it worked, but I quit to desktop reconnected and loaded the mentioned save.
    I was only using invincibility twice in the twelve times I reloaded. (the first time and the one I recorded.) Maybe invincibility to the Player character can bug this? - maybe the bug lingered till I QtD)

  • Ubi-Borealis
    Ubisoft Support Staff 6074 posts

    Hello there @FireTigerisHere! Welcome to the forums 😊

    I'm sorry to hear that you're having trouble defeating the Puca in "Into the Fog." Thanks for taking the time to share your report with us, and for including a video. You mention that you're using "invincibility," which isn't a feature available in-game normally. If you're using a third-party software to alter the game files, this could be causing you to encounter issues whilst playing the game, as the game isn't working as intended. You can read more about the effects background applications can have whilst playing Ubisoft titles here.

    If you are using any additional third-party software whilst playing Assassin's Creed Valhalla, I would recommend that you disable this and try completing the quest again.

    Thanks! 😊

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 6074 posts

    Hello there,

    As we have had no reports of this issue with defeating the Puca in "Into the Fog" since the release of the hotfix on June 2 2021, we will now be locking this thread.

    If you encounter any further trouble with “Into the Fog," then please feel welcome to create a new thread and we’ll gladly take a closer look. When creating a new thread, please include any additional images/videos of the issue you’re encountering in-game, as this will be helpful for further investigation.

    Thanks! 😊

    Official Response

Suggested Topics