ubisoft forums

Quick Suggestions

  • guest-VeFA0suF
    1 posts

    Figured it out. When following an npc dont get sidetracked with loot. Follow them directly and collect the loot later. Reload the save to where you started following to the church in the first place but this time stick to her like glue. it worked perfectly for me. Hope it works for you all as well, and maybe it will work on other missions where you have to follow npc's around. Dont know.

  • Thimonsoe
    1 posts

    I have had the same problem the with prey in high hall quest. Also something a like happend in another quest The way of the berserker. The bear Njal chose to go swimming and got stuck standing still in the water.

  • Natalie_Aussie
    5 posts

    I really hope there will be a fix, im 50 hours in hoping there will be one, i have all my gear maxed have done so much while waiting.

  • Ubi-Baron
    Ubisoft Support Staff 798 posts

    Thank you for all the added reports.

    This issue has been passed on to the team to be looked into, and we've added these reports on to the team.

    Official Response
  • Asbel-Lyhant
    19 posts

    @ubi-baron I also have the mans best friend bug where I complete the quest but the ability doesn’t unlock, I’ve gone and gotten the book to unlock it, but it still doesn’t work. I’m on PS4

  • skyline1556
    1 posts

    @arkanis12 i have the same problem

  • loramarcos06
    1 posts

    I have the same problem and i don't have autosave, because when the npc stopped moving, I went to do side missions.
    Help plz😢

  • horackchad
    1 posts

    Issue still persisting, She just stands in middle of church and no further action can be taken. I go upstairs to where the next part is supposed to be and the guy is laying there sobbing but no dialogue window. I also went to get the treasure chest before walking into the church.

  • A Former User
    0 posts

    Hey there, thanks for getting in touch! Could you try loading an earlier save? When you are following her to the church, for example. He is the guy you're looking for, but Wulf needs to be in the church for the interaction to trigger.

  • A Former User
    0 posts

    Hey there! Is she stuck in the church? By any chance, did you try to access the treasure in this area before interacting with her? Try reloading a previous save, or fast travelling to and from the area.

  • bigred9802
    4 posts

    @ubi-spud I did all of that. I have cleared out everything and left come back multiple times. I tried to go back for auto saves but nothing.

  • sheeld
    1 posts

    Season pass quest

    Legend of Beowulf - Prey In the High Hall - Follow Wulfhilda to Brisleah glitch

    After Wulfhilda walks into the church she stops in the middle of the room and does nothing. The mission states "Follow Wulfhilda to Brisleah" but she doesn't move once she stops and doesn't trigger any more actions (Speak, Interact etc.).
    She explained about the guy upstairs, but the quest didn't continue after finding him and I can't interact with the guy upstairs.
    Reloading an older autosave didn't help and now she's just stood looking around doing nothing at all.
    I'm guessing this isn't normal and something that can be officially reported/added to the Report Issue Megathread as I don't think I'm the only one who has experienced this.
    I'll reload my old manual save and come back to the mission later.

  • AirBisqit
    2 posts

    @kdkfk Same here... Frustrating.. she just stands there, and I can't talk to the guy up on the ledge either. I have tried reloading and coming back later.. no dice...

  • AirBisqit
    2 posts

    @horackchad Same... I got the chest first before going into church... F'n Frustrating

  • MushroomStampN
    2 posts

    @kdkfk Nothing like a questline game breaking bug.... Sure hope I don't need this quest to finish, but it's SUPER F'n Irritating to have this much time into a game, then quests can't finish... I'm a completionist and garbage like this will make me stop playing entire game because you don't know how many other quests are bugged.

    p.s. I also got the chest before following her in church... I always get the chests first...I find everything in area before I progress quest, ALWAYS... pisses me off having this unsolvable quest staring at me in the guest list... teasing me .. reminding me how bugged it is

  • MushroomStampN
    2 posts

    @akorna Sadly, I tried 3 previous Autosaves (different stages of quest)... ALL of them actually when they loaded, loaded me back to teh church and the Autosave time stamp mas made current... WEIRD.. so then after trying to load previous autosave points... they ALL became the SAME point... Game breaking bugs is what made me stop playing LEgion, and now it seems I will stop playing Valhalla if I encounter one more bug 😞

  • Akorna
    14 posts

    @mushroomstampn Yup, I had the same thing as @guest-VeFA0suF except that for me, just like you, all autosaves seemed to have "changed" into the same point. So there was no way for me to reload an older save. Even worse, the manual save from the day before (I would have lost +-8 hours of progress but fukkit) had the same "save content" as the latest one, so even that one spawned me at the church with the bugged npc again. So... not even a way for me to return. Can't say it gets better... not yet at least.

  • Valhalla430
    1 posts

    I followed wulfhilda to brisleah and looted instead of talking to her now she's stuck in the church and I can't interact with her I've put 45 hours into the game and don't have a save around this quest please help if this isn't fixed I'll stop playing im not restarting and losing 45 hours of work

  • Nowmane
    3 posts

    I have the same problem, she just stands in the middle of the church and waits for me 😞

    2 posts

    im Having problems with progressing through the bar wolf dlc. The point after you have met the nun and go to the church to see if the group of Vikings are a cause of the attacks. Once u get there you are suppose to check for survivors but the women just goes in and stops. No dialogue option comes up. And I know you are suppose to find the guy upstairs who is the only survivor to see what he knows. Is anyone else having this issue with this quest

Suggested Topics