ubisoft forums

Quick Suggestions

  • R4st__LK54u7523
    1 posts

    @lazylaziel I got the same problem. Just noticed it when I went back to kill the other sisters. I know the only wealth I left in the area is some gear, suddenly I'm missing two in the area.

  • ReservoirDodds
    3 posts

    I was in


    as 1.0.4 came out. I had left the save with one wealth left to find, however when I came back to the game following the update it showed that I had two more wealth to collect. Somehow a new wealth that was held on one of the enemies at a camp in the centre of the map (Hvallgrof Outpost) however the enemy was dead on the floor and the only interaction with them was to carry them - I could not loot their body.
    I have returned to the area several times to see if the issue is resolved and it isn't. I tried fast travelling to a viewpoint and returning and each time it was the same issue. I carried the body somewhere else and threw them on the floor to see if I could loot then, but no such luck. In the end, I got frustrated and threw the body in the river, where it still floats with the golden marker every time I return to check.
    Please help, it's not a case of reloading a previous save as I have gone on to complete the game and collect an awful lot of wealth / mysteries since then.

  • Addrulz
    2 posts

    Exact same problem with me, finished up my collectibles to find the trophy didn’t pop. Check back in that particular area to find the exact same “wealth” even though I’d already cleared the zone prior.

    so frustrating as it’s pretty much the only thing keeping me from my Platinum 😫😫

  • TSTO1
    18 posts

    @nightmarity_xbl thank you for the Dunwic tip man. That was the last one I needed to find in East Anglia (other than the Lerion related one)

  • Ubi-MrM
    Ubisoft Support Staff 4541 posts

    Hello everyone,

    The developers have gotten back to us and would like us to submit the save games of affected players for further investigation. Unfortunately it is only possible for PC and PS4 players to do this at this time, but we'd welcome additional videos of the issue from any affected players on any platform, as they're useful too! If you do take the time to submit a video or save file to us in a support case or via Live Chat, please quote your case reference number here in the thread so we can retrieve those and forward them on.

    In the meantime, I'd like to say a big thank you to Nuka-SK00MA for devising the aforementioned workaround, and to TaYeuleCaliss1 for going out of their way to make a video of it as an example of how it works. You're both awesome and your assistance is much appreciated. I'll copy their contributions below so that anyone having the issue at present can try it out, and let me know if it works for them as well:

    Trap the body then let it explode. Save your game and reopen the game. The enemy respawned for me.

    - from Nuka-SK00MA

    - made by TaYeuleCaliss1

    Official Response
  • sanastian
    4 posts

    Trying to Finish the 100% of each territory for the trophy "Completionist all the way!" In Ps5 the trophy never popped. I went map by map looking for the missing Wealth, Mystery or artifact and found I had 4/5 Wealth in Vinland even knowing I had finished this map at its 100% already I went to check out the missing wealth and I found the missing Wealth to be in an enemy dead body.
    Somehow the wealth was removed from my progress and the enemy never respawns so I can't get to finish my 100%. I tried attaching an image to this post but every size and resolution says its too big if there's any other channel to do that I will gladly send the detailed pictures you need.

  • CKEALiddy
    8 posts


    I’ve had the same problem and I did quite a bit of googling and the solution I found was set a trap on body and carry the body out of the area to nearby patrolling enemies and place it near them, even if they seen you I just quickly ran away and eventually they went back and the trap was set off and the body disappeared. I don’t remember if the wealth guy reappeared in the outpost straight away or not but you could either just save and load the game again or fast travel to nearest point.

  • ikamandi
    2 posts

    New wealth (with patch 1.04) in Vinland is not collectables. It shows on map, not on the enemy I'm supposed to loot from. Blow up his body many times, reload, still couldn't collect it.

  • vignones1
    1 posts

    Same here. I know I cleared this area 100% since I had no plans on returning to Vinland. I finished up my last territory...but no achievement. Sure enough, dead guy marked with an ingot that I can't collect.

  • patrick31995
    2 posts

    I got the same issue on PS5, even though I 100% the area before leaving so Ubisoft caused this bug which I hope they fix as I was looking forward to getting my first platinum on the PS5!.

  • patrick31995
    2 posts

    I 100% vinland before I moved on but now going back to it there's a dead NPC that has wealth that I can't collect therefore I cant get the trophy for 100% completion. Playing on PS5.

    Other people have same issue: https://discussions.ubisoft.com/topic/84815/vinland-wealth-bug-unobtainable-loot/2

  • Vampearo
    1 posts

    The wealth obtained from an enemy in Hvallgrof Outpost in Vinland cant be looted. Closed game, reopened. Waited on respawn, but that particular body stays there unlootable.

  • TaYeuleCaliss1
    10 posts

    @ubi-woofer Hello,
    I don't have any save which have this issue anymore, but if it can help you out here's the reason behind all of this.

    Before the patch 1.0.4, there were 4 wealth accounted for in Vinland and after the patch there were 5. I don't know if they completely added that wealth or if it was on the npc, but it wasn't counted as a wealth for the region. Either way it doesn't matter, the real issue is that for most players the npc holding the wealth was killed and looted before the patch 1.0.4 and this npc doesn't seem to respawn through normal means. So, players can't clear that wealth since there's nothing to be picked up anymore.

    I see 2 ways for fixing this:

    1. Add the loot on the npc in question if he's already dead
    2. Forcing the npc to respawn (Which is basically what the workaround is doing)
  • unne23
    2 posts

    When I tryed to get a treasure in Vinland... The guy that I have to kill was already dead when I was there and I can't get the treasure from him

  • unne23
    2 posts
  • jeje_71
    77 posts

    @patrick31995 there is a workaround, you have to put a trap on the guy, carry him to a patrol near the camp to make him explode (you can carry him near them he will explode), save, and when you come back after a reload, since the corpse disappeared from the world, the guy will be alive again.

    (maybe it's ubi's version of practicing necromancy)

  • MrSamu3l
    1 posts

    I can't take my last Piece of wealth in Vinland. The guy is dead, but he wont drop it.. 

  • ReservoirDodds
    3 posts

    @addrulz At least it's not just me, but I've lost my appetite for trying to get 100% of the collectibles now that I know I physically can't do it yet.

  • AlbanianMode
    2 posts

    I was clearing the outpost without any of my gear on because going to Vinland removes it for the story. I cleared about half of it in stealth and then I got caught and I had to fight with bare hands which resulted in me knocking out the guy with wealth instead of killing him and getting the autoloot. After i cleared out the rest of the outpost I went back to loot the body and the option wasn't there. The only option was assassinate, so I did that and the autoloot skill didn't work and I didn't get an option to loot afterwards. I quit the game and reopened it and it didnt change anything. The body was still there and unlootable. I would go back to another save, but my last save would revert a lot of the stuff I got done.

  • sanastian
    4 posts

    @albanianmode same thing happened to me can't complete 100% cuz I'm only missing that one

Suggested Topics