ubisoft forums

Quick Suggestions

  • feresassal
    9 posts

    I just finished all side quests, Roman artifacts, repents, in short, everything. Only this mission remains to unfold so that I can access the last arch, find the last member of the order and, who knows, start the Yule festival.

    That's sad 😞

    I've tried everything. I went back to basim control, changed Eivor's gender. Reloaded my game. Nothing happens. No cutscene of Eivor and Sigurd returning to camp and the dagger "leaving" Hamtuscire map (I can't "report" hamtuscire to Randvi).

    2 posts

    So I'm fighting basim, past the fight with odin and past the next couple of cut scenes, can't complete as my character doesn't move after trying to stun attack under the tree. 130ish hours to finish with this pile of whack. Shame really!!

  • ThePhatGinger
    1 posts

    Is there really no way to fix this damn bug? After I beat Odin, Sigurd says to stand and then I'm stuck on the battlefield. Both Sigurd and Odin are physical in the sense that I can bump into them. The doors and columns that they're attached to are physical but the stairs are not. Odin even has lines that he repeats but nothing else happens.

    Gotta say, I'm going to be [censored] if I wasted 133 hours of my life on a game I can't even beat. At least I didn't waste my money on it.

  • guest-gGuZofCG
    1 posts
    This post is deleted!
  • Black-Serenade
    2 posts

    @thephatginger I just got to this bug...same exact thing.

  • Ubi-MrM
    Ubisoft Support Staff 4541 posts

    Hello all,

    Thank you for your continued reports of these issues with "A Brother's Keeper". The developers are aware of two issues with this quest currently - that the cinematic does not start, and that after the fight with Odin, Sigurd does not return and there is no new objective to complete - and their investigations into these are ongoing at the moment. I am glad to hear that our most recent title updates fixed the issue for some of you, but rest assured we're still looking into this!

    As I mentioned previously, additional videos of the issue (as requested by Ubi-T00n) and save files of affected players on PC or PS4 (unfortunately it isn't possible for us to acquire Xbox save files) would be much appreciated. Videos should be provided by hosting them on an external site like YouTube and then providing a link, while save files can be prepared by following these instructions and then submitted via a support case or Live Chat. Once submitted, all you need to do is quote your case reference number here in this thread and we'll take care of gathering those and forwarding them for you.

    @x8xGODZILLAx8x Did you submit your video via a support case, or over social media? Can you provide me with your reference number if you have one?

    @Tedybear315 Are you able to provide a video of the issue you're experiencing with the staircase? Have you tried reloading a previous save and trying again to progress from there?

    @vinckeee If the issue you have reported is not the same one as this thread concerns, please do not derail this thread by attempting to discuss it here. We will reply to you as soon as we are able! Thank you.

    @thedjc880 I am sorry to hear of your situation. Regular updates to the game are planned in order to resolve issues, improve the gameplay experience and add new content, so updating it will become necessary if wishing to have the best experience. If it is feasible, it may be a good idea to take your console somewhere with an internet connection to perform the updates periodically. We're unable to troubleshoot effectively with you if the game is not fully updated, so this would also be required if you require further assistance from us.

    @UneaseSole Could you provide a video of the issue you are having please? Have you tried reloading a previous save as well, to see whether you are able to progress after doing so?

    @bookhorn Welcome to the Discussions forums! Could you please confirm for me the platform you're playing on? Can you please also provide a video showing that you cannot climb the staircase? Thanks!

    @nerwenancalime Just to clarify, is this freeze in-game? Can you hear any sound effects or audio at all, or is everything frozen? Are you able to access any menus in this state? A video would be very helpful if you can provide one as well.

    Official Response
  • feresassal
    9 posts


    Thank you!

    I'm anxious for the patch!

  • guest-R9jwt4GV
    2 posts

    It seems I am stuck at a different spot than most. I can get to the tree of life in the cavern and go through cutscene where Sigurd is lifted by the tree and I am supposed to walk to the center of the circle (to be lifted up as well). I start slow walking to the center following Sigurd but as soon as he gets lifted up Eivor freezes. I can look around but cannot move, swing a weapon, fire an arrow, nothing......

    I have tried restarting the game, going back to other saves (even went back pretty far to where Sigurd and Eivor speak to Sigurd's father), restarted PS4, and still same outcome. Almost 90 hours in and I cannot complete the game or even get to fight Odin. I am not sure if the latest patch in December fixed the other issues players were having with this quest but also caused a new one.

    Anyone know if another patch is coming up or any fixes for this?

  • guest-R9jwt4GV
    2 posts

    @nerwenancalime Same issue for me on PS4. Very frustrating at 90 hours in

  • Tomphelps43
    5 posts

    after I couldn’t play the Vinland territory because of a bug I decided to just play the story through. Get to “a brothers keeper” and am now stuck with Odin just looking at me and Sigurd waving his nub. Walk right through the stairs. Can not continue. Thanks ubisuck.

    -have tried restarts

    -been updated

    124 hrs played.
    it’s like reading a book and not knowing the back 30 pages were ripped out.

  • Tomphelps43
    5 posts

    @guest-rxmjhlmk unequip your axe

  • Tomphelps43
    5 posts

    @tomphelps43 unequipes the axe and it went right to the cutscene

  • Tomphelps43
    5 posts

    @thephatginger unequip your axe

  • Alekfrost17
    1 posts

    For ps4 players i somehow fixed this issue. I re started the game, changed the game language of all sorts from Spanish to English and started my saved game, odin beated me with 2 strikes but the story continued. Hope it helps

  • tomoian74
    1 posts

    playing on pc can get past the odin section get rid of axe go through gate it is the next bit fighting basim 25 to 30 mins of fighting and nothing happens cant progress any more

    35 posts

    The Quest “A Brother’s Keeper” where you go to ‘fight’ Odin and he doesn’t take damage so he slaughters you. Sigurd tells you to get up. You get up and run towards Sigurd towards some golden steps... and you run right through them. Can’t interact with Odin. Can’t interact with Sigurd. Can’t interact with the steps. Can’t leave. Stuck.

    Tried a past save, got to same point, SAME ISSUE. I have over 150hrs in this game. I AM NOT STARTING A BRAND NEW SAGA!

    Another game breaking bug by Ubisoft.. figures.


  • JUNHO_Woo
    2 posts

    goinHelier Cave in Hordafüllke, Sigurd has to open the door by memorizing the spell, 
    but Sigurd is forced to move to the port. I can't do anything at the moment. Unable to progress quest

  • stripey1988
    1 posts

    After I entered the animus with Basim the cutscene didn't play so I still have the dagger in the alliance map for hordafylke. How can I fix this.

  • guest-seLxP5G3
    2 posts

    @stripey1988 I have the same issue and can’t find any work around

  • kyledofduty
    1 posts

    Had the bug where Sigurd just waves and you clip through the stairs. Fixed it by going back to where Odin was and going into my inventory and unequiping the axe

Suggested Topics