ubisoft forums

Quick Suggestions

  • Asgardian02
    1938 posts


    me too, thnx.

    Now back to seeing if i can get soime decent runes from the shop, loading and loading back into the game till i get some chc diamond runes

  • Docholiday421
    18 posts

    And it still hasn’t been fixed, Ubisoft get your [censored] together, it’s [censored] January now

  • Rgehara
    1 posts

    @kittenb0mbz this worked perfectly for me. Thank you

  • Mattic48
    2 posts

    Saw someone post a work around. You can shoot the door through the lattice window at the back of the house. The quest continues as normal then. Hope this helps anyone.

  • VesperJinx
    5 posts

    Thanks, incendiary powder trap worked for me. You need to aim at the barred 'window' in the door to trigger an explosion. Just hitting the door doesn't work. I killed the snakes, talked to the woman, reloaded, and she wouldn't open the door. This worked on xbox for me. The poison
    triggered and she became hostile after entering.

  • Lunatriiix
    1 posts

    worked for me! Thanks🤘

  • maxbdavis
    1 posts

    @scuzzya2014 THANK YOU! I have been trying to finish this damn quest for a week and what you said worked.

  • t34416l31
    10 posts

    @mattic48 this worked for me. Your a life saver. I worked on this for over an hour lol

  • Killacase77
    1 posts

    @mikelw6914 thank you!!

  • Trai1b1azer
    3 posts

    This mission's messed up for me. I've killed the snakes, the boar, and i've got access to the cottage. the gas is filling up the room and i've jumped out the window but nothing from the old dear. She just stands there singing like a demented [censored]. Nothing from her, just like Halfden in the Lost Glory mission. Don't get me started on that.

  • SanDiegoMatty50
    1 posts

    Im still having issues with this first i got to talk to her and it had me look at the door but nothing happened so i reloaded a previous save and now i cant get her to stop singing to talk to me again

  • Piattas
    1 posts

    @mattic48 this worked for me big thank you

  • Ubi-Mark.
    Ubisoft Support Staff 3006 posts

    Hello Vikings,

    Sorry to hear that you are unable to complete this quest.

    I can see that this issue is currently being investigated. Once we have an update, we are going to let everyone know through the patch notes. Apologies for any inconvenience caused by this and if you have any additional questions, please let us know.

    Official Response
  • jeepingib
    1 posts

    @captbarnacles1 have there been any updates on this from the dev team? I am having this problem as well.

  • zpals
    11 posts

    After 2 hours i rage quit but when i reloaded back in she attacked me and i got it completed I tried everything else and nothing worked. Maybe try just quitting.

  • holmevik
    1 posts

    @mikelw6914 this solution worked for me as well. Thanks!

  • Beniah30
    1 posts

    I come to the lady but I can't even talk to her to proceed with the quest.
    Re: [Glowecestrescire “Lady of the Lake” Mystery Glitch](/topic/86290/glowecestrescire-lady-of-the-lake-mystery-glitch)

  • Ubi-Keo
    Ubisoft Support Staff 6391 posts

    @jeepingib @beniah30 I can confirm that this issue has been reported and is being investigated.

    I have merged all the posts for this issue into a megathread. Some players have suggested a workaround in this thread that work.

    The workaround appears to be opening the door to the house, once inside you need to escape and the quest should hopefully progress and allow you to finish it.

    The door is locked and can be opened by shooting through a window at the back of the house or using the explosive fire arrow on the door itself. Please confirm if the workaround works.

    Official Response
  • Revendreth
    2 posts
    This post is deleted!
  • Father-Jack
    35 posts

    @ubi-keo The suggested workaround (re-enter the house then escape) did not work for me. I had visited this World Event earlier and had escaped the house, but the lady was far too powerful for me to kill and so I left it until later. Coming back later, the lady was singing on the other side of the small bridge near the front of the house and could not be talked to. The house was still unlocked, but escaping it again through the window did not help. Then I quick saved/loaded right behind the house. I saw the lady was now walking toward the house, and when I approaced her she became aggressive. I defeated her and the event completed normally.

    It seems to me this World Event is not completely resetting as they should when you leave the area i.e. house door not relocking, movable barrier not returned next to the window, and not being able to talk to her initially.

Suggested Topics