ubisoft forums

Quick Suggestions

  • 0 Likes/205 Replies/35777 Views
    8 posts

    @uniquities Its quest related, you have to do a quest till it takes you to Lundun, the girl and the guy will reset after and a key can be found near him.

  • BlackEyeGod
    1 posts

    Same problem me, the key does not appear in any case. There is no other way to open the door so I have to pay Maximilian ...

  • fatalitywolf
    3 posts

    @ugobananas thank you, i was able to complete the quest, though when i tried to use the same method as the first time the quest bugged out again, but i had made a save prior so i was able to reload and just pay the guy

  • fl4sh__
    1 posts

    @ugobananas after smashing the compass key was there, thank you

  • Tinyjester27
    2 posts

    Same.... Chose the little girl to distract and there is no key on the stool out front. I even killed a few people. Thinking it would make the girl shut up and run away. Trying to get the quest to reset. Now? they're lost somewhere in the city lol.....and still no key. Come on Ubisoft. I cant advance this story arc.

  • x3ro-Shikari
    21 posts

    I was in the same boat but managed to get the key to appear after finishing the main Lunden storyline.

  • EternalJosh
    22 posts

    @ugobananas Is Smashing the Compass something you just get naturally by playing? I'm also stuck with the bug and i'd like to resolve it as soon as possible.

  • aazhari
    10 posts

    @eternaljosh it's one of the pledge missions, for Lunden area which happens to be the same city that has the bug.

  • hima-3azima
    1 posts

    @fatalitywolf i have the exact same issue with no fix

  • zzcool500
    40 posts

    i spent an hour looking for the key all over lunden then i got sick of it and googled it and now i find out it's bugged, i'm on pc and it's looping for me too and i can't reload as i did a whole lot to try to find that key

  • VikingHalfdan
    1 posts

    Same happend to me. Kid on loop, can't go back, no save for it. On pc.
    Hope they fix it somehow, die to reset the boy and man, something. I don't wish to continue playing, I've put this quest out for some time and progressed too far to restart.

  • Roeken87
    4 posts

    I payed the girl to keep Maximilan busy, but the key hadnt spawned, so searched for fixes, one suggested that just reloading would fix the key spawn.

    It didnt and now girl is triggered in my save due to Autosave, and for some reason Maximilan has glitched to be a kid, reloading doesnt fix it, restarting game doesnt fix it eitherundefined

  • APPLE5333
    28 posts

    @roeken87 I just have the girl repeating the same line permanently while distracting him around the corner. This NEED to add a quest reset button for all main quests and side quest ( "mysteries" )

  • Jasette
    27 posts

    @roeken87 idk about Maximilian turning into a kid, that’s weird, but I also don’t have a key on that stool, no matter how hard I stare at the stool and move around it. (Also tried leaving and coming back etc) Kid just keeps going on and on about the guy with the curly hair and a big nose and the lady with the wreath on her head. I tried running into them to get her to stop but they didn’t even seem bothered 😂

  • Roeken87
    4 posts

    Okey, so i guess i solved the missing key part, and a fix for the Maximilan being a kid, Key spawned when i finished the main quest for Lunden, and Maximilan also got turned back into normal when it was completed, the kid though was a "grown up this time" but still worked to use the kid

  • Jasette
    27 posts

    @roeken87 ack I can’t progress on “brewing rebellion” (no one will help me break into the longhouse) so I guess I’m super stuck 😭 glad you were able to get through though!

  • ugobananas
    13 posts

    @eternaljosh yes, it's part of one of the main quest arcs

  • Shadow-Wipeout
    19 posts

    I've got to the part where the little girl is distracting Maximus however the key thats suppose to be on the table next to him at the doorway had never spawned so now its stuck in an endless loop, ive uninstalled and re-installed the game and dont want to have to start a new game to finish the quest

  • TSwarthout
    1 posts

    The rivalry of the ages quest won’t let me continue after I distract Maximilian. I’ve tried loading an old save, I’ve tried meditating, and I’ve done 4 quests since then but nothing is making the key spawn to get the statue inside his house.

  • jxckskye
    1 posts

    I'm also having a bug with this quest but slightly different. I have already completed the main Lunden arc, but on arriving to speak to Maximillian, he is dead.

    I can't then complete the quest as it tells me he needs to be distracted.


Suggested Topics