ubisoft forums

Quick Suggestions

  • HarBuggley
    7 posts

    @torfinr Don’t know if you guys are getting the same but when I’m near him my marker isn’t even Ravensthorpe. It’s like 1.5km west and looks like it’s well below the surface of the map the way it moves when I scroll over to it in the map mode. Is your quest marker actually saying go to the settlement?

  • HarBuggley
    7 posts

    @txg_mogatron Ok guy’s somehow mine just fixed I will tell you exactly what I did cos I didn’t even mean it. I saved and loaded in a couple of times. Got annoyed so I fast travelled to Lunden and completed the bugged out quest there cos someone responded to a post of mine from a month ago. Which also entailed saving and loading back in while there. I then triggered the end of that quest and got the dialogue. Then fast travelled to Ravensthorpe and Bertram just appeared at my side. He’s now following me and the quest marker is in the right spot not in Sciropscire where it was earlier. Got back to Winfrith and she’s talking now. @torfinr

  • Kingsley4K
    1 posts

    Bugs I’ve experienced so far during the Yule Festival

    ”Cow Catcher” quest:

    1. Bertham is awful at following Eivor and constantly just stops for long moments at a time
    2. Once the cows were killed and it was supposed to be leading me back to Winfrith, the map marker incorrectly pointed thousands of meters away West instead (luckily I tried looking for Winfrith back at the settlement before following my map because I knew that seemed wrong, and once I got close to her, THEN the map marker corrected itself.
    3. Can’t finish escorting Bertham back to Winfrith because I get a “you must be anonymous” error even though I’m in my own settlement with no enemies around. (Tried putting my hood on, doing other Yule festival games, even assassinating the dummies near Hytham, but still got the same “you must be anonymous” error when returning back to Winfrith)

    “Yule Brawl” quest:

    1. As soon as a round starts, the enemy runs in place as if being blocked by something when trying to run after me to fight. He eventually corrects himself but this is a very obvious unintentional bug. Enemies sometimes randomly float above ground for periods of time too.

  • Asryan2a
    73 posts

    Ohhh ok that's a buggy marker i was wondering why I had to go that far haha

  • schorpio1970
    2 posts

    the NPC in the quest "cow catcher" from the Yule Festival is "stuck" and don't follow me no more back to his mother.
    Not on a horse or boat. It's standing there and do nothing. Please don't say that i must preload a earlier save file, because i did some more activities and don't want to lose that progression.

    Hope there is a better solution.

  • Aerandir_A.
    1 posts

    I have collected 4 meat but the quest does not update pas 3/4, he is also not following me, Bertham just acts like any NPC in the settlement.

  • B19B0ss
    1 posts

    PC: RTX 3080, Ryzen 7 2900x, 32GB 3200 game loaded on SSD
    Assassins Creed Valhalla “Yule Festival”
    1) The person you’re supposed to escort after hunting the cows Does NOT follow you to be escorted. And when you ride a horse or get on your long boat or a small boat the person would get on, but then would jump off.
    2) The barrel of ale keeps disappearing. Solved by not dropping it at all until you get to your destination and until the cut scene start.
    3) Bow and arrow contest: The target sometimes does NOT spin so scores doesn’t count even when target is hit.
    4) Brawl contest: It seems like there’s an invisible platform in the middle of the arena. Eivor and your opponents would sometimes be standing about Eivors height, and opponent could not be hit.

  • lloydbullock91
    2 posts

    Yule festival filled with bugs brewery quest is 250m underground in sciropescire.
    Cow catcher, killed all the cows now I cant escort bertham back and its showing to escort him to the same quest mark mentioned in sciropescire, now he is stuck in water not moving was in the boat and he decided to jump out and not move. Like come on!!!!!

  • lloydbullock91
    2 posts

    @b19b0ss I've just encountered the exact same things its so [censored] annoying! The game is stressing me out more than im enjoying it, hopefully it gets fixed soon, but very unlikely with the holidays coming

  • andreserrano77
    8 posts


    1) and 4) for me.
    Regarding remaining game had no major issues in more than 80h of game, only few visual bugs, but this "Yule Festival" is all bugged

  • Mr.Foxconn
    17 posts

    Same problem here

  • Arcane_Rebel
    1 posts

    @schorpio1970 I had the same issue. Oddly enough though, he would just stand there if I went a certain direction, but if I went past him and headed down the mountain another way he was on my heels finally.

  • Ubi-Orion
    Ubisoft Support Staff 1405 posts

    Hey there folks.

    We are aware of 2 issues with this quest that are under active investigation. To keep things organised I have merged a few threads together that contain threads on both of these issues below

    1. The quest will not update as complete if the cows are killed in a certain order outside of Bertham's line of sight
    2. The quest marker is at the wrong location or is shown underground

    Apologies for any inconvenience caused whilst we're looking into these issues and thanks for all your reports so far.

    Official Response
  • mrdeadhead
    11 posts

    did you harvest the meat? I accidentally did that before his little animation (had no idea he was even shooting this one). then he ran all the way back to the summit the cow was standing on and pretended to harvest the meat and we were good to go

  • Sneaky_RAFP
    4 posts

    @ubi-orion I am stuck at 3/4 Bertram is stood in the river and will not follow or move, anyway to reset the quest?

  • kraftwerk15
    4 posts

    Just returned to Ravensthorpe to start the Yule Festival and started a mission to Build Cattle Farm Building in the Sciropescire region. When I reached the location marker, it seems like it is 250 m below the ground and I cannot reach it. Also when I fly my Raven in the vicinity, it hits some point and launches itself a couple of hundred meters in the air.

    I'll see if I can upload a video showing that here.

    https://ufile.io/ri008fxh: (https://ufile.io/ri008fxh)

  • miagolano
    5 posts

    Mine just went missing and the event isn't over. Disappeared after I finished the quest.

  • xWeiznx
    2 posts

    I finally got him in a small boat (after over 30 mintues of trying differnt things). But now I'm close to the destination and he won't leave the boat. After destroing the small boat he simply stands around doinf nothing.

    This is a real annoying bug.

  • xWeiznx
    2 posts

    Finally got it with the following:

    1. Did some other Yule Festival Quest
    2. Teleported to ship (now Betham was with me)
    3. You can walk him back to Winfrith now

Suggested Topics