ubisoft forums

Quick Suggestions

  • Sam_Boo26
    175 posts

    I also have this bug with the Oxenefordshire treasure. I still have the clue map in my inventory, and every time I go back to the location, I can "take" the treasure, I receive xp, but not the treasure itself.

    I hope they will correct this soon.

  • FatalStatistic
    1 posts

    Rygjafykle is still glitched for me. Saw a thread from a month ago that it was "fixed". The whole island is damn near glitched.

  • Th_White_Snoman
    3 posts

    @corwyngreenleaf Exact same for me too. Also on Xbox One.

  • Th_White_Snoman
    3 posts

    @ubi-raziel Hello, Xbox One here.

    Oxeneforscire Hoard was picked up. The location for me was visible and after I interacted with it, I received the loot. The map remained in my inventory.

    Eurvicscire Hoard is not showing up. I believe there are more threads on this one specifically. No marker, cannot visually see it, nor interact with it. Definitely have not picked it up, but if I somehow have, the map is still in my inventory.

    Also, a new recent thing with the Yule update has made me only able to carry the amount of arrows that you start the game with. I went from being maxed out on it to now having 12, 20, and 5. Can't seem to fix that one yet. Not sure if it's related, but ever since then my quiver is also invisible. Very weird.

  • larrykop1967
    79 posts

    I'm on PC, i too have this bug, i'm on 1.1.0, and there is no treasure to pick up,

  • Lobosilvano
    4 posts

    Same problem in PS4. Patch 1.1.0 dosen´t resolve bug. 😧

  • NerdyGirl1516
    1 posts

    Oh my god it’s still not fixed since November? Dang. I just got to the solution location and it’s still not there. My Oxford map is still in my inventory even though I solved it as well.

  • Rogu3Cowboy
    5 posts

    I'm currently having the same issue with the Oxeneforscire hoard map. I've collected the treasure but map does not remove itself from my inventory. I've also noticed...I can log out...log back in and the prompt to collect the treasure is there but upon activated you don't get the treasure again but you do get the full experience for it.

  • Metroid_Meister
    113 posts

    I still have the bug for the treasure hoard map in Oxenefordscire where the map remains in your inventory when you pick it up. I would like to know when that will be fixed.

  • diploidhelix
    15 posts

    Same issue here on Xbox One with Patch 1.1.0.

  • ChuckKatse
    359 posts

    Nope it is bugged. Several horde maps rewards are bugged. Welcome to the pathetic game support of Ubisoft. They put out a game riddled with bugs and don't fix many of the problems reported. Even their festival drunk bug has not been fixed. They gave everyone a walk around. Meditate every time you load a saved game. They could of fixed that. Real professional.

  • wildp1tch
    4 posts

    Same issue here PS4 1.1.0

  • wildp1tch
    4 posts

    Same issue here. Eurevicscire treasure hoard does not spawn at location. I’m on PS4 patch 1.1.0

  • JustPlainLucas
    2 posts

    Same here. Doing my clean up just now and there is no loot in the pool. Also, the Oxenefordscire treasure map remains in my inventory after I picked up the loot. I only have two left to do, East Anglia and Glowecestrescire, but I'll do those later. If those are bugged as well, I'll come back.

  • timmyd111
    10 posts

    I am aware I picked up the eurviscire treasure when I earlier killed the list drengr but it is listed as incomplete in my inventory same goes for oxenefordscire though I can return to the well and collect the loot over and over again and get the 180 xp you just have to move away and complete another task go back and it's there again but no reward and still in inventory. Kinda suck

  • JSRG1840
    80 posts

    Same big on euviranshire on the PS4

  • UbiExcellent
    756 posts

    Hey everyone! Thank you for posting about this issue. Our teams have received similar reports about the treasure in Oxenefordscire only providing XP and not leaving the inventory, and are working on a fix! Please keep a close eye on the game's official Twitter page, website, and forums for updates to this error.

  • Batsoww
    4 posts

    I have the oxenefordscire map still in inventory as well after collecting the treasure hoard. The Eurviscire treasure will NOT appear for me.

  • Batsoww
    4 posts

    Same here. I'm on PS5.

  • Lysvander
    146 posts

    Can add to this, bit of a minor issue, but maps do indeed remain in the inventory after acquiring the rewards.

    1/ acquire reward, but don't have the map (i suppose) - because i tried to recover several, but it seems they were already in my inventory.
    2/ have map, go to spot, get reward - map remains - this i had happen once so far, and 4 maps remaining, although not sure if i got map or reward first. did not search specifically for them though.

    @ubi Is this a recognized thing? If you need screenshots of map and reward in inventory for clarification, can supply those.

Suggested Topics