ubisoft forums

Quick Suggestions

  • FactoryOfCrap
    5 posts


    It's been three weeks since I last played Valhalla. Can't do stealth or parkour because of this stupid glitch.

    I was able to get a PS5 recently and the bug still persists. Ubisoft support was useless.

    Ubisoft please fix the bug or at least respond. You have a very good game and I was enjoying it very much until this glitch came up.

  • ExothermicBoom
    5 posts

    Yesterday an issue began occurring when I would pull out my torch: there would be no fire on it as well as no light emission. The more I played I realized that several visual issues had been introduced to my game. I have included a list of things that are now invisible or disappear as I get closer to them below (I doubt this is the exhaustive list as I continue to find new things):

    • Grass, foliage, herbs all disappear when I get close to them (makes stealth particularly difficult)
    • tight ropes are invisible
    • torch fire is invisible (and accompanying light)
    • hanging platforms are invisible
    • ziplines are invisible
  • ExothermicBoom
    5 posts

    For some reason I am unable to edit the original post but upon further inspection the light from the torch is emitted.

    Also, the leaves on trees also disappear as I approach the trees.

  • Skummy5683
    1 posts

    Dealing with this now too and it seems like its been a problem for a little while now... Alright Ubi, what are you doing? Whats going on?

  • Rachlily1971
    26 posts

    Not much it seems.


  • MDMayerjr
    6 posts

    On first look, the 2.0 update did not solve the problem for me (though I'm not sure if the issue was addressed in this update). Anybody else? Any word on an ETA for a solution?

  • Rachlily1971
    26 posts

    I don’t think it was

    why don’t they respond?

    I mean this is game breaking really. How can you use a wire by jumping into thin air. Hide in no bush just relying on the invisibility of the character.
    trees lose their leaves as you approach, grass disappears, tents and buildings.

    WHY WONT YOU UPDATE US @Ubisoft !???

    @Ubisoft Please respond and address this!!

  • TooBadToWin
    8 posts

    I’ve waited 2 weeks and the bug still isn’t resolved. How does a bug like this exist in the first place? 13 days without a single response from Ubi support 😐

  • PudimKawaii
    1 posts
    This post is deleted!
  • Russel_978
    2 posts

    Been having the same issue on the ps4, played through 80 - 90 hours of the game and nothing really happened, and then after finishing the main missions in Gloucestershire it started. It makes every little vegetation piece simply vanish as you get close to it, really immersion breaking, and also kind of a pain when trying to be stealthy.
    This is after the patch 1.1.0 btw.

  • Tempus_909_L
    4 posts

    After completing the mission in Lunden, where you


    . I've started noticing that various parts of the scenery are dissapearing and becoming invisible. The most notable are the foliage of bushes and shrubs disappearing as I move through them, as well as hanging ropes completely becoming invisible (so when I'm traversing buildings using parkour I suddenly land on something invisible in mid-air). These are the only things I've noticed so far, as I stopped playing due to waiting for the latest 1.1.0 patch to be installed. However after the patch was installed yesterday, the problem still persists. I can still seemingly progress in the game, however it severely reduces the immersion and also makes stealth combat much more difficult and not very enjoyable. I've tried various things like reloading saves prior to that specific mission, fast travelling to different places and uninstalling and reinstalling the game, all to no avail. Unfortunately this is spoiling what has been a very enjoyable game to date and with around 40+ hours already invested, I definitely do not want to be replaying a majority of the game to fix this issue. I'm disappointed that the latest patch has not addressed this issue and I hope for a swift fix, as I will not be playing the game again until it has been fixed.

  • Tempus_909_L
    4 posts

    @ubit00n any update on this at all? As it is still happening to a lot of players (Re: Dissapearing interactive scenery), even after the 1.1.0 patch, making the game unplayable in a lot of people's eyes. Very disappointing considering it's a decent game and a lot of players are missing playing the game at this time of year! Thanks for any response in advance.

  • summer_mutawe
    3 posts

    @morianehtar I’ve tried that; it didn’t work. I even uninstalled and reinstalled the game... still same problem. Even going back to a previous save where things were fine didn’t help... I’ve tried everything and now I am out of ideas. Maybe I should just stop playing and revisit once this mess is fixed a year or two from now 😞

  • fade2black_23
    9 posts

    So I was playing today and I noticed that as soon as I get close to any foliage it disappears. This makes it hard to sneak around because I don't know when the foliage ends. Is this a bug or is this intended behavior?

  • WillGiles92
    16 posts

    @fade2black_23 I had this for a while but now seems to have resolved...

  • pumaxx_ub
    2 posts


    also after the 2.0 update the vegetation bug is still alive 😠

  • Ubi-Raziel
    197 posts

    Hello all!

    I managed to find quite a lot of threads surrounding this issue, so I have merged you all together.

    Our dev team are still looking into this, apologies for the incovenience.

    We will inform players once the issue has been resolved.

  • blizzardix
    1 posts

    70h hours in, Sciropescire, PS4 and same problem of "not rendering" vegetation around Eivor. Also, all the tight ropes are invisible and that makes the game way more challenging as you are unable to see the paths that you are supposed to use.

  • pumaxx_ub
    2 posts

    after another restart now it seems to be ok

  • mendonca.brian
    1 posts

    @ubi-raziel hey just started facing the disappearing foliage 56 hours into the game. Game has a lot bugs since the Yule festival... but this one has killed stealth play, which is my preferred game style. Any chance the dev guys putting out a new patch soon?

Suggested Topics