ubisoft forums

Quick Suggestions

  • beanofwar
    11 posts

    Submitted case 13518224 for this issue.

  • mcgrann
    1 posts

    @beanofwar its saying page doesnt exist, any update on your case?

    19 posts

    Now i really do have a gamebreaking bug. I'm at 79 hours and i enjoyed the game big times so far. But now i have to kill the Needle and he glitched out. He is just standing there and i cant kill him anymore. He is untouchable. I tried to load Autosave, Manual save, go somewhere else and come back, explosions, nothing works.

    Without the quest i cant complete the questline in Jorvik, cant finish the region, cant finish the Order etc. so i guess thats game Over for me until it eventually gets patched. 😞

  • S4V10R537F
    5 posts


    It's completely unacceptable that any developer would release a game in this state. They owe all of us an apology for ripping us off like this.

    I wasted $119 on the Ultimate Edition and can't even get a refund because of the Playstation Store policy.

    19 posts

    Dear Ubisoft,
    you made a great game. I love it. The graphics is breathtaking (PS5) , there is so much awesomeness in this game. I bought the ultimate edition for 100$ which is a lot of money, and i put another 20$ into helix credits.
    Now i'm stuck in the game. I cant kill the Needle. He just stands there and is invincible. That keeps me from progressing with the game, from being able to kill all order members etc. From what i read here and on reddit a lot of people have adressed multiple problems in several missions, which have not been patched in the latest patch and leave them frustrated for not being able to process in the game. It is very frustrating indeed to be quite honest. I Know you guys are working hard. I know its hard with Covid and home office etc. And i know it doesnt help a lot if people keep complaining. So I will try to be more constructive.
    How about , instead having to patch all the mission bugs and glitches instantly, you will add an option to reset a mission? That will allow everyone to progress in the game since its unlikely that the same bug happens again. And it will give you time to look into the problems that still persists,while most people will be able to move on with the game instead of having to wait until their particuliar problem is being taken care of.

  • beanofwar
    11 posts

    @mcgrann they claim to have submitted it to development for review. I don't see it in the latest 1.1.x patch notes, so it's not fixed yet.
    Got put through the standard helpdesk ringer (full reboot, clear cache, uninstall-reinstall). After a few go-rounds they said "submitted to dev", best I can do.

  • H0bo-Baggins
    8 posts

    @beanofwar this is so frustrating. Numerous players are encountering this issue and it hasn't gotten any traction with devs despite being a known issue on these forums for weeks. Hope they get to this soon!

    Not enjoying having purchased a game I can't progress further in.

  • H0bo-Baggins
    8 posts

    I basically haven't played AC Valhalla since end of November cause I can't finish the pledge and would rather not invest time doing side quests if I'm going to have to scrub the game and start over.

  • Ojisan_Olesan
    2 posts

    I can not assassinate the needle at jorvik, please bug fix as soon as possible (last played 200 hr. more) platform ps4

  • MissM16
    214 posts

    I'm not up to this quest yet, but I'm trying to avoid these bugs by reading others' experiences.

    Anyway, I have a dumb question for you...

    Since the quest asks us to specifically "assassinate" the Needle (not just kill him in any way possible), have you already tried climbing the roof and stealthily assassinating him?

  • Ojisan_Olesan
    2 posts

    @missm16 All methods have been tried.

  • Storm_Breaker__
    7 posts

    Was having a great time playing ACV until I was stopped from progressing due to “Assassinate the Needle” being glitched and I can’t complete it. No communication from Ubisoft has told me they basically don’t care. I purchased a different game and I’m moving on.

  • Wodanswolf45
    4 posts

    i also have this bug and can't finish the game now. bug has been around for a while. why isn't it fixed yet ?

  • pest84
    2 posts

    I also have a bug on this mission and can’t progress. I have no mission marker, I did the trade depot without the marker but now I’m stuck. Looked on YouTube and what I need to do is not available. Glad I spent nearly £100 on a game I can’t play. Xbox SX.

  • VanadiumCobalt
    317 posts

    @storm_breaker__ Look at this thread. few people have found a fix and it might/might not help you. https://discussions.ubisoft.com/topic/82517/can-t-progress-in-pricking-the-needle/32?lang=en-US

  • GaimerLady
    10 posts

    Seriously though, why hasn't staff seen this yet?? I posted about it forever ago and have seen several other posts.
    This is absolutely ridiculous.

  • beanofwar
    11 posts

    lol - agreed



  • beanofwar
    11 posts

    Everyone should be submitting support tickets for this issue, IMO. To raise visibility, report this as a bug (in a more meaningful fashion than posting on the forums). $0.02

  • cjmsouza_BR
    1 posts
    Guys, greetings to everyone!
    I have a bug in the alliance mission in the city of yorkshire, the moment I send "Kill the needle" the character is immobile and does not die. Has anyone else had this bug? I am unable to progress because of this. I played in PS5
    Thank you all 

  • guest-eHxyGt6d
    3 posts

    Can you help me please?
    I am at Jorvik and I must kill one of the two member orders.
    After I kill the flame I complete the other one quest but I can’t kill him because he is invincible and he can’t do anything.
    So I am blocked with the storyline.
    Thanks for your time.

Suggested Topics