ubisoft forums

Quick Suggestions

  • Locked Solved [RESOLVED] Unable to proceed with "Pilgrimage to St. Albanes" as the cutscene does not play after rescuing Fulke | POST HERE

    0 Likes/185 Replies/6774 Views
    10 posts

    Day 16 since we were told there was a fix however still nothing.

    sorry, what at this point makes you think I care about anything else in a title update, doesn’t matter what else you include if I can’t finish the damn main story. Just flick a quick apology announcement out on everyone’s Home Screen and force a little update with just bug fixes, not new content or updates... just bug fixes. Would appreciate it heaps aye.

    furthermore, increased frequency of posting in the news section would also be appreciated. Nothing has been added since you told us, I’ve just sat here waiting.

  • Ubi-MrM
    Ubisoft Support Staff 4541 posts

    @Xenilll - Thank you for your feedback regarding this issue with A Pilgrimage to St. Albanes. I'm glad to hear that you are looking forward to the fix! 🙂 In terms of the reported issue megathread list, we do frequently add new issues to it when we determine that an issue is common / shared, as opposed to experienced by only a small group of players. It can take a little time for some issues to get to this point, so I do apologise that you felt like you were not being taken seriously. Please rest assured that that is never the case, and that we value all issue reports and feedback shared with us! As I've written in the thread as well, the list is not exhaustive and if an issue is not listed, it does not mean that the developers aren't looking into it. 🙂

    @selfysh - If you believe that there is a bigger thread than this one for the same issue, can you provide a link? When we establish a megathread, we try to merge as many topics for the same issue into one to keep all of the information together, so it may be that the discussion you believe to now be closed was actually merged with this thread here. If it hasn't been merged, and you can find a link, please send it here so that I can take a look! You can refer to my above update regarding an incoming fix for the latest details.

    @oneleft1998 - I do not have any additional information or an ETA to share regarding the fix at this time. Once the patch details are confirmed and announced, we'll share that information here for the reference of all affected. Until then, I must ask for your patience and understanding.

    @AussieJay93 - I am not a developer - I'm support staff - and cannot hustle along the process of implementing fixes unfortunately! 😞 I do fully appreciate however that this issue is preventing further progress for you, and would like to reassure you that we will update this thread as soon as possible with additional information when it becomes available. As I wrote above, the Community Team will also make a new thread in the News & Announcements section each time a new hotfix or title update is incoming, so please do keep checking there. Finally, per our forum rules, please do avoid bumping threads. I appreciate that you are eager for new information however we will reply as soon as we have this, without prompting. Thank you! 🙂

    Official Response
  • AussieJay93
    10 posts


    any chance you could get a developer in here so I could chew their ear off about this issue. I know y’all got a fix, I don’t understand why I am waiting this long for a patch. I don’t want new fresh content, I just want to be able to do anything. I’ve literally completed the map as far as I can, I’ve collected every available treasure, completed every mystery, solved every puzzled, completed every little mini game. I’m done, everything is maxed in upgrades. I spend my time now redecorating the church at Saint Albans church, setting up displays with all the bodies that won’t unspawn. Pretty disappointed with how hard the ball has been dropped here. I’ve never been able to complete a game in my mind without having been able to finish the main quest until now. 😢

  • AussieJay93
    10 posts

    @ubi-woofer you can’t get us any more info? Been 25 days since you said they had a fix and were chucking us a patch soon. I’ve seen or heard nothing. I keep checking the news and updates section and not even a mention of it. Now at 4 months of being stuck 😔

  • Ubi-Borealis
    Ubisoft Support Staff 6074 posts

    Hello all!

    I would like to reach out to you all with an update from the development team. The issue wherein Fulke cannot be interacted with in "Pilgrimage to St. Albanes" will be resolved in TU 1.2.0. This update is due to be deployed 16 March, 2021 at 1PM CET/8AM EDT. You can read the patch notes and learn more here.
    If the issue still persists for you following the deployment of TU 1.2.0, please can you provide us with a video that shows the following:

    • You have TU 1.2.0 installed. You can check this in the title menu in the bottom right-hand corner.
    • You're unable to interact with Fulke still.

    Thanks all! 😊

    [EDIT 7 July, 2021: As we have received no further reports of this issue happening in-game, we will now be locking this thread. If you continue to encounter trouble with "Pilgrimage to St. Albanes," please don't hesitate to open up a new thread. A member of the player support team will take a closer look as soon as they are able to.

    Thank you 😊 ]

    Official Response

Suggested Topics