ubisoft forums

Quick Suggestions

  • Locked Solved [RESOLVED] Unable to interact with Tove after completing "Carrying the Torch"; quest missing from log | POST HERE

    8 Likes/280 Replies/7646 Views
    1 posts

    Cannot talk to Tove after Svend died. (PC, patch 1.1.1) The quest "Carrying the touch" doesn't appear in completed quest list. Please fix this, I cannot customize the character at all.

  • Ripper2O3
    5 posts

    Sadly given the time it took to fix the issue with all NPCs, I feel its going to take some time before this is resolved.

    A little bummed because of some of the new tattoos I have acquired but I suppose I can save my silver from buying new ones at merchants. Kind of glad this didn't happen when I was "experimenting" with new looks.

  • Makhnovtchina
    4 posts

    @ripper2o3 It is just a matter of finished quest check. I dont know why they took so mutch time to fix the first related bug but I think this one may be fixed far faster.

    (I know how mutch this is frustrating as I'm stuck with a weird style myslef).

  • luc4o.
    1 posts

    After Sven's death I can't talk to Tove anymore

    2 posts

    I know its part of the game that he dies and she takes over, I speak to tove at her grave and she heads to the shop and sits down but cannot be spoken to. I tried reloading an earlier save, talking to different people in the settlement... nothing.

  • Daednumai
    10 posts

    I'm having the same issue, I'm at settlement level 4, have done the Svend death quest and built the tattoo shop but Tove will not talk to me to buy tattoos.

  • warzone16643
    1 posts

    @sleepy_raymond having the same problem, I’ve completed the quest and have even gone back to the grave to see if I have missed something.

  • MadrepC
    2 posts

    I’m exactly the same. Did Carrying the Torch, Tove went back to the hut and now can’t interact at all. No problems with anyone else , just her. I’ve been and travelled all over the place, re-loaded but she still in-responsive.
    Im guessing this is the only place in the game you can change your appearance / tattoos , so really needs to be fixed as it seems a lot of people are having the same problem.
    Thanks !

  • Gnarly_Duma
    1 posts

    @sleepy_raymond hopefully there will be a patch soon I'm eager to try on my new tattoos from legendary animals and treasure hoards my hard earned ink 😂

    2 posts

    @daednumai actually so relieved that it's not just me!

  • IljaSil
    3 posts

    @sleepy_raymond Same issue here. Anybody an (temp) solution for this?

  • SAT-9
    3 posts

    What the hell the devs are doing right now nobody in this universe can't change their appearance(I don't understand the point of the mission anyways) It shouldn't be this hard to make a hotfix. If they sent me the source code of the game this morning I could debug it in 30 minutes.

  • guest-PLNz12mW
    1 posts

    I can’t interact with Tove the tattoo artist even after completing her quest.

  • CellarD00r666
    5 posts

    Already told Ubisoft about this issue and they said they are working on it... after talking to Tove at Svens grave, the quest did not complete and Tove cannot be interacted with. Therefore, cannot use the tattoo shop in my settlement.

  • Fraser178
    6 posts

    Hi guys,

    After Tove
    takes over the tattoo shop in Ravensthorpe I cannot interact with her at all.
    It's almost like she isn't even there, if I stand on the stool she sits on there is no collision with her character model at all.

    • I've tried reloading the game.
    • Different fast travel points.
    • Ariving by boat (so no fast travel ).
    • Spending the night in Ravensthorpe.
    • Upgrading other buildings.
    • Travelling to Norway/Asgard and back.
    • Going to Svends grave and interacting with it
    • Buying new hair/tattoo from vendors.

    I can't think of anything else to try at this point. I followed the story and interacted with Tova soon after I found out about Svend's death.

    Please let me know if there's anything else I can try.

    Thanks in advance,

    Joel Fraser

  • TheLastHarrison
    1 posts

    @samjp910 this has happened to me too, I've completed the quest for her in ravensthorpe and now she's usually sat at the tatttoo table drawing but no speech bubble above her head and pressing Triangle won't do anything. Needs fixing asap as I've got soo many tattoos now

  • Tyu101
    2 posts

    This is the same for me and needs fixing basically ruins the character customisation

  • Tyu101
    2 posts

    @mistahpiggles This is happening to me too on the PS4 v1.1.1.

    Even after I finished Carrying the Tourch d so then you are unable to interact with Tove.

  • NyxTheCreator
    1 posts


    I’m having the same issue, completed the quest but she won’t talk to me. Sucks because I have a facial tattoo I don’t like right now, and now I can’t change it.

  • auridulis
    86 posts

    @wrightwayup The same here, v1.1.1 on PC.

    The quest 'Carrying the Torch' is missing from my completed quest log too.
    I did that quests and built the Tattoo shop in v1.1.1.

Suggested Topics