ubisoft forums

Quick Suggestions

  • Locked Solved [RESOLVED] Unable to interact with Tove after completing "Carrying the Torch"; quest missing from log | POST HERE

    8 Likes/280 Replies/7670 Views
    2 posts

    Good afternoon,

    Since the update in Jan 2021 I am no longer able to talk to Tove the tattooist. Can you please advise how to fix this. I have reloaded the game numerous times, going back to before the update is not an option as I have put many more hours into the game I do not wish to lose.


  • Rossifer13
    3 posts

    I also am unable to speak to Tove after the latest update 1.1.1. I've completed the Carrying the Torch quest but it does not appear in my log as finished or active. I am on PS5.

  • MASON512
    2 posts

    Cannot change hair or tattoos after speaking to Tove at a burial site. She is in the shop but no interaction is available, have not been able to change my appearance for some time now

  • Fraser178
    6 posts
    This post is deleted!
  • immendes
    1 posts

    Same problem here. I'm seeing so many bugs in this game it's heartbreaking. It's a plague in the game industry. We are in dire need of laws that substantially fine these greedy companies for selling a product that doesn't perform as advertised. Refunds are not enough. Hurt greedy people where it hurts the most, their pocket. It's always the same companies, these are not honest mistakes, it's blatant malpractice. They just don't care. Test your games and updates tirelessly before you release them. A few minor bugs is ok but these absurd amount of bugs is just criminal.

  • FlashingZero
    1 posts

    I'm having the same issue. Please fix this, we can't change our hair or tattoos...

  • Rmsbra25
    1 posts

    I have been playing for 50 hours and experienced the following bugs:
    -I can't costumize eivor, after svend death I can't talk to Tove.
    -characters don't move the mouth in some scenes
    Don't tell me or other player to erase the game data and begin the game again. Is your job to do a nice product for your customers and fans. For now, you demonstrate how lazy and disgusting your work with ac Valhalla is... Please fix ALL THE BUGS

  • willofthewisp85
    1 posts

    I completed the “Carrying the Torch” quest, but I can’t interact with Tove. This has been going on for a few days.

  • Martucho
    1 posts

    Like the title says...atm i´m unable to change tattoos or hairstyles because Tove can´t be interacted with after the Svend memorial quest "Carrying the torch". Don´t know if this has been posted before, but trying to bring the devs attention to this issue.


  • guest-Tii0BWu3
    4 posts

    @martucho same here. Its quite annoying. They need a hotfix before the end of the week.

  • Dragoness31
    7 posts

    @acezim57 I am also having this issue on Xbox. reply to get the issue bumped and hopefully if enough people point out this is happening, maybe it will be fixed.1

  • Mykey602
    1 posts

    I cannot change Eivor's appearance, Tove in the tattoo shop in Ravensthorpe does not have a dialog box and there is no way to interact with her. This started after the 1.1.1 update which I got before going back to Ravensthorpe and finding out Sven had died. I talked to Tove at the grave marker, she walked back to the tattoo shop, now I cannot interact with her.
    Also many NPC's mouths do not move during cutscenes

  • StruckCap614979
    1 posts

    I've not had most of the other bugs yet but tova still want talk it seems to be the same with other players also when npc talk mouths dont move I love this game alot but is annoying when you cant change hair or tattoos please sort out ubisoft

  • HellRaiser81816
    2 posts

    I have tried multiple times to reset the quest even uninstalled and reinstalled the game I'm still on able to access the hair and tattoos in the game at the moment since the new update. I also can not find the quest when I go back to my completed quest either. I'm hoping this is fixed very soon.

  • LuckyNumberZeik
    7 posts

    @lajarai yes it’s terrible, I specifically went back to the settlement just to change how I looked after switching genders and I can’t do anything

  • lewisstorer89
    19 posts

    @immendes "Refunds are not enough"

    we arent even getting those right?
    in my eyes they would be enough. I paid £60 for this - and got around 50 hours back for my money before I stopped indefinitely thanks to this bug in November.
    I just want my money back.

  • austyn56
    1 posts

    Same, super frustrating. i did carrying the torch

  • Dantia88
    2 posts

    This is bugged for a lot of people it seems, Ubisoft really needs to get their [censored] together and fix all this crap.

  • Dantia88
    2 posts

    @martucho Same here. A lot of people are experiencing this. Unsure what triggers it.

    They have to hotfix this as we can't do anything with our appereance now because the geniuses decided to have only one tatooist in the entire game.

  • WrightWayUp
    18 posts

    @dantia88 I think it is to do with ‘Carrying the Torch’ not appearing in Completed Quests so the game does not recognise Tove taking over.

    If there was another tattooist would be a lesser issue ....

Suggested Topics