ubisoft forums

Quick Suggestions

  • StarFalcon1017
    6 posts

    Yup, same issue. LAME

    3 posts

    Yeah I have the same problem. I like to clear an area then move on but I can’t finish this mission and it’s driving me crazy.

  • Ubi-Swaggins
    Community Manager 439 posts

    Hey folks,

    Thank you for reaching out.

    Have you tried fast travelling away from the location and returning?

    Official Response
  • Burton768
    4 posts

    Very similiar issue for me. I smashed the first wall, cow didnt move through, as I pressed focus and it went to the tower the builder had created. I pulled the stone inwards (huge mistake) rather than pushing it foward, and cleared all the other walls. After travelling to viewpoint and coming back the cow had moved to second room but won't move from here and the stone is stuck behind the wooden planks on the floor and I can't move it. I managed to get the cow to move slightly by summoning mount on top of it but it will not enter the third room at all, it is the one thing stopping me from 100%'ing the game 😞 Really hope they patch it as it really demoralised the rest of the grind

  • Techromon
    1 posts

    Fast travelling doesn’t seem to work. Nothing does. I have been stuck on this mystery for days now.

  • DM_Steel
    9 posts

    @ubi-swaggins I have the same issue. I've left Asgard to reset the quest even and finished the first arc, but when I return to the cow, it's still sitting stuck next to the movable rock and all the walls are back up. It's like the position of the movable rock won't reset and now it's stuck on debris on the ground.

  • SM0K3YMcP0T94
    1 posts

    I was looking at it and I’m pretty sure it’s the tiles beneath the stone wall you move, if you move it back it looks like it drops were there aren’t tiles so it’s stuck, not sure if this was intentional or not but I did the same thing and that was my conclusion aha

  • Tzarak
    1 posts

    @aerial_arts undefined
    The stone may have got positioned before the cow moved from its original spot and is now stuck in the wall ( This is on the PC )

  • guest-bx9tXjaF
    2 posts

    @ubi-swaggins OP here. Yeah I've done every other mystery and wealth at Asgard, but this rock is still glitched. As someone below stated, only the rock is the issue. Fast travelling and just leaving Asgard only reset the wood walls that you need to break, not the rock.
    Hope this helps find the issue!

  • KindaDope
    1 posts


    I have problems with this mission because when I break the first wooden door the cow advanced. When I moved the stone, instead of forward, I did it backwards, the stone and the cow were trapped and even if I break the other doors, the cow does not advance.

    Is there a way to restart that mystery mission or other solution?


  • RandyMossReaper
    2 posts

    @gfyc73446 pretty annoying eh? I'm glad I'm not the only one. Hopefully it'll be fixed soon.

  • Superfly_Boss
    105 posts

    On a side note, is this a nod to Fallout 4?

  • HelenSBlake
    21 posts

    So, a new update released. It claims to fix certain quests that could not be completed before due to bugs. I load my game, go to Asgard and try for the 10th time to finish the last mistery I have left there. Not only does the god cow not move, stuck as always, but now the damn rock doesn't even move. Before, I could slide it slightly to the right, which did nothing but, it could be done. Now the rock is stuck there because of those damn planks on the floor and the quest is still unbeatable. How many times do I have to ask for this? Please fix this quest. Reset the rock or something, but let us who didn't complete it due to this bug finally finish it. It annoys me to see that it's the only quest left in Asgard.undefined

  • R4zy01
    1 posts

    The side quest in Asgard where you have to escort a cow is still broken. It stays stuck at the bit where you move the rock. The rock is stuck in the wall but leaves space for the cow and it won't move and I can't change the position of the stuck rock.

    3 posts

    So I just came back to the cow after the update and now the cow is in a new spot but still stuck and the rock is still stuck on the wall and can’t be moved.

  • TheDingo92
    1 posts

    Still bugged after update

  • Hchmss
    3 posts

    @floodedmantis same here... Too bad the new patch didn't fix this problem

  • Hchmss
    3 posts

    Same here! Hope for another new patch who fix this bug

  • tblackwell97
    2 posts

    @crimsfyrill I am having the same issue and I even tried to see if the new patch (1.04) fixed this and nothing changed.

  • SimperingTyler
    2 posts
    @crimsfyrill I am having the same issue and I even tried to see if the new patch (1.04) fixed this and nothing changed.

    I am also having the same issue and I’m on xbox.

Suggested Topics