ubisoft forums

Quick Suggestions

  • Locked Solved [RESOLVED] Quivers reset to minimum arrow capacities even if upgraded following TU 1.1.0 | POST HERE

    1 Likes/584 Replies/10472 Views
    7 posts


    Just go back to Vinland, shot the arrows you have, and go back to settlement and rebuy them.
    Fixed it for me.

  • DavidDouglas123
    1 posts

    @d0nt_panick Seeing the same arrow issue here, and I also had the Yule festival conclude during some sort of offline issue. Also played around 10 hours this weekend, and I'm not looking to lose that progress. I'd rather not participate in the Yule festival if folks are going to be walking 10 feet in the air, especially during the fights. But I need my arrow count fixed.

  • cedarrapidsboy
    4 posts

    How does the Vinland fix work? I've unequipped my bow (not holding anything), travelled to Vinland (fast travel) and shot all of my arrows (I'm in full Native American garb with Vinland bow). Unequipped bow so not holding it. Fast travelled back to the settlement. Tried to buy arrows. Won't let me buy more than 15.

  • ValkyriePhox
    7 posts

    This is what I did, and it worked. If it doesn't work for you, then it sucks.. Sorry m8


  • rtmk
    1 posts

    Current Power 154, Quiver Level 6 of 10
    Arrow Reduced capacities: Light=20, Predator=5, Hunter=12
    Cannot purchase more than the above amounts nor will upgrading quiver make any difference in capactity
    Problem started a few days ago (Yule update?).
    Also had problem with losing new Skill Points but that magically resolved itself today.

  • cedarrapidsboy
    4 posts

    @valkyriephox Thanks. That was what I attempted. Maybe I'll try going back to Vinland and buying some arrows... New World Eivor is currently out of arrows.

  • jeffcs1137
    4 posts

    I had arrow capacity go back to lvl 1- so I tried going to Vinland after I selecting Arrow Looter, it has gone up to 20 hunter arrows which I think is where I was when I went to Vinland the first time, which it should be at 24 (and 12 predator arrows , not 9) so I got some of my capacity back but not all- I have no idea why that would happen. It’s better than lvl 1 so I’m hoping it returns to normal after Yule 😞

  • Nuubz0rr
    2 posts

    Having the same issues on PC. Also after i reboot the game Eivor is just drunk. Meditating helps with this but that is not permenatly.

    5 posts

    same here on pc my quiver is max but it went from 30 arrows to 12... help?

  • DuskDragon56496
    475 posts

    When I experienced that bug a couple of times I had to go back a few hours into the game, I found that as long as I didn't let the arrows get below beginning game number for example, not letting the predator arrows get below 6, I haven't had a problem since...people can try that. so far it's worked for me for about 20 hours of play through...good luck!

  • guest-pww2dj2g
    6 posts

    Anyone know how much time could Ubisof take to fix this problem?

    It is extremely frustrating.

    35 posts


    I haven’t gotten to Vinland yet. I’ve been doing a lot of exploring prior to the main quest missions.

  • celepacif
    5 posts

    Hi everyone. After the new update (1.1.0), specifically playing some games from the yule festival I started to have problems with my game.
    first, every time I start the game, it doesn’t matter where my character is, that is going to be drunk and have to wait a minute till I can see a better picture.
    also, I have my arrow bag at level 9, but I only have 12 arrows, before this happened, I had 28 on my bag. Don’t know what to do.
    I read that I should spend all the arrows and then go to ravensthorpe and buy all of them in order to get the 28 back, but when I try it, I can only buy 12, no more.
    so I don’t know what to do. Should I wait for a solution or is it a way to fix it by myself ( I am playing it from my PS4)
    Ty all.

  • HeathenShip6935
    8 posts

    @jimbo-davis Same issue - was doing the Wenlocan Outpost, on my way to Sciropescire, and halfway thru my quiver capacity was cut in half. Only noticed when I tried to pickup more arrows and could not, though the quiver showed only 5 predator arrows available.

    Went to the save just before I started the Outpost, and it showed I had 10 predator arrows in my quiver. I just made sure I did an additional, separate save, and logged off in disgust. Have not been a fan of "change bow to use different arrows" method introduced with Valhalla, and this bug just makes matters worse.

    Please fix!

  • Syrjaelae86
    18 posts

    @lotharkamgang I tried this aswell, not only did it not work, my quiver actually REDUCED itself to level 3 from level 5. Safe to say, noone at Ubisoft actually tested the Yule update for bugs.

  • Deadmennwalking
    21 posts

    I have the same issue. Now have 12, 20 and 5 arrows. Had previously upgraded to 18 or 20 hunter arrows. Upgrade bar still shows the quiver has been partly upgraded.
    Have fun and may RNG be forever in your favor.

  • B.isfor.Basic
    2 posts

    I am also having the same issue on PS5. My quiver is upgraded 8/10, but I am only able to carry the same amount of arrows mentioned here. I know my Predator bow could carry at least 10 before Yule started. I upgraded the capacity yesterday hoping it would fix the issue, but the max capacities did not change.

  • celepacif
    5 posts

    It’s happening to me too. Also when I start playing eivor is drunk.
    so frustrating

    hope we get help ASAP

  • celepacif
    5 posts

    Same here.
    also, Eivor is always drunk when the game starts.
    So frustrating.
    hope it gets fixed ASAP.

  • celepacif
    5 posts

    @celepacif also, tried to go to Vinland, and shoot all the arrows and the bag level was downgraded!!!

Suggested Topics