ubisoft forums

Quick Suggestions

  • Locked Solved [RESOLVED] Quivers reset to minimum arrow capacities even if upgraded following TU 1.1.0 | POST HERE

    1 Likes/584 Replies/10538 Views
    1 posts

    Am having same issue, my maxed out char is stuck with 12 hunter, 20 light and 5 predator. Just did a quiver upgrade on my second char and saw no change in arrows capacity, stuck at 12, 20 and 5 and I only have one quiver update left. Not sure if it has something to do with the Asgard/Jotenheim zones, but seems to have been since I went to them.

  • Damonsalv1
    3 posts

    Same issue: my arrow capacity is maxed out to 30 but all of the sudden it dropped from 30 to 12 and it said my arrows was full which isn't correct as the max capacity of the arrow is 30 so how can it drop to 12.

  • quepio
    2 posts

    Same here, quiver size is capped at low number (e.g. predator bow at 5) after upgrading to 1.1.0. Re-installed the game and tried with older save, which initially showed my predator bow quiver size as 9, but after I used arrows in the combat, I got capped at 5 arrows again. Upgrading quiver size doesn't do anything either, quiver size just remained the same as 5.

  • lillysdad1120
    6 posts

    @quepio thanks for information i hope they get this fixed soon.

  • bdogbolt4
    2 posts

    I am over 40 hours in and when upgrading my quiver I am gaining no new arrow inventory and actually went from 18 hunting arrows to 12 after the new update.

  • Bizwiz2006
    4 posts

    Sometime today my arrow capacity went from the max back to lowest. I had 15 predator arrow max now it's back to 5. I don't know if it's related to update but today is the first time I played since the patch. Please fix!

  • XNQtionr
    3 posts

    This has happened to me too on PS4. I have a lvl 4 quiver but, after completing the quest Tilting the Balance and starting Heavy is the Head, it reduced down to base capacity. Also, when reloading my save, the quiver on Eivor has completely disappeared

  • Wolfassassin240
    2 posts

    So i was progressing through the storyline in cent and for some reason after upgrading my quiver my arrows that were last max quantity at 34 arrows for the light bow reverted back to 20, 12 for the hunter bows, and back to 5 for the predator bows. I should have double those number of arrows in all types since i upgraded the quiver to the 2nd to last spot. I'm not sure if i stumbled upon a new annoying glitch since the 1.1.0 update but it happened at random while i was exploring and i cant seem to revert it back to what it should have been. If the tech team has time to look into this i would really appreciate it.

  • Ubi-MrM
    Ubisoft Support Staff 4540 posts

    Hey there Wolfassassin240! Thanks for posting about this issue here on the forums. I'm sorry to hear that it appears your quivers have reset to the default quantities randomly.

    Does this issue persist after restarting the game? How about after reloading an older save, does it continue then? Please let me know! A short video clip would be helpful showing whether you can only shoot the mentioned number of arrows or if you actually do have the right amount and it's just a visual bug, too! 🙂

    Official Response
  • xtralag
    7 posts

    Hi Ubi-woofer, there have been lots of reports on this issue already (see below under arrow capacity or quiver upgrade; typing on mobile makes it hard to copy links properly, sorry). It happens to me randomly when killing soldiers. 3 times it took 3-5 soldiers, in my final test I eliminated almost an entire fortress. And the loss of max arrows is real, no display issue.

  • JMetch
    59 posts

    @ubi-woofer It is a real bug, I have it too. Predator bow only carries 5 max after being updated. MY game is broken before this last patch. Mission, Storming the Walls does not start up. After this patch to fix it, Which it did not. Caused even more issues. Your updates are making the game worse. At least I beat all the Zealots and legendary animals. Now my enemies don't fight back, So I can attack them without a chance of being struck back. So LAME.

    10 posts

    add me to the list for this Bug too, plz Fixed it ...

  • lovingfarcrysup
    1 posts

    @xxelfninoxx , THIS SUCKS

    I played more than 10 hours before realising the problem and 5 more until I went on this discussion ... I play on ps4 but I'm not going to go on an older save... I'm going to wait for ubisoft to make a bug fix... but it sure does suck to carry 5 predator arrows, especially when u maxed out the needler

  • UbiT00n
    Community Manager 256 posts

    @lillysdad1120 Hey! Thanks for all the feedback folk, this has been raised with our teams.

    Official Response
  • diver_gr
    7 posts

    After 95 hours of gameplay my quiver got bugged (it is fully upgrade ) and the predator arrows quantity went from 30 to 12, it also affect all arrow types, light arrows for went from 40 to 20 and predator arrows quantity also took a hit.

    This doesnt fix even if i reload the game. Tried to change runes , bows, all character gear hoping that will resolve the glitch and go back to normal but nothing.

    Have anyone encounter the following bugged or know any solution? It is very annoying because i play my character mostly with bow and now with 12 arrows its destroying my game.........

  • brnt9
    1 posts

    Same here

  • Arya.---
    1 posts

    Same issue for me. Tried upgrading my quiver since it wasnt maxed in the hopes it maybe fixes it but it is still limited to 12. Am on the 2nd to last upgrade possibility.
    Playing on Pc

  • MadnessReigns33
    21 posts

    Same here on PS4. Played all of yesterday without issue and stopped playing right when I started the Lincolnshire arc. Booted up the game this morning to continue and noticed my arrow capacity on the light bow was down from like 38 to 20. Don’t use the other bows much so I don’t remember what the max was before but hunter is now at 12 and predator at 5

  • Wolfassassin240
    2 posts

    I cant reload the game on a previous file since i overwrite them with a new one. I have tried also restarting the game twice and no changes to having ut go back to what it should be as its still stuck at the default amount. I'll check again to see if its just a visual problem on my side. But probably more than likely the actual amount of arrows one can hold has been somehow reverted back to the default amount. Apparently its not just me either bit has happened to others as well.

  • leoleo1982
    2 posts

    Same here, I have the same problem my quiver size reduced
    30 to 12 arrows.

Suggested Topics