ubisoft forums

Quick Suggestions

  • Locked Solved [RESOLVED] Quivers reset to minimum arrow capacities even if upgraded following TU 1.1.0 | POST HERE

    1 Likes/584 Replies/10605 Views
    9 posts

    Unfortunately, I experienced the same thing.
    It does NOT fix the issue, for me as well.
    Very frustrating to be at such a disadvantage when encountering high-level targets.
    And, the UBISOFT SUPPORT page does not actually allow you to submit cases. (Calling it a BETA site, does not excuse the behaviour.)
    Is Ubisoft showing cracks in the wall?

  • BfloJack
    1 posts

    Having the same issues with the quiver. I've maxed out the quiver, but I only show the minimum number of arrows (5/5 Predator, etc). All since the update. I'm level 278 on Xbox Series X.

  • Apollosh
    11 posts

    Dear all

    My max. amount of arrows (for every bow) is now - since the patch - on a minimum (like on the beginning) even the quiver is on max level. Are you experiencing the same?

    Following, all I've tried so far for solving the arrow problem. Everything even after creating a new manually savegame and do multiple reboot, while online:

    • tried with completly different clothing
    • tried with completly different weapon
    • tried with completly different bow
    • by resetting all skills
    • by resetting / removing all abilities

    This, in all kind of combination, without any result.

  • Jenny4466
    1 posts

    Anyone else how a problem with there arrows decreased in numbers

  • jraven00
    5 posts

    Same happened to me have max quiver but the capacity dropped back down to 12/20/5 rather than 30/40/??. Playing on PS5 and the three new skills are gone as well and I now have 3 skill points I cannot assign.

  • Ubi-Raziel
    197 posts


    Thank you both for reporting this back to us, we will make sure this gets resolved.

    First of all Apollosh, I'll add your YouTube video to the thread as it's very helpful:

    The team thought they found the case of the issue and that is related to the Arrow Dropper skill. I understand you have reset your skills Apollosh so it doesn't seem to relate to you.

    @MrGTST Can we please check if you have the Arrow Dropper skill equipped, and does restarting your game (while connected online) help?

    The image you provided is very helpful, I added that to the investigation 🙂

    Thank you!

  • faff81
    1 posts

    I’m also experiencing this since yesterday, very frustrating. Tried everything, unassigned the arrow loot skill, Traveled to Norway let loose all my arrows unassigned bow and travelled back. Manual save quit game started again. The list goes on.

  • ftsi
    9 posts

    Vinland solution did not work for myself (XBOX ONE X, AC Patch 1.1.0) or others.

  • Ubi-Raziel
    197 posts
    I’m also experiencing this since yesterday, very frustrating. Tried everything, unassigned the arrow loot skill, Traveled to Norway let loose all my arrows unassigned bow and travelled back. Manual save quit game started again. The list goes on.

    I appreciate you getting back to me on this, and I have notified the team that the suggested workaround doesn't seem to work.

    We'll come back once we have more questions or information!

  • Apollosh
    11 posts


    yeah... frustrating what's pretty quite describing it.... it's just more and more which is not working and now even getting worse with a patch which should solve issues.... it's just destryoing the whole game-experience and I'm about to not play it anymore.
    buying a game and wait month and patches for playing it ... this is what we used to call alpha- and betha-version some years ago.... nowaday it seems normal to sell a beta version of a game

  • GVO872
    8 posts

    same thing for me on xbox

  • Z3no2k
    6 posts

    I have the Same issue 😞 so Game Breaking 😞
    And quiver is missing.

  • Apollosh
    11 posts


    dude u made my day. worked for me as well!

  • Apollosh
    11 posts

    guys, just found this in another thread and it worked for me!!!
    go give this guy some props in the other thread




    For me now even the quiver is shown correclty. may you want inform the team about that workaround 🙂

  • natesac69
    4 posts

    I wonder if I need to have completed the Vinland arc for this to work. I have only just started it and just now acquired a bow in Vinland. I don’t want to get into details in case of spoilers, but at present this workaround is not working for me.

  • Ubi-Raziel
    197 posts

    Hello everyone!

    I found there were quite a few different threads for this issue so I have merged you together.

    Our team are aware of 2 issues -

    • A max upgraded quiver now behaves like a level 1 quiver
    • The quiver has visibly disappeared from Eivor's hip

    We've forwarded player reports to the team, and we'll let you know if we have any further questions!

  • Zegotron2.0
    1 posts

    There must be other people who are experiencing this issue after the update. Before the update I had 30 arrows in my quiver. Now I have 12 arrows maximum. Also my character does not seem to have a quiver my arrows are just sitting next to my player at all times with no quiver.

  • diver_gr
    7 posts


    tried going back yo Vinlad, empty all arrows as suggested at reddit, remove bow, went back to main map , it almost fix it because while quiver is max upgraded it still missing arrows for example hunter arrows is now 26 when they should have been 30.

  • Rlytle97
    1 posts

    My quiver was almost maxed out and now it is stuck at a maximum of 12 Hunter arrows only. I have been looking up solutions, and found that very many players are experiencing the same issue across all platforms. I believe it happened after the last update, but I am not entirely sure when it started. I can no longer pick up arrows once I have 12, and I cannot upgrade my quiver anymore. Could someone please look into it and provide a patch?

Suggested Topics