ubisoft forums

Quick Suggestions

  • 0 Likes/1212 Replies/24358 Views
    8 posts

    @moog500 Same here. Did not work for me either. What is most frustrating is that a few people have been able to find ways around this, but after trying ALL the suggested fixes I have had zero luck. I will have to do the same as I don't see myself getting the game to launch at this rate.

  • emmaj95
    66 posts

    @beez_trees I'm in the same boat. Been on these forums for three days now trying every solution under the sun. Nothing has worked. Unless they patch it out, my chances of fixing it myself look slim. Really upsetting as I have been looking forward to this game since it was announced.

  • Daleth42
    3 posts

    @abhi_thegamer I'm in the same boat. Frustrating.

    3 posts

    same here. I have tried everything I have seen and read online to fix it but no joy yet.

    seems we have the worst of the worst unfortunately, very disappointed.

    good luck!

  • DeltaMaykos
    1 posts

    same here 😞

  • ScorpionDK27
    14 posts

    @crazydonkey88 its the first assassins creed i wanted to play on pc and i really wanted to see how an assassins creed would look with the graphics and stuff but what they do right know is just redicilous and i dont have the feeling they will change anything in the next few days...

  • Leelany85
    2 posts

    This post by @Frostizy helped me to start the game! I had to copy the video and sound files to c:/

    The following solution worked for me, found on reddit:

    Basically, you need to try the old fix that works for Origins: https://steamcommunity.com/app/582160/discussions/0/1483235412214825118/

    But for audio (Assassin's Creed Valhalla\sounddata\PC) AND video files (Assassin's Creed Valhalla/video).

    So you need to copy across your .pck and video .webm to where your windows OS is installed. Then with https://schinagl.priv.at/nt/hardlinkshellext/linkshellextension.html : (https://schinagl.priv.at/nt/hardlinkshellext/linkshellextension.html)create a symbolic link for each file and junction for repertory.

    The whole thing only takes a handful of GB and takes about 10 mins for those who are still unsure here is a step by step.
    • Download and install Link Shell Extension
    • In your OS drive (usually your 😄 drive) create two folders one for the videos and one for the sound files.
    • Open the ACV folder and keep them next to each other.
    • Drag all the files and folders from the video and sound folder in the corresponding 😄 folder (cut and paste don't copy them.)
    • Right-click the sound folders and select "pick link source" then in the empty original ACV folders right click and "Drop as" - "Symbolic Link" (make sure you do this for every file, and yes you can batch it by selecting all the files.)
    • Do the same again with the files in the video folder. Note Do not try to batch link the folders as it won't work and you have to do each one individually but instead, select "drop as" - "Junction"
    • You can delete any language files you don't want in order to save some space.

    If you make a mistake don't worry just delete the .sym file or the junction and do it again.

    Launch the game and give it a min or two and you should be good to go. 📷

    Want to give credit to redlight on the Ubisoft forum for the original help. I'm gonna put on a brew now. Got a long night ahead!

    I hope this will help!

    Source: https://www.reddit.com/r/assassinscreed/comments/jrc7pu/fix_for_infinite_splash_screen/

  • emmaj95
    66 posts

    @leelany85 didnt work for me 😞

  • CrazyDonkey88
    100 posts

    @leelany85 i will give it a try but how to create junction?

  • Baelzar
    2 posts

    If your Epic Games PC installation of Assassin's Creed: Valhalla isn't launching at all - when you either try to launch from within the Epic Games program or via the shortcut that was created and it gives you nothing, no splash screen, just....nothing....this fix worked for me.

    Go into your install directory (in my case C:\Program Files\Epic Games\AssassinsCreedValhalla) and double click ACValhalla.exe. That allowed the Ubisoft Connect Launcher to update, which is apparently necessary.

    THEN I was able to get it to launch, either by using the existing desktop shortcut, the Epic Games program Launch button, or double-clicking ACValhalla.exe. Hope this helps someone. Skal!

  • dss8654
    4 posts

    @trolsopol i still have this issue

  • Staky000
    9 posts

    Mine suddenly worked last night, made it to england..

    I just got home from work today, and it's crashing on splash screen again 😞

  • CrazyDonkey88
    100 posts

    @staky000 lucky u man 😉

  • CrazyDonkey88
    100 posts

    @dss8654 Me too, after almost all day of reinstalling and trying other solutions.

  • CrazyDonkey88
    100 posts

    @jsjordache1 True, they don't do anything. Well Origins and Odyssey looks amazing in 4K. Shame on Ubi o simply [censored] them 😉

  • dss8654
    4 posts

    @crazydonkey88 i chatted with ubisoft suport and they said basically just gotta wait for an update. I got this game free with my new cpu, but if i paid money for this game I would be livid. I would have refunded and bought on sale or not at all.

  • trolsopol
    32 posts

    @dss8654 already there mate, tried submitting a refund request on Tuesday, I still have had no response...

  • Woog_TX
    8 posts

    This just started happening to me today. I've been playing it fine but with occasional crashes (usually while climbing mountains). Same as OP, no error message just a complete lockup at the logo.

    From Event Viewer:

    Log Name:   Application
    Source:    Application Hang
    Date:     11/12/2020 1:22:16 PM
    Event ID:   1002
    Task Category: (101)
    Level:     Error
    Keywords:   Classic
    User:     N/A
    Computer:   STEPHAN-PC
    The program ACValhalla_Plus.exe version stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
     Process ID: 27f4
     Start Time: 01d6b9280b7bd544
     Termination Time: 4294967295
     Application Path: C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Assassin's Creed Valhalla\ACValhalla_Plus.exe
     Report Id: 15849786-6f37-4ffa-a84a-a30404fcc922
     Faulting package full name: 
     Faulting package-relative application ID: 
     Hang type: Top level window is idle

    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">: (http://schemas.microsoft.com/win/2004/08/events/event%22%3E)
      <Provider Name="Application Hang" />
      <EventID Qualifiers="0">1002</EventID>
      <TimeCreated SystemTime="2020-11-12T19:22:16.392304900Z" />
      <Security />
      <Data>C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Assassin's Creed Valhalla\ACValhalla_Plus.exe</Data>
      <Data>Top level window is idle</Data>

  • dss8654
    4 posts

    @trolsopol no way!!! dam i thought that would be automatic!

  • Woog_TX
    8 posts

    After looking at the error from event history I added C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Assassin's Creed Valhalla\ACValhalla_Plus.exe to Windows Defender Firewall. The game started right up with no issue. Hope this helps everyone.

Suggested Topics