ubisoft forums

Quick Suggestions

  • 0 Likes/1212 Replies/24729 Views
    20 posts

    @iamcadenz3090 im doing once again another reinstall if a patch didnt push as a update for some reason IDK but afterwards I will try safemode and let you know

  • EfeTozan
    6 posts

    @pale_rider_tv is it in your hdd or ssd?

  • Pale_Rider_TV
    20 posts

    @efetozan m.2, my OS is on SSD no HDD on my PC

  • EfeTozan
    6 posts

    @pale_rider_tv okay, coz it doesn't work in hdd when you have ssd.

  • proxyonemusic
    2 posts

    I get about as far as pressing "New Game," and then it immediately crashes.

  • Pale_Rider_TV
    20 posts

    @proxyonemusic yeah i just want to get past the splash screen after pressing play. looks like all i got was temporary 400x600 wallpaper.......pff

  • Agent_Ting-TTV-
    2 posts

    12hrs later, still can't launch the game.

    1. Reinstalled Ubisoft Connect
    2. Reinstalled the Game
    3. Updated Nvidia Drivers
    4. Set the game to run as admin
    5. tried adding both ACvalhalla and ACVahalla_Plus to High Performance in Nvidia Settings
    6. Not running a Microsoft Storage Space
    7. Installed to default location on the SSD C Drive.

    Nothing gets the game past the Splash Screen

    This feels like a DRM issue if I've ever seen one. I almost want to uninstall/refund and wait for a proper CODEX patch 🤣

  • PascalJansen
    4 posts

    Assassins Creed Valhalla Startet nicht habe es bereits 2mal neu instaliert aber sobald ich auf spiel starten drücke öffnet sich nur das UBISOFT CONNECT Fenster und weiter passiert nix

  • GRCarlos_05
    3 posts

    I delete from SSD and put to the HDD and work now.

  • iBenM24
    2 posts

    @pascaljansen Bei mir startet es auch nicht!

  • chewbaccat_
    1 posts

    It is indeed a problem with windows storage spaces drives.
    If you can install the game on a non windows storage spaces drive. If you cant you can try this solution from 5 years ago: https://forums.ubisoft.com/showthread.php/1259451-SOLUTION-AC-games-won-t-launch-when-installed-on-Windows-Storage-Spaces-Forums: (https://forums.ubisoft.com/showthread.php/1259451-SOLUTION-AC-games-won-t-launch-when-installed-on-Windows-Storage-Spaces-Forums)

    This is what worked for me. I had to create directory junctions for the sounddata and videos folders

  • royalretro87
    4 posts

    Game won't launch beyond splash screen. All other games from Ubisoft works on same drive. This is a QA issue and it is embarrassing to see for a company asking for $100+ pre orders. Villains of the industry.

  • Pale_Rider_TV
    20 posts

    @royalretro87 seriously! I only got the standard edition only because every game I have preordered spending 100+ on in the last year has been highly disappointing. Now this.... I cant win. There better be some time of compensation! Worst major developer game launch ever experienced.....

  • PascalJansen
    4 posts

    hast du das gleiche problem an der selben stelle?

  • BFire13
    2 posts

    I'd like to add that I'm having the same problem. Tried uninstalling and reinstalling ubisoft connect and the game on the same drive. Nothing works and still stuck on splash screen.

    Brief specs:

    RTX 3090
    32gb 3600mhz

  • OGCadenz
    7 posts


    Soooo...i'm a dunce. I bought the game on my backup Uplay account! 😞 after speaking to support and logging into my other account i see it sitting there all pretty and ish! 😞 Downloading now, Will update on whether it launches:

    RIG ahead of time: I'm going to try on 457.09 First
    CPU:i9 9900k
    MB:Z390 Aorus Master
    RAM:64GB Corsair RGB DDR4
    GPU:EVGA Geforce RTX 3090 FTW3 Ultra

    LG 38GL950G
    2x Asus ROG PG278Q
    KB:Logitech G513
    M:Logitech G502 Hero SE
    Case:Corsair Obsidian 750D
    Headest:Astro A50 Gen 4
    Xbox Elite Wireless 2 Controller


  • Pale_Rider_TV
    20 posts

    @iamcadenz3090 well GL with your download some people on PC can play and some cant best of luck with your DL

  • Xyrella
    18 posts

    @frostizy My game is installed on my main c driver already. Isn't that fix for people who have the game on a separate hdd.

  • iBenM24
    2 posts

    ja, genau gleich!

  • Ziener89
    6 posts

    @pale_rider_tv it's emberrasing. and instead of letting us know whats up, they only answare people who lack details.
    I've tried:
    Reinstalling both Uplay and the game.

    • Run as admin.
    • Update drivers.
    • adjust gpu in nvidia control panel.
    • have both Uplau connect and game on main ssd.

    I still can't get it to work. imma go to bed early, and hopefully the game will work when i come home from my therapist tomorrow xD

Suggested Topics