ubisoft forums

Quick Suggestions

  • 0 Likes/1212 Replies/24408 Views
    448 posts

    @primalstrike65 Hello there. I sincerely apologize for the inconvenience and frustration that has been caused by this problem in Assassin's Creed Valhalla. Your disappointment is completely understandable considering you have not been able to play a game you spent money on. I would feel the exact same way in your shoes! With that being said, have you uploaded your MSinfo and DxDiag files in a case at support.ubi.com? If not, I would highly suggest doing so. I did look over your former posts, but did not see a case number. Please reply back with your ticket reference number once it has been created. Thank you so much!

  • PrimalStrike65
    11 posts

    @ubikoality The problems I’m having are on the XB1S not PC.

  • PrimalStrike65
    11 posts

    @ubikoality I forgot to mention I cannot submit a ‘ticket’ through the game (XB1S) because it freezes (the cursor will not move) once it gets to the ‘Continue’ screen.
    The only thing I can do is push the ‘X’ button to close the game. You can however look for my original post regarding this matter. The post name is “Can’t play at all now...” (posted Nov. 22, 2020, 10:46PM). I have since I posted original post uninstalled ACV again with no effect.
    Thank you for your reply and any further help in getting this great game working for me.

  • RedIndianRobin
    188 posts

    @primalstrike65 Lmao to the support guy. I feel sorry for you because Ubisoft are notorious to never fix issues. Their last patch 1.0.4 didn't had half the fixes they claimed in the patch notes.

  • krvpt.
    63 posts

    i have the splash screen issue and every work around doesn't work for me. i noticed ubisoft put the issue into the "known issues" post, and that it will be addressed in a future update, but when? how long do i have to wait to play a game that i paid $60 for? some people even spent more and have the same problem! its been 21 days and i'm starting to get REALLY annoyed.

  • Borb98
    6 posts

    @krvpt Hello, if you did not try the Ubi support i recommend to do so the will send you some steps to follow. It helped me with crashes. Try re-installing Microsoft Visual Studio C++ redistributables (2010, 2012, 2013, 2015; and IF and only IF your windows Build is greater than or equal to 18362 - install Microsoft Visual Studio C++ 2015/2017/2019 Bundle) After this hit win update that will download .NET and that should do it.

  • Ubi-Baron
    Ubisoft Support Staff 798 posts

    At what point are you getting stuck? Is it at the Splash Screen? Do you get an errors?

    Official Response
  • crusaderofblood
    5 posts
    • @ubi-baron splash screen here is my case number as well 13180189

  • AmiDreAm
    9 posts

    that is big problem for many people. case № 13326448
    need patch!!!

  • krvpt.
    63 posts

    @borb98 ive done that already, doesn’t fix it for me.

  • krvpt.
    63 posts

    @ubi-baron holy [censored] read the [censored] posts. YES THEY ARE GETTING STUCK ON THE SPLASH SPLASH SCREEN. THIS ISSUE HAS BEEN IN THE GAME FOR 21 DAMN DAYS

  • krvpt.
    63 posts

    @krvpt ubisoft will never get another dime from me with this dumpster fire of a launch

  • angelofsm
    1 posts

    I click on my game in the Ubisoft connect and then the sqaure with the logo of the game appears and it stays like that forever and dont launch the game. can someone help me solve this problem pls. thank you

  • Breakabletie
    6 posts

    i just bought AC valhalla and downloaded it and am very excited to play but when I click the desktop icon or 'play' in the uplay launcher i see the AC logo and it never starts like it freezes. i have reinstalled it, no change. I have internet connection. restarted my computer several times and even let it sit and 'load' for 20+ min. I uninstalled uplay/ubisoft connect and reinstalled, varified my game files several times, ran game as admin, updated windows and my graphics card drivers

    I even double checked that unbisoft has taken my money so i know that i payed for it. Any ideas that might help other wise I will have to refund it.

    ubisoft help please i summitted a ticked several days ago

  • krvpt.
    63 posts

    22 days and i still can't launch the game due to the splash screen freeze. when will there be an update that fixes this? i know its known and going to be addressed in a future update but when? 22 days and unable to play a game you paid $60 for is unacceptable. also ive done all methods given to me by ubi support and ive tried community methods, nothing works for me.

    no answers from ubisoft, just helpless useless emails that dont fix my game. 22 days ubisoft. its been TWENTY TWO days.

  • ShawnPyrik970
    1 posts

    @ubi-litten Similar, but my splash screen never goes away (still counts as played time, though.) Purchased Ultimate Edition from Epic. Freezes on launch screen, requiring reboot of PC. Have tried troubleshooting per the FAQ with no luck, nor can I open a support case on your website.

    At this point, I'm fed up and want my $132 back. The forums aren't the only thing that are in Beta.

  • Plan3tCrackr
    46 posts

    @shawnpyrik970 If true such a mechanic lacks any semblance or morality.

  • Lomig_1983
    8 posts

    I finished uninstalling windows 10 and reinstalling another version of W10 (support wasn't of a great help; unfortunately...). And then, tadaaa, it worked.
    It's not a great help to you, but desperate times call for desperate measures... Good luck everybody.

  • Lathby
    5 posts

    I got the game a week or so ago and I have not been able to start the app once. I have it on Epic Games-When I click on it it says "Cloud Syncing" then goes back to "Launch" then after a second it says "Launching Game..." and then back to "Launch". It has never opened any sort of window and I can't figure out why. I have tried uninstalling and reinstalling both the game and client, I have installed it on an external and internal hard drive and I have tried using the "VCRedist" but nothing worked.

  • krvpt.
    63 posts

    @lathby been waiting 23 days, this is lovely

Suggested Topics