ubisoft forums

Quick Suggestions

  • heathermasons69
    3 posts

    I'm STILL having this issue 3 months later and it's just insane at this point. People with this glitch cannot continue progressing in the game. The patch notes clearly stated this issue would be resolved, and it did nothing. What is so hard about this bug that it just can't be fixed?

  • ptrusler
    2 posts

    I too am still unable to progress any further in this quest. I am stuck at roaring meg's spring where I am supposed to investigate the scene, but there is nothing to investigate and the key required from the bottom of the waterfall is not there. There are also no markers on the map anymore.

    I tried to skip ahead to what walkthroughs say is the next part of this story mission but I am confronted with another missing key which I assume is because I have not triggered the required events from Meg's Spring.

    I have no other regions to pledge too so I am at a loss as to how to complete the story missions. Very frustrated I have played 75hrs with no sign I will ever be able to complete the game.

  • VictorMelfman
    11 posts

    So come on then Ubisoft, let's have an official response please. You say you've fixed one of the bugs with this quest, so which one was it please? And when are you going to fix the rest of them? Do you even care? Please just keep us informed. If it's proving difficult then say so. You can help manage my expectations by sharing information with me. This silence from you only serves to fuel the anger and disappointment. Please be more forthcoming with your progress.

  • Aerial_Arts
    29 posts

    anyone else having this lovely issue of npt being able to submit anythng to the support?
    i had the submit a ticket thing there, then the site updated and "blop" gone...

  • Aerial_Arts
    29 posts

    in regards to my previous post about the support page not giving me an option to submit anything.
    Here's the message i was going to send in.

    @Ubi-Woofer you previously responded with being able to open up a ticket on your end so i hope you're able to help in this regard here as well.

    Support message:

    Hi, i've tried to submit a ticker a few times now without it actually getting sent in. Swedish page keeps sending me to the uk support and then when i submit the case, the page just drops and restarts, and now last try it just removed the option to submit anything.
    But hopefully we'll get through at some point. 

    First up the issue with ac valhalla " in the absence of an ealdorman" quest that is NOT fixed even though according to the patch notes on 1.1.1 it should have been. 

    So my question at this point is what's actually going to happen here?, 
    i do think that this does qualify under "faulty product" regardless of it being "activated" played or a digital item. So refunds of the game or partial compensation. are in fair order for anyone affected by this issue. 

    Also i'd like to aske about refunding my compy of watchdogs legion, not downloaded, activated or whatever other thing we can dream up as a reason to not refund. 
    This is in no regard to that game, just that until propper customer support and transparency has pretty much convinced me to give up on ubisoft as a developer. 

    so after more that eleven years of loving this company and the games and franchises you produce. Unless you're willing to meet us customers at what at this point can very generouly be considerded a half way point, 

    I'm done.

  • SBHeathcote
    13 posts

    @pixe1pimp I dont understand why forceclosing wasnt the immediate hotfix, considering it softlocks the main story progression.

    We're now at 59 days since report on the boards with not a single credible reason as to why its not been resolved. submit a video? we cant replicate it? oh my.

    Im just posting because the patch notes said they fixed an issue with the quest. god knows which one they fixed because Im still softlocked.

    See y'all in another two months? 🤡

  • Mathias_PL
    3 posts

    Still bugged after 1.1.1
    Congrats Ubisoft!

  • rustynailz121
    18 posts

    I can confirm this STILL is not fixed... thanks. Guess it’s back to playing something else ugh!

  • gladjag57
    7 posts

    Ditto, logged after update, went to quest destination to return Brooch and there are still standing around with no interaction option and i have the Brooch in my inventory. What a disappointment once again good Job UBI.

  • Pollitt-_-
    1 posts

    So ive had this game pretty much since like a week after release and about a month ago i started a quest called in the absence of an ealdorman which i was supposed to collect a brooch but cos i collected that item before the quest as i already explored the room earlier in the game it bugged out and wont let me contine with the Lincolnshire questline any further, i thought id wait it out til the next update hoping it would be fixed but a new update has came out today and i still cant finish that quest, just wondering when your gona plan on fixing this instead of wasting time releasing fancy new items in the store for your profit only, as ive waited way to long just to complete 1 quest

  • linaraoul
    3 posts

    @pollitt-_ same here!

  • linaraoul
    3 posts

    @guest-gcend0so same here!

  • LoudAssassin410
    10 posts
    This post is deleted!
  • LoudAssassin410
    10 posts
    This post is deleted!
  • Trickster_Plays
    4 posts

    Update 1.1.1
    Still has NOT fixed the issue with ealdorman quest and the quest item which is a silly little brooch that is not letting a mighty viking to progress in the main story line or level up the settlements.
    More than a month of waiting for this one little issue and its still not fixed.
    Instead the dev team is fixing how a quiver should look on the character?

    how hard is it to fix a quest item to reset to its original location or how hard is it to make the quest item to go from characters inventory back to the quest related location so that the main story progress is not hindered?
    How bout if they could fix by giving a option for quest reset so that we can start the specific quest again which would have all quest related items also reset to its original positions.
    So much frustration.
    Correct me if Im wrong.. this valhalla was made by same team as the ones who worked on origins?

    Just give a reset option for the specific quests so that everything related to the quest and its quest items to progress is reset also to its original positions and we can get things done.

    Cant really try to be polite even though I have the option to delete my words and rewrite them to be more pleasant. But why should I suffer all the mental stress and frustration even after paying such a high pre order price for this game.

    Completely disappointed.. (like they care).

  • captainjack03
    13 posts

    @ubi-woofer Thank you for the reply.

    I have created a ticket with a video and my save files. Please let me know the next steps.

    Thank you.

  • VictorMelfman
    11 posts

    Has anyone started a brand new save file and had success completing this story line? If you don't pick up the brooch early, can you complete the quest? I don't want to start all over again if the quest is still going to fail.

  • UnbidEu69
    1 posts

    I am on Xbox and I picked up the Brooch when I should have, the quest marker was there when I picked it up, then I logged off and got back on later and the quest marker was gone, and I still have to Brooch in my inventory.

  • dyauman6692
    1 posts

    @pollitt-_ also stuck in this quest forever. I cannot proceed with the story game

  • DonFurinkazan
    10 posts

    Hello @ubi-woofer,

    I'm on PC and experiencing the "There are no corpses to examine in the sewers" issue. I already opened a ticket to the support which was closed (who knows why). Btw ticket number is 13448809 and I provided everything needed to reproduce : save files, screenshots, MSINFO and DxDiag on this ticket.

Suggested Topics