ubisoft forums

Quick Suggestions

  • KAMLiOo10
    11 posts

    ok now this unbelievable !!!!
    you are the worst dumb developers i have ever see !!!
    i will say it again you are just a pinch of children controlling us .. and the shame on us for trusting you !!
    every issues you have fixed was not preventing players from completing the game except this one !!!
    more than three months without fix a number 1 priority issue ..
    i am a doctor and it's really hard to have any time to play ur game ! although of that i played more than 90 hours playing time literally for nothing at the end !
    you always talk about policy and terms and you never had them
    i will write on every social media accounts i have and every site for community rights how this company is really disgusting..

    thanks ubisoft you have lost us forever and hope you will lose all of ur community in future

  • Killgore1981
    21 posts

    I preordered this game and played it at launch. I'm sitting at 158 total hours as I've gone around doing absolutely everything else possible waiting on patches for In the Absence of an Ealdorman, the main storyline in Lincolnscire, and they never happen. It's been months. This prevents me from continuing the story and also gates me from numerous trophies. Contacted a GM and they basically told me to sit and wait and HOPE that maybe some future patch will fix it. I'm not holding my breath.

  • imcrazyblah0
    17 posts

    @poisonakuto let me know what you find out

  • imcrazyblah0
    17 posts

    @optitron82 i will join that.

  • imcrazyblah0
    17 posts

    wow. why did I even get excited that this patch would fix anything. ubisoft is truly playing us for fools now.

  • Mathias_PL
    3 posts

    @ubi-woofer After patch 1.1.1 is worst then before. Pre-patch I could start the quest from the beginning. Now I have not even quest mark at pledge start cause I've loote brooch too early. Congrats 😞
    109 hours/84%

  • SordidMeerkat14
    6 posts

    @aerial_arts got the new patch today and it still doesn't work.

  • Bakarly
    1 posts

    Well same here still I have been trying to fix this using reloads, fast travel, closing and starting app, another load but to no use.
    Fix this crappy game. Of all the Assassin's Creed games this is by far the one with the most bugs and unfixed bugs still after 4 months. You developers should be ashamed of the lousy work you have delivered to this community of AC players.

    I expect that at least you will fix this within a week. With over 150 hours played I will not start everything again and then this will be the first AC that I will not finish....shame

  • WErPSU4ever
    10 posts

    @ubiexcellent with the new update today I still have the same issue and can’t continue quest

  • SordidMeerkat14
    6 posts

    Absence of an Ealdorman still isn't working!!! I still can't progress after I get the broach. On top of that, Eivor is still repeating his lines and I can't finish the Jorvic, Essex, and Lincolnscire pledges. 😠😠😠

  • SordidMeerkat14
    6 posts

    @poisonakuto one would think an unplayable game would fall under their refund policy.

  • Symitri
    3 posts

    Just adding in with the others that after the patch, this still doesn't work - my quest's next step is still empty, I'm unable to interact with anything in the dungeon room, and unable to move forward in the quest. Have tried getting out and back into the animus, deactivating the quest and reactivating the quest, still nothing. Genuinely disappointed.

  • Jamie002020
    8 posts

    Why even claim its fixed for a second time when it's clearly not fixed? I would prefer the truth like "we're sorry we can't fix it" than another let down of which I wasn't surprised even if they just updated so that we could start the whole quest again and and travel to the castle collect the brooch I don't think anyone would even mind that. But having no solution to this for months now is a joke and I know they don't care because there are thousands of people voicing this same problem.

  • MGPanda
    2 posts

    @ubi-woofer Listen, I've been checking out this thread for a while now, and I've tried to stay calm and not put the blame on the developers because I know that fixing a game this huge is not as easy as it seems. That said, we will need compensation after this. It's been more than two months since the last time I was able to actually play the game, and I couldn't even play through the Yule Festival timed event because I didn't really know if it was worth grinding through something for a save containing a game breaking bug that might never be fixed.

    We are being patient, we really are (some more than others), but today you pushed a patched that affirms that's fixing this specific issue and... Yeah, it might be fixing it, for 5% of the people in this thread. The rest of us are still stuck and with no ETA whatsoever for the next possible fix. When Unity came out, you didn't hesitate to give away the Season Pass for free, as well as a voucher for people who had already bought it, but that's not the case with Valhalla since the game hasn't gotten the bad press that Unity did.

    Please understand our situation, I've been a huge fan of the series since its very beginning, and it's heartbreaking to see that I (and hundreds of other players) are unable to keep playing the game that, in a lot of our cases, we spent more than 100€ on. I'm not asking for a refund since, let's be honest, I've sunk around 110 hours into the thing already, and I intend on playing much more if the game is ever fixed, but I am asking for a compensation of some sort. Hopefully you'll give us an actual response and not just keep asking for more saves and video proof, since this has to be one of the most infamous bugs I've seen on the series so far.

  • Aerial_Arts
    29 posts

    installed patch 1.1.1 and... Still nothing... So far there is no change in the status of anything related to this quest.
    Tried switching pledge and the switching back, Did Nothing
    Going through all of the quest locations to see if anything had been reset up to a certain point etc, Nothing

    How hard would it be to just add a condition that just checks for the brooch in your inventory and then moves the quest along.
    Or just simply add an option to reset the quest, incl the items.

  • Aerial_Arts
    29 posts

    @mgpanda I completely agree

  • SordidMeerkat14
    6 posts

    I haven't seen anyone else talk about these, but here are my may
    In quest bugs aside from the ealdorman one. In Jorvik, when Eivor meets up with his friends after the fight, the dialogue doesnt prompt and allow me to go back and report to Randvi. In Essex, the dialogue with Rollo doesn't prompt after getting him out of the brothel. I haven't dared try Suthesexe yet because I've heard there were issues there too. 😠

  • HateYourFace69
    10 posts

    My issue is the mission just dumps. Progressing with the mission when I reach LIncolnshire my mission icon just disappears. I have not obtained the brooch and going downstairs doesn't activate a cut scene and no investigate markers appear. Just nothing and picking up the brooch doesn't progress the mission. I have tried using an earlier save and reinstalling my game to no avail. Every time I try this mission it just dumps. On Xbox one.

  • Apestront
    4 posts

    Perhaps it's no use for me to also reply to this post, but better every case of reporting the gamebreaking bug: stuck at the part where i have to hand in the broach. Picked it up in the dungeon as I was following the questline. Got the quest marker to hand it in but when i fast traveled back to Lincoln, the quest marker was gone. Hunwald is standing with his companions in a circle like a bunch of nitwits, and no interaction with him possible. Thus ending progression. 2 months of not fixing this bug...yikes...

  • Pixe1pimp
    1 posts

    Hopefully the devs just decide to force close the quest in the next patch, because there looks like there are several issues all resulting in the same problem, which is just wasting their time and eating into the profits.

    My game bugged out after I followed the storyline and looted the brooch as part of the quest, not before, and never gave me the option to hand it in once that part of the quest had been completed.
    After the patch today, I have had several more unrelated bugs that I never encountered before so will again leave the game until the next patch, and continue on with Cyberpunk. Cheers team, look forward to 1.1.2 in 3 months time 😂

Suggested Topics