ubisoft forums

Quick Suggestions

  • PaleHorse67744
    2 posts

    It has been months now and two patches have claimed to fix this game breaking bug. Patch 1.1.1 did nothing to fix it. I am still stuck and cannot return the broach to Hunwald. My game did not crash, after receiving the broach I had stuff to do, so I saved the game and when I came back and reloaded into the game, the quest marker disappeared from Hunwald. And now no matter what I do, I cant finish the quest. I have tried everything. How hard would it be to put a mechanism into place to be able to restart quests? Other AC's have had this function, why doesn't this one? I haven't played this game in more than a month because I cant proceed with the story line. If we had a mechanism to restart quests it would solve a lot of these game breaking quest bugs. Especially the ones that don't happen all the time.

  • Comocai
    2 posts

    Can’t finish the mission. I guess that I picked up the broach before the mission and now I can’t proceed. Please help.

  • Atlan.
    1 posts

    I have the same problem as most of the people. I picked up the brooch while exploring before i took the quest "In the Absence of an Ealdorman". Since the game isn't on steam, and i do like my steam achievements i decided to give Ubisoft+ a try and buy the game once it's sold on steam. I could have played the game with the first month subscription if i wouldn't have been blocked by this lovely bug. When you announced that the bug is fixed I subscribed for another month just for seeing that you didn't do as promissed, thus I've wasted another month of subscribtion without even playing the game. To be honest that feels like being scammed.

  • Alexia_8
    4 posts

    I'm in Lincolnshire and currently on the Mission "In the Absence of an Ealdorman" and I'm stuck..I can't return the brooch to Hunwald it doesn't let me it doesn't even show me the track blue mark anywhere in the map..
    I close the game and open again nothing, I tried other saves nothing, I did other stuff in the game nothing, I even went in the house where Hunwald is and still noting....
    I'm very upset because I can't continue the game like this.....
    What can I do, is it a bug or I've missed something??!!!

  • Denizen777
    1 posts

    I'm having exact same problem. I'm playing on PC with latest patch as of 2/4/2021 (1.1.1?)
    I never picked up the brooch before. I didn't enter the castle before this quest.
    When I enter the basement where the brooch is found and what looks like the dead Ealdorman, with the woman taking care of the body, I get no cut-scene. Nothing. If I pick up the brooch, I get a voice-over from Eivor that "this should be enough." But the quest marker does not update back to the son who's waiting in Lincoln.
    I'm stuck and cannot progress.

    There is another, longer thread on this bug on Reddit as well. It seems like many people have this problem.

    Thanks Ubisoft for getting this game breaking bug fixed soon.

  • Alexia_8
    4 posts

    @denizen777 let's hope they fix this..I'm a devoted player of AC and I play a lot of games from Ubisoft so I will be and everyone will be very disappointed with them...I will try some other stuff if they work I will text it..

  • SBHeathcote
    13 posts

    80 days since report

    ...because Ubi doesnt have any fun news for us, I thought I'd share this fun fact;

    On November the 4th, 1889, Nellie Bly left New York on a 24,889 Mile journey around the world. After 72 days, 6 hours, eleven minutes and 14 seconds, Nellie arrived back in New York and claimed the world record for circumnavigating the earth.

    I mention this amazing feat, undertaken by a woman in the 1800s, not just because it was done in less than 80 days, but also because she visited a leper colony and bought a monkey, two other things we cant do in Assassins Creed Valhalla.

  • FreelancerND
    4 posts

    I think we all might congratulate UBI, they officially made themselves look WORSE than god damned Bethesda and Fallout 76.
    Ignoring main story game breaking bugs in a story driver single player RPG for almost 3 months, that's a sight to behold. Well done!

  • Alexia_8
    4 posts

    I didn't fix the problem with Lincolnshire about the Mission with giving back the brooch to Hunwald..but I did the next best thing fortunately I had some previous saves and I load one of them..it was unfortunately way behind from the story of Lincolnshire and ofcourse I lost everything when I load this way back but I manage to do all of the things I did before again and when I get to do the mission about the brooch it didn't stack thank god and I manage to get past this point...so I'm playing ok now and I'm saving as much as possible from now on (I currently have 16 saves)...
    So I suggest doing that and before you do any searching for mysteries and treasures you do only the blue marked stories first and then explore on the map....
    Ubisoft ofcourse needs to fix that but until they do don't go explore before the story unfolds in every alliance you go...

  • RBradigan
    11 posts

    I can't take this anymore man.... this should be illegal or something right? They are not helping thousands of players who literally cannot beat the game, and yet they won't refund or help any of us. Something isn't right here and action needs to be taken. It has been 3 whole months now.. 3 months without a single answer. There is absolutely no way it takes them 3 months to fix one buggy questline. So much wasted time and money for all of us. This is complete robbery.

  • guest-tJxL99et
    2 posts

    New the this forum and I could see that I am not the only 'lucky' customer who is now stuck with a un-finishable game. AC Valhalla is one of the buggiest games I've ever played. (By the way, I am on PS4). I don't seem to see any PS5 players reporting this issue (point it out if I am wrong, thank you). I wonder if Ubisoft just couldn't care less about PC /PS4 code when PS5 is the now hot console.

  • Comocai
    2 posts

    @ubiexcellent I system did not crash. PS5.

  • PoisonAkuto
    17 posts

    Hello everyone,

    it’s been three months now and we obviously aren’t getting any help. This is absolutely shambolic treatment of loyal paying customers by Ubisoft. But sadly, it seems posting in these forums, uploading saves doing everything they have asked is getting us nowhere. Again, it’s been THREE MONTHS.

    So I have a favour to ask. Something that could help all of us.
    please join me in reaching out to as many game journalists as possible. Detail your issue and this gross malpractice from Ubisoft, please also link this thread in your email so said journalists can browse the complaints, awful staff responses and see for themselves the tragic timescale this simple fix is taking.

    I have listed a few of the major ones here with contact info:

    IGN - https://corp.ign.com/contact: (https://corp.ign.com/contact) (please select news tips and content)
    Game Informer - https://www.gameinformer.com/writetheeditor
    Polygon - https://www.polygon.com/contact#tip
    Eurogamer - https://www.eurogamer.net/contact

    if you have any other suggestions for journalists to contact please list them in reply.

    Lets get this issue into the eyes of the mainstream media, let’s bring Ubisoft the heat CDPR got, maybe then they will take notice, maybe then they will care. Let’s get their reputation on the line. They don’t care about us. It’s time we treat them with the same respect back.

    Thank you.

  • GORT_Klaatu
    2 posts

    Still not working. How many months we have to wait to finish the main story?? It is disgusting ...

  • GORT_Klaatu
    2 posts

    Usually I don't experience major bugs in games, but this time it is annoying. Same problem as mentioned above, I can't progress.

  • Ubi-Viral
    2366 posts

    Hey, folks!

    We've received reports of players who are unable to complete the quest "In the Absence of an Ealdorman".

    The development team has been made aware of this issue and they are currently investigating it. Once additional information becomes available, it will be posted on the forums.

    If you're on PS4 or PC, we would appreciate if you could also forward us your save files. You can find further details on this via the link below:


    We apologize for any inconvenience and thank you for your patience and understanding while we work to resolve this issue.

  • Maybe2Maybe3
    9 posts

    I'm using a xbox one x and I'm also not able to progress with "In the Absence of an Ealdorman. To be clear I did not pick up the broach prior to starting the quest. I did explore the area and picked up the Focus of the Nornir ability, but was not able to explore the room bellow as it was locked. I don't recall any crash while doing the quest. After picking up the broach, the only thing showing in the upper left corner of the screen is "in the Absence of an Ealdorman" and I'm unable to progress any further.

    I had a save game prior to starting the quest and have tried the quest several times resulting in the same issue. Prior to picking up the broach the area in the upper left corner shows a blue banner with EXPLORATION AREA, "In the Absence of an Ealdorman" in green font and an action statement "Search for proof" in white font. After picking up the broach, the upper left corner shows only "In the Absence of an Ealdorman" in green font.

    I also noticed the item that looks like a small scroll on the right side of where the Focus of the Normir was. The prompt is to collect this, but it does not seem to do anything and does not show up in the inventory or as a clue in the order tab area.

    I have also run into several other issues like broken world events and annoying dialog hints that repeat every 5 to 10 seconds and follow throughout the world, but this one is game breaking.

  • TheLyngs99
    2 posts

    I just got the medal in the quest '' in the absece of an ealderman ''
    be sweet and do something about it,

  • TheLyngs99
    2 posts

    I just got the medal in the quest '' in the absece of an ealderman ''
    be sweet and do something about it,

  • Asgardian02
    1938 posts


    just reload an older save

Suggested Topics