ubisoft forums

Quick Suggestions

  • ImPsychoNinja
    1 posts

    I have the same issue on PC. In the quest menu it tells me to search the area but I can't search for anything and there's no marker on my map. There's no way I'm gonna load an old savegame from 7 hours before. Please fix your game breaking bugs this is annoying as hell. Had same issues in Origins and Odyssey.

  • morehumphrey
    1 posts

    'In absence of Ealdorman'. So what is the fix because currently I cannot submit a case on your site as it it will only show the chat tag but tells me it's unavailable. I cannot progress in the storyline because I can't give Hunwald the brooch

  • rustynailz121
    18 posts

    Can we get some type of update if this will be fixed during the next patch?

  • imcrazyblah0
    17 posts

    cdpr release a hotfix for a bug that was part of their last patch in roughly 4 days. this takes 2 weeks to get a response saying nothing is happening.

  • PoisonAkuto
    17 posts

    This quest isn’t listed in the Feb patch so don’t expect a fix next month... or anytime soon. Absolute joke now.
    go on ubi, give us an official response again about how you’re investigating and it would really help if we uploaded our save files. How many Save files do you need? I can recreate this bug as many times over on a new game, it is broken. I’m gonna break it down for your expert dev team so they can recreate it too. Please send this across to them:

    a) head to the castle chamber (before starting quest) pick up the brooch from the floor.
    b) begin the ealdorman quest
    c) follow the quest until you reach the chamber - watch cutscene.
    d) your quest is now bugged. You will be tasked with picking up the brooch, you already have it. The quest objective will disappear.

    Boom. Bug recreated.

    please let me know if your expert dev team fail to follow these steps correctly, I will dumb it down even further if need be. Alternatively, if they would like to upload their save files in which they are struggling to recreate this glitch they can do so. I’ll get back to them within the hour and let them know what they’re doing wrong. (i suspect they simply aren’t trying) I've found one of the best ways to recreate this bug is to follow the above instructions in an attempt to fix the game, rather than work on shiny dlc armour. Bizarre concept, I know; but new armour sets don’t seem to solve the issue at hand, so if you could prioritise the above steps that would be great.

    Please let me know the results of your findings, I eagerly await your response. Should the bug recreate itself - which it will. Because your game is broken. And this bug happens every time you follow these simple steps. You can then proceed to fix it, and stop asking for Save files, which of course you will no longer need. As I have now given you the resources and ability to generate an infinite number of broken save files yourself. Kind of me I know, I wish your expert dev team had worked just as hard and we might have gotten somewhere in these three months.

    much love to all the Ubisoft crew, especially your hard working, resilient and expert dev team.
    can’t wait to see the results.

    Your loyal* paying customer
    Poison xx

    *not anymore

  • LoudAssassin410
    10 posts


    same, I replicated the bug no problem on a different save when they initially said that they couldn't reproduce it last month, its been 2 1/2 months now without a fix that I just want them to force end the quest at this point.I've looked up the ending of the quest and the game(sucked [censored] in my opinion).I have invested alot of time, materials and skills in my first save to start over again so ill settle with just skipping the quest if I can. I said it before and I'll say it again, [censored] UBISOFT you owe me and everyone on here compensation for putting up with your [censored] deceitful buisness practices & your buggy [censored] game.

  • Kristharipper
    3 posts

    I have 13 videos of the glitch bug recreating the mission or backtracking steps , videos they asked for. But after over 2 months I cannot fathom the fact they need more evidence.
    I’ve gone into the other arcs. I am level 400+ With over 30 master points. Over 250 HOURS played mostly due to the fact I have to find minuscule things to do while waiting for a main story progressional bug to be fixed. The fact I can’t finish this game I’ve invested time and money into, I finally receive my next gen console and refuse to break it with this game.
    The ignorance and betrayal...from inquiry below and beyond it seems a lawsuit to come before a fix. I feel sick.

    @poisonakuto should I even bother joining everyone by opening a new case support ticket over this. We are investing more time on this than anyone it’s disgusting. Literally we are prevented from finishing their game, including the loss of our money during such a crucial time, and most definitely should not have to restart the game after 255 hrs played and everything along with it. How is there not a lawsuit here like Cyberpunk? And wait, I haven’t heard that game had main story line bugs or inability to finish it? So sad because I do desperately want to finish it. I have enjoyed it. But this easily has diminished any positive feels I ever had.

  • Kristharipper
    3 posts
    This post is deleted!
  • FearlessReject
    3 posts

    I don't agree with the unnecessary vulgarity and insults from me fellow gamers, but as somebody who preordered the ultimate edition and dumped hundreds of hours into the game, I definitely feel the frustration and impatience after about 3 months post release. When I see paid dlc skins being released while a bunch of us can't even beat the game because of a well-known main questline bug, it does rub me the wrong way as a lifetime Ubi-fanboy. Is there no way to just make it so we can reset missions, or maybe you guys can just break it for us so we can at least progress? There has gotta be some way to fix this, even if its jank, so we can beat the main story without resetting completely lol. PLLLEEASSEEE ubisoft. I was mad when yall killed Desmond in 3, but now I'm genuinely heartbroken.

  • GeneticV8
    2 posts

    There is no reason to think anything except a petulant dev staff at Ubi is punishing people for "abusing" a bug in their game, and they simply don't want to fix it. I avoided ALL guides and spoilers, found that a skill let me open doors, and assumed that was by design. So honestly, you people are truly uncool to leave us swinging in the wind like this.


  • rustynailz121
    18 posts

    @kristharipper yes open a ticket! If we pester the [censored] out of them then maybe they’ll fix this damn problem!

    I’m literally opening a new ticket complaining about the quest being bugged as soon as they close my old ticket out. I don’t care if I annoy them to death! Maybe they will eventually get the hint...

  • rustynailz121
    18 posts
    This post is deleted!
  • saikopk
    2 posts

    so disappointed

  • ShrillSmile
    1 posts

    Just posting my issues here also. I see that several have the same problems. Platform Ps4

    A) After going through the sewers in "the missing ealdorman" i can see the door but can't get in. The key is not there either and the three dead bodies neither. So i can't get any further. I guess this might be due to that i have been down this cave before and outside the story. I remember i picked up the key that time but "in story" this is now missing and i am in a deadlock.

    B) I have the same issues as others when trying to escort hhe dude to the docks in the next story. I get to the docks and see my goal but nothing happens so i cant proceed there either.I actually started that story before the Ealdorman thing but dropped back to Randi when i discovered i was way low on power. So i ran through a couple of other stories to get my power up to around 230 and then started the Eoaldorman. When that failed i went back to the convoy and it stopped there to.

    There must be a fix to this . Seems to me like the game wants me to do the game in a special sequel. If you roam for free you might end up messing the storyboard. If i had known that before spending xx hours i would have done the stories and then free roamed after.

    I am leaving this game. No point in proceeding. Might come back if a permanent fix is available. Have done several Ubisoft games over several years starting with the first Tomb Raider. Never experienced anything like this before. Not happy.

  • RockhatAlencar
    1 posts

    I MIGHT found something of a workaround, depending on your problem.

    In my case the investigation in the Springs didn't trigger. We all know about the brooch issue, but I had yet to explore Bolingbrook Castle. However, I did receive Ceolbert's brooch in Sciropscire after the Cent arc which I had just completed prior.

    It seems like even Ceolbert's brooch had the same effect. Either that or reloading to an earlier save worked. Hopefully this will be of use to someone.

  • downloadtaky
    19 posts

    So i tried to load my savegame on Nvidia Now, hoping that something would change (usually I play on PC) and...surprise surprise the bug is still there.
    How long will it take to fix it? I litterally have nothing else to do in game. (actually I should go fishing with the baker but it is also bugged).

  • HateYourFace69
    10 posts

    You guys suck! Just fix the ealdorman problems already.

  • tuayang
    1 posts

    Any updates or fix to this problem. I did the same thing everyone else on here did. I keep going back everyday just to see if it's fixed. Still seeing a clue symbol on the table, but no clue. I've decimated the Bolingbroc Castle several times. Fix fix fix.

  • Gwyl0
    1 posts

    @ubikobold My system/game did not crash.

  • MasterSylverMan
    1 posts

    I play on Xbox One. I did not find the brooch early. I found it during the quest. I know where I have to go to return it even though there is no marker on the map. I cannot interact with Hunwald to give him the brooch. It still says that it's my active quest but I am not able to complete it.

Suggested Topics