ubisoft forums

Quick Suggestions

  • KillerEliteXQc
    1 posts

    i get massive frame drop whenever i move my xbox controller while playing ( i am on PC). all drivers are up to date (bluetooth,wifi,controller drivers too)..had the same problem with Odyssey but the problem went away after a certain update...

    Same thing with one of my friend...we have the same pc build

  • NightHawk29
    16 posts

    So, for me using Xbox One controller have these same issues with constant and random disconnect/reconnect causing severe lag as it's trying to switch between m&K and back to controller but I also noticed that when Valhalla starts up that my controller turns off. Happens 100% of the time and ONLY with Valhalla. Odyssey no issue, Fenyx has no issue and every other non-Ubisoft game I tried has no issues and it is literally Valhalla causing the controller to completely turn off as the game loads up.

  • guest-hYbPYc6Q
    1 posts

    As if the game wasnt dog [censored] enough. Ubisoft are a joke. It's glitchy, runs poorly and now it can't connect to the new controllers. Jheeeeez. The amount of profit you dudes make, you'd think gamer experience would be a priority. Is anything being done to fix this? Or have we all spent money on a new game, and new controller only for it not to work?
    Also, whoever created the Builder to be so [censored] impossible to beat, needs to go work for homeland security. They wasted on video games.
    Can't wait for rockstar to bring out a proper RPG.
    Sorry for the harsh words, needs to be said.

  • dcGColts
    12 posts

    @killerelitexqc you gotta set controller only in settings instead of Hybrid the lag is from input switching.

    3 posts

    Just an FYI for people encountering this issue currently, I was able to fix this by updating my controller. Specifically for the series X controller. In order to update it, you must have the Xbox accessories app, and also a cord for the controller to connect directly, or the Microsoft controller adapter for wireless updates. After I updated the controller through the app, I no longer had any connection issues.

  • Jurld
    17 posts

    I have this same issue using an xbox one controller in wired mode. I've had this controller for years and it has worked flawlessly in all other games. It runs fine most of the time, until I get into combat. And sometimes in combat it is fine.

    When it starts misbehaving, sometimes I can unplug it (and the overlay notes that I did that) and plug it back in (overlay notes that as well) and it will go back to working. Sometimes permanently but usually for only a few moments. Sometimes it will never start responding again.

    At one point I thought maybe it was detecting the mouse moving or something causing it to try and swap, so I moved my mouse away to a place where it would not be jostled and this seemed to solve it for a few days. I was happy! But this morning it is right back to doing it again... the moment I get into combat the controller stops responding.

    Sometimes mouse and keys stops responding as well. Only option at that point is to hit the windows key to pop up the start menu and kill the game.

    Hardware surpasses minimum specs, drivers and OS are up to date, as is firmware on controller.

  • Jurld
    17 posts

    After fighting with this several times, including once when I loaded the game and it refused to recognize the controller straight away, I decided to investigate in Windows again for drivers or other updates. I noticed that the controller was not being recognized by the Xbox Accessories app. The controller -is- pretty old now so maybe it is time to try another...

    So, I swapped to a newer version of the xbox one controller (I think this was is one that came with my xbox one x). I found that this one connected and disconnected every time the controller vibrated. I turned vibrations off and it stayed connected reliably.

    So, beats me. It kind of feels weird playing without vibrations, but I guess that's what I'll have to do from here on out. Will report back again if it fails any more.

  • Jurld
    17 posts

    And it failed again. Even with vibration turned off, it intermittently just stops working, and unlike the older controller, unplugging and re-plugging it doesn't seem to do anything, ever.

  • Husain.87
    1 posts

    I am facing the same problem with AC4 Black Flag, once I did something like stealth assassination the controller turned off and on. I have updated the firmware and I have the latest Windows 20H2 update, I am connecting the controller via my motherboard bluetooth.

  • heliocron
    3 posts

    The "launch the game from Steam" trick was working for a few days, but last night that ended. Now having to use a "wired" controller.

  • smileyjo999
    1 posts

    @aiqlee This solution worked for me perfectly. I don't launch Ubisoft connect anymore. Just launch the game through steam.

  • webjunk1e
    1 posts

    @gonsaaa I just ran into this. People have hijacked the thread talking about all kinds of other issues, but this is a straight up Ubisoft Connect issue. I have no problems playing games with my Series X controller from Epic, Steam, etc., but in Ubisoft Connect, constant disconnects.

  • alex04634
    2 posts

    @gonsaaa I'm having the exact same issue on both ac odyssey and valhalla. Game is pretty much unplayable and it keeps getting more frequent. Now it's happening during game play and not just the menu and skill tree.

  • palniok
    3 posts

    I have the same issue. I even bought 3rd party bluetooth 5.0 receiver (I thought maybe it's the motherboard's implementation issue), but it still disconnects. AC: Valhalla is the ONLY game it happens and my symptoms are 100% identical to yours.

    I would add that it started to disconnect during cut-scenes... like right before a fight with [ xxx ] after conquering Cent.

  • palniok
    3 posts

    @ubi-woofer , in addition to above, answers to your questions below:

    • Which model of controller are you using? Is it an Xbox One controller or an Xbox Series X|S controller?

    Xbox Series X controller

    • What are the specs of your PC in brief? (CPU, GPU, RAM)

    Ryzen 5800X, 32GB RAM, RTX 3070, MSI X570 Unify, ASUS USB-BT500 receiver, Windows 10, latest versions of OS and drivers

    • Is your control input method set to exclusively controller, or hybrid?

    Hybrid, I can switch between K/M and gamepad.

    • Do you have any other bluetooth devices or input devices connected at the same time while playing? Have you tested with these disconnected?

    No. Only the gamepad.

    • If connecting the controller(s) to your PC with a wire, do the issues persist, or are they resolved?

    It works like a charm with a wire, but it's very unconvenient for me and I don't want to use the wire.

  • Prometheus-CO
    19 posts

    This issue was fixed for a bit last week but on Tuesday 3/23/21 it started acting up again. I have tried xbox one x, series X and Elite series 2 controllers and still the same issue. I have opened a ticket with support and they directed me here and told me that the developer team is aware of the issue and there is nothing they can do.

  • palniok
    3 posts

    Looks like the latest patch to Ubisoft Connect fixed it for the most part. I had only one disconnect in one of the menus. Before that the gamepad disconnected while going into the skill tree - it does not happen now.

  • abostaca
    1 posts

    Xbox One controler on PC keeps disconnecting, same issue, ONLY in Valhalla game. I just bought to play this game with a controler. Maybe i should have read this before. Trash, been charged twice from the card as well. delete account.

  • zaryuta
    1 posts

    Mine xbox one and series 2 controllers keeps disconnecting too on Windows 10, only in Valhalla, no other games affected.

  • Aajaxx
    1 posts

    The X, Y, A, and B buttons will stop working with 2 different XBox Controllers either by BlueTooth or Wired when running River Raids. All the other buttons seem to work, but X, Y, A, & B are by far the most important. This can happen 30 to 60 minutes into the raid.

    I have a little different problem with my XBox Controllers used on my PC. Both controllers when used on River Raids in AC Valhalla will surprise me during battles with the X, Y, A, B buttons not functioning. All other buttons work, I can run, watch my allies die around me, but I can't administer aid, I can't defend myself, or attack and the very worst is I can't get away and save my progress in the raid.

    After starting three failed raids last night, Jomsvinkings will shy away from joining me, my current ones will mutiny. Worst yet, I can't raise an arm to defend myself.

Suggested Topics