ubisoft forums

Quick Suggestions

  • gorrissey
    5 posts

    Dang I’ve had this bug since November. I cleared the map and can’t move on. This is so dumb and I’m so bummed i wasted so much time for no ending.

    1 posts

    I have experienced this issue as well. I diverted in the process to get a chest. As soon as I opened the chest, the quest marker disappeared. I currently play on an Xbox One S. I took a capture to show what I see when I enter the Governor's Villa.

  • pedroasm
    1 posts

    I’m also experiencing this glitch and cannot progress any further. Got +70 hours playtime on PS5 and going back is not an option. Guess I’ll just leave it still until the fix comes (as if it will ever come!).

  • ll_Mr_Lucky_ll
    1 posts

    I cannot report to stowe and erke. I have attached a video of the error. The Xbox clip is the link below. Thank you

    https://gameclips.io/ll%20iTWO%20G33K%20ll/f52aa52c-f5d8-4de4-9bf1-3f1c79f5890e: (https://gameclips.io/ll%20iTWO%20G33K%20ll/f52aa52c-f5d8-4de4-9bf1-3f1c79f5890e)

  • OmiZdea
    4 posts

    @ubi-woofer is there an ETA or a work-around for this issue? It has been so long and I'm not getting any value for the product I paid for.

    I do understand the need to recreate the bug in order to deliver a permanent solution, but by this time any senior staff within your dev team/department would of thought of a workaround as well.

    Trying to open a ticket about this is a nightmare because the issue does not fall under any category in your support portal. Also the Live Chat has not been available since last week.

    I guess everyone affected is waiting for a solution or a workaround therefore I am going to ask the same question again: What is the timeline of solving this bug or when will you be providing a workaround? Please provide an objective reply so people can set realistic expectations

  • FaZe_Riceman
    6 posts

    The patch that comes out tomorrow doesn't have a fix for this? come on man

  • GroundsControl
    8 posts

    @faze_riceman yeah not too happy about that. Surely there's a way to create a temporary work around for the quest. Like interacting with an object that triggers the completion or something like that

  • RShack13ford6
    1 posts

    Same problem here and they've made it a complete nightmare to attempt to report this glitch. Apparently we all need to spam every one of their social media accounts until they do something.

  • dave11674
    6 posts

    I never saw a mention of this fix in the patch notes
    i really hope this patch has fixed the game breaking issue
    or I’m sending game back

  • Rebuildingz
    13 posts

    Another monthly patch gone by, and still no fix! Ubisoft, I get it's hard to patch things, especially when you cant recreate them in game, but shouldn't 3 months time be enough to at least find a workaround so we can play this game again? I paid 60$ for this product, a shame it doesn't work for so many of us. I expected a bit more from such a large studio as Ubisoft - I get all games launch with bugs, but now it's three months in, three *patches* in, and the same game breaking bugs that were present at launch haven't been fixed yet? This will unfortunately make me think twice about buying Ubisoft games in the future. Hope you guys get it fixed soon, I want to play this game again.

  • TitchyKitty
    3 posts

    I’ve had this issue since Nov. So instead of waiting I decided to restart the game but this time I didn’t divert and London has actually worked for me

  • guest-00LDo9O0
    1 posts

    So I loaded a save from before londen, if you go threw with the whole mission, go straight from temple to the villa. Than it works fine ( I know this is no good for anyone who continued on with game)

    Hope this helps some of ye.

  • Jeppe184
    1 posts

    Adding to the choir. Have the same problem. Cant report to Stowe and Erke, no quest marker. I saved the game right after exploring and when I opened it again no marker.
    If I have to reload an earlier save from before I pledged to Lunden I will lose 10-15 hours of time, so that is not an option.

    Any idea when this issue will be resolved?

    Kind regards


    Playing on stadia btw.

  • KT0211
    5 posts

    @jeppe184 bro I encountered this bug at 70 hrs of play and now I am close to near 147 hrs with no solution in near future,I will say loose that 10 hr play or else you will be stuck like me.

  • RiceIsNice710
    19 posts

    Garbage that there is still no fix for this. Ubisoft sucks anymore and have carelessly lost throws of current and future customers because of this game. They put this game out with what I have found to be a second game breaking bug. The first was Sons of Ragnar and now this. It’s terrible you all treat the people that supported you this far the way you have by not giving any insight other than, “tHe DeVs ArE wOrKiNg On It...” I, like many others was duped out of $120 by the old bait and switch. Needless to say, UbiShite will not be getting another dime from me, regardless of what steaming pile of poo they churn out next. Still enjoying Ghost though!

  • guest-UBU4ANep
    1 posts

    I’m currently 50hrs of gameplay in and the story line mission “Walls and Shadows” appears to have a bug. Instructed to report back to Stowe but NPCs are nowhere to be found. The objective does not appear on the map either. Ubisoft at best only seem to recommend deleting and reinstalling a game. Not even a for sure fix??? Anyone else have these problems or have found any solutions?? I’ve tried reloading previous games and all. I DO NOT WANT TO DELETE OVER 50HRS OF WORK especially if it’s not a guaranteed fix?!

  • porcupine_racer
    4 posts

    I have the same bug on PS5. Happy to upload save files or whatever, but can you direct me to a link on where/how to upload a save file?

  • abbyweeks
    1 posts

    I'm having this issue playing on Xbox One. I turned off the game for the night after finishing up in the temple and leaving. How have Ubisoft not fixed this yet!? I've been back to the temple, the governors house and found the characters in St Paul's Cathedral but it still doesn't progress and no marker for the quest appears 😢

  • Reginald_Denny
    1 posts

    I am experiencing this issue on Xbox One. No one is at the Governor's Villa, and I can still see the sketch of the man hanging from the ceiling. There is no quest marker. Reading through these comments, someone said they found Stowe and Erke in Saint Paul's Cathedral; I found them there, but there was no action available and no cutscene. Basically I cannot proceed with the arc whatsoever. Is there any ideas on how to solve this or when it will be sorted by devs? I can upload a mobile video of my gameplay, but it would appear that everyone has the same issues here. Please fix this!

  • SmolleDK
    1 posts

    I know I'll just be another one in this large choir of complaints, but... I too am experiencing this bug. I had hoped it'd be fixed in the new 1.1.1 patch, but it isn't. I probably can't contribute with a lot more than what has already been reported here, but one more message might put a little more pressure on getting this fixed.

    For me, the bug manifests itself - as for many others - by Stowe and Erke not being at the location they should be (the villa) and no quest marker showing up on my map. If I go to the villa, the blue 'shadow' of a man hanging from the chandelier is still there.

    I'm playing on an Xbox Series X and is on patch 1.1.1. I've completed all other regions that have been made available for me and have also finished (I think) the missions in Asgard and Jotunheim. Right now I'm running around, gathering collectibles, but I'd prefer getting on with the story...

Suggested Topics