ubisoft forums

Quick Suggestions

  • CA1981StarWar
    5 posts

    my only manual save is from the 40 hour mark, I’m well over 100 hours in at the point, so if I go back I lose a ton of progress, but at this point if I want to look the way I want that’s what I’ll have to do, and then not play the Mary lwyd arc until it’s fixed. But the way it’s going who knows if that will ever happen. Complete and utter BS

  • jameskdixon
    1 posts

    Having the same problem has many others. Can not remove clock . Extremely annoying for someone who enjoys cosmetics in a game . How has this not been fixed yet?

  • Roughman01
    16 posts

    Shame this glitch doesn't affect the helix store too as I bet they'd hotfix that in the time it takes me to write this. They're more interested in pushing there next new shiny armor. I was looking to get into this game and participate in events and get helix store armors, but with missing the whole yule event whilst waiting for a fix I'm at a loss. At this point I'm genuinely becoming bitter to ubisoft if this is how bugs are treated whats the point in paying for the game only for it to be pot luck if it'll work then its another [censored] shot if they'll even fix it. I'f I hadn't already committed over 150+ hours I'd of given up. What's also daunting is I've bought the ultimate edition so I've got dlc to play too (which is probably another priority over the bugs). I'm also kinda convinced they don't know how to fix it, that's why we keep getting the generic copy and paste answers every so often saying "were aware of it and will sort it in a patch in the future" I'm sorry but we want a more genuine answer, at the moment it's either in the next patch or in patch 457889975432225789. Rant over for now.

  • Mylilroshi
    2 posts

    After the merry lewd mask mission, I haven't been able to remove/change the cloak I was last wearing and the mask is permanently stuck on my head.... I've tried all the possible fixes with no luck. I've been an AC fan from the beginning but the amount of bugs in this game is really disheartening. I don't think I'll be buying Far Cry 6 new. Just not worth the money...

  • ziggurcat
    167 posts

    @mylilroshi I kind of had that same thing happen - I just brought up the wheel by holding down on the d-pad, then selected the cloak.

  • Fenargol
    1 posts
    This post is deleted!
  • fmlirl
    1 posts

    Same problem as everyone else... I am not continuing this game until it's fixed

  • CA1981StarWar
    5 posts

    Ubisoft is the Dag of the gaming world

    1 posts

    Any solution yet ?

  • VitakkCZ
    1 posts

    I also have this bug. Finished Glowecestrescire arc. It's strange it wasn't fixed yet, it's after winter event and can't rid of this terrible skull mask

  • tokajero32
    21 posts

    they need to patch it , why u ask no solution yet i dont get it. its simple . they wont patch it, it wont be fixed . when u see next patch notes and u dont see this problem in the list getting fixed then u can complain more.

  • jandraelune
    126 posts

    The Mari Lwyd cloak is awarded to you as an item that does not show up in your inventory, after this whenever cloaking up the Mari Lwyd cloak is the only cloak you have.

  • Damo_77
    15 posts

    Over 8,000 people suffering from this bug have searched out the video I uploaded to Youtube for you. When are you going to give us the fix, [censored].

  • Surcouf_Julien
    1 posts

    Hi, I’m playing on XBOX One x. I have the same problem, I’m stuck with the Mari Lwyd costume.

    The only time it disappeared is when I did the Vinland saga, but as soon as I came back to England and Norway, I was stuck with it again. I tried what others proposed as solutions, but I’m still stuck with it. It’s especially annoying when using predator bow, as all the fur gets in the way. Please resolve this bug quickly. Thank you.


  • DJAM3R
    15 posts

    Complete embarassment of a game, it's been such a long time that I honestly don't bother with the game anymore, and only check in here once a week tops.
    Goes without saying that this is the last time I buy a game from ubisoft. If I want a ubi game down the line it's either pirating or buying it at least a year after release on G2A, as it might actually be finished by then.

  • the_muzz1
    2 posts

    I was having this problem as well. I noticed though that everytime I would jump in water deep enough to swim in, it would get rid of the cloak. Thankfully it doesn't return anymore now that that quest line is done for me. I'm on PS5, in case that matters at all.

  • ToddLouis
    3 posts

    I finnish the game a month ago game was fine. All of a sudden this dam thing equipped on its own and not i can't get it off... PC

  • Warrior-Webb
    1 posts

    How has this not fixed???? It’s 8th of January and still bugged for me!!!

  • jandraelune
    126 posts

    Even after finishing the full arc and leaving the region, the Mari Lwyd cloak remains and no trick after this quest's reward will remove the cloak.

  • UbiKoreanBBQ
    Ubisoft Support Staff 392 posts

    Hey all, we appreciate your patience! This issue is getting a fix implemented in an upcoming patch.

    @jandraelune Thanks for reaching out. To help consolidate, I've moved your post into the Megathread for this issue. 🙂

    Official Response

Suggested Topics