ubisoft forums

Quick Suggestions

  • KnightofTara
    22 posts

    I am playing on the XBox One version. Ultimate Edition.

    I now also have the Mari Lwyd cloak stuck on me no matter where I go or what I do. I cannot wear the cool Native American outfit outside of Vinland. And I am also spawning drunk (since Yule Festival start).

    This is really making me angry. These problems seem pretty universal. Did no one play test any of this before release?

    No point in buying any of the cool armor sets if I cannot see it through the damn skull cloak.

    Is a Hotfix inbound? It is badly needed. Updates would be appreciated.

  • ABigAssMexican
    2 posts

    @w0ffeh go in photo mode it tends to dissapear dont know for how long tho but it did work

  • cnnryng
    16 posts

    @abigassmexican This works for me but only to remove the skull mask, doesn’t seem to affect the cloak

  • binskies
    29 posts

    I'm playing on Xbox Series X, and I don't have the issue that alot of others are having, I don't see the deer skull when the hood is down (thank goodness), but no matter what I do, I cannot get rid of it when I pull the hood up. It doesn't matter which cloak I'm wearing. I've completed the Glowecestrescire Arc and reported back to Randvi. It doesn't matter where I am in the Valhalla world, when I put on the hood that stupid deer skull is there. I've gone to Asgard and back, exited and re-entered the animus, quit the game and rebooted the console. I've researched all over the internet, and I've tried everything that I found to be suggested that has worked for other people and nothing is getting rid of it. Honestly, if there isn't a fix for this soon, I will probably quit playing altogether, it is THAT annoying. Please fix this!!!!!!!!!!!!!!!

  • ZackSpahr
    2 posts

    @th3pr1nc333 happened to me, I took it off upgraded it then put another one on then switched again, not sure what part fixed it but it worked

  • guest-vE0qB42G
    4 posts

    Ubisoft! please fix this big. I cannot get rid of the hideous cloak from the Samhain/glowchestershire mission. its really unsettling! Please make the patch so we can use our other outfits, and not the samhain cloak and mask. thank you.

  • scarlett-joker
    1 posts

    @abigassmexican What's photo mode? Do you mean selecting share?

  • lalusitana
    21 posts

    Mine disapeared when took a photo

  • Mr.Foxconn
    17 posts

    I just encountered this,, Cloak Bug,,. The Marry.... Blablabla Cloak appearence is stuck on my Eivor. I tried very strange solutions which i found on internet, but nothing helps. Hide, take on, fast travel, went to Asgard and came back, changed gender, nothing...
    Is there a solution or this is system bug?
    @Ubi-Woofer @Ubi-Woofer @Ubi-Woofer

    This problem is ruining the game experience...

  • BygoneEgg368964
    4 posts

    I play this game on Xbox one X, my main story is almost completed but I can't still get rid of the skull cloak.

    Such a great company. Ubi would rather give us lots of Merry Christmas missions that are full of bugs than fix numerous bugs that we have been suffering from.
    This fraudulent organization tricks us to waste our hard-earned money on Helix store and we can't wear awesome skin on because of this stupid skull cloak. 

    We can't even know when will it be fixed. I'm so disappointed!
    Sorry for showing my anger to the staff, your CEO and the whole management team have a big problem!

  • Merlinthewise24
    2 posts
    This post is deleted!
  • Merlinthewise24
    2 posts

    Been trying for ages, photo mode, reloading etc, hated the thing. This 100% just worked thank god!

    Fast travel to settlement.

    Unequip everything, so you're naked + Skull cloak obvs. then in inventory equip JUST your regular cloak.

    Toggle hood up, and hopefully it should glitch back like mine just did. Also re-equipped all my gear too randomly.

    Then manual save like your life depends on it 😜

    Hope this helps someone.

  • Zarilya
    3 posts

    @maxheavelar thanks for mentioning the predator bow. It's SO annoying.

  • M3W3SY
    11 posts

    Regardless of what I try it remains. Even with the cloaks unequipped the cloak remains with no ability to put the hood up but the mask is on with no hood. Even when the clock is hidden the cloak is still visible. Regardless of which cloak i select the appearance remains the same.

    Make the mari lwyd cloak a selectable cloak like the others.... like you should have done in the first place.

  • KnightofTara
    22 posts
    This post is deleted!
  • KnightofTara
    22 posts

    @merlinthewise24 Gave this method a shot. It sadly did not work for me. Glad it worked for you though. Seems you just have to get lucky. Ugh.

  • SantiagoGD11
    2 posts

    I have a bug after I complete the Mission of Mari lwyd where Eivor put on a mask to know to doors in the village, after that I still have on the damn mask, only disseappers when I remove the hood, I dont play this game until you fix this stupid bug, cheers.

    (I play on Xbox One) p. S I still have issues with asgard lol

  • RobSoloKeano
    1 posts

    When is a skull cloak patch fix going to happen? If could give a date? Or an idea on how is to be fixed?

    This is a massive flaw in the games visuals. Im near to the end and dont want to continue until fixed, as will ruin the whole end of the game.

    Building up your gear is part and parcel of the game and decisions on which set to upgrade is based on how good your armour looks. So alot of investment of time and effort has gone in and to finish on shoddy looking Gear will diminish what has been an epic game upto now.

    Hoping for a response and action soon.

  • Kotastraphe7568
    2 posts

    @santiagogd11 it’s not bugged. You need the mask to complete other missions in that region. Once you finish the boss battle and return to Randvi the mask and cloak will be removed.

  • Danziii
    6 posts

    This is absolute bs, I've tried everything in this thread and the cloak just will not [censored] off. It's gotten to that point where I've spent so many hours trying to get rid of it, it's ruining my immersion completely. I was hoping to play and finish this game over Christmas whilst I have time off work, but I don't see that happening now. Surely it's not a hard fix, it's completely de-motivated me from playing this. I've encountered so many awful bugs in this game but this is surely the worst. I'll be having nightmares of this [censored] Mari Lwyd mask for months

Suggested Topics