ubisoft forums

Quick Suggestions

  • Kbanause
    7 posts

    I'm facing the same issue. All story quests are finished but The Father hasn't been revealed. In addition to the 'Unable to move the shelves to free the NPC in "The Demon Odour at the Tithe"'-bug I'm now facing TWO bugs that prevent me from getting two trophies that I need for the platinum on the PS5.

  • Kbanause
    7 posts

    @petteflet88 If I'm correct then the Ubisoft employee answered that they got several reports of players not getting the quest and that the development team has been informed. The employee also says that the dev team is already looking into the issue.

  • Odyss122
    4 posts
    This post is deleted!
  • Odyss122
    4 posts

    @kbanause Do you know when dev fix it?
    Disorder of the Ancients is the last trophy needed to get platinum 😞 😕

  • Hocofaisan
    2 posts

    After 125 Hours I have this bug. The save where I could fix it is over 30 hours ago.
    Cannot complete the game.

    This really needs to be prioritized.

  • Hocofaisan
    2 posts

    @kbanause Kill a npc outside. Throw the NPC's corpse at the shelves. It will fix it.

  • LesserMagic
    2 posts

    Same bug, but with slightly different variables.

    • Finished the main story
    • Completed all regions, including the Hamtunscire arc
    • Killed all Order members, except for The Father
    • The Father is not revealed and has 5 out of 6 clues
    • Hytham is in his cabin and has no other dialogue
    • I have 14 medallions in my inventory, Hytham needs 15
    • I have not gotten the Thor cape
    • "Breaking The Order" quest is still active

    1 posts

    I've got the same problem! How is this still not fixed? I've played all AC games and this is by far the buggiest version of all their games. After pumping 120 hours in it im unable to finish the game! HOW..

    Please fix Ubi..

  • LottaTronIcs
    12 posts

    I have the same bug on PS5 version. I have restarted the whole system and switched avatars, etc to no avail.

    My situation is slightly different because I *do* have Thor's cape (have all 5 of the armor pieces) but I only have 1 medallion in my inventory (after turning it for Thor's cape)

    But the rest of my state is as follows:

    1. Finished the main story
    2. Completed all regions including the Hamtunscire arc
    3. Killed all Order members, except for The Father
    4. The Father is not revealed and has 5 out of 6 clues
    5. Hytham is in his cabin and has no other dialogueI
    6. I have 1 medallion - yes just one - in my inventory (maybe I was able to turn in the Thor Cape quest with just 14?
    7. I've also married Gunnar and Bridget and gotten back together with Randvii so I appear to be done with the main story.
    8. I've also finished the Asgard quest lines.

    Help Ubisoft. I cannot fathom restarting at this point.

  • drekken2010
    16 posts

    @lottatronics Same here mate, exactly the same, no solution and no feedback from Bugisoft:)

  • TheLahaaarl
    1 posts

    I did absolutely everything.
    Raventhorpe is level 6; the order is decimated, I have Mjölnir and Excalibur.
    i just finished Gunnar’s wedding.
    there is still the Father to uncover in the order. Problem is: i already did the quest Haytham gives to follow the Christ’s poor fellow soldier.
    trophy locked, platinum locked

  • KnightofTara
    22 posts


    26th of November, 2020.

    It is now the 2nd of January, 2021 and this game breaking bug is still not fixed.

    I literally CANNOT FINISH THE GAME and Ubisoft apparent lack of urgency is really annoying me.

    I am 182 hours in. Restarting is not an option. Fix this immediately.

  • Shadow-Wipeout
    19 posts

    Whats even more frustrating is the silence on ubisofts side of things...yeah its being investigated but to keep this many players in waiting is beyond a joke....Cyberpunk is getting so much slack but at least there weren't any game breaking bugs!!! I've counted at least 5 during my incompleted playthrough of AC Valhalla where glitches was the only way to proceed

  • Petteflet88
    348 posts

    Going towards 1.5 month!! 😄

  • AxellSlade
    7 posts

    Is there no fix for this yet? Sigh.

  • Quackable
    3 posts

    Still no progress on this bug? It's really annoying.

  • Kbanause
    7 posts

    @hocofaisan If it was only a shelf sitting on the wooden beams on the floor then I would have finished it long time ago. However, I have the 1x1 shelf sitting on the wrong side of its beam. And whenever I try to lay down a corpse beneath the 1x1 shelf, the vases shatter and the shelf falls directly on the ground. No way for me to push it over the beam.

    1 posts

    @alexandru27p I am having the same problem

  • drekken2010
    16 posts

    @shadow-wipeout Mate Cyberpunk is beiing brought to trial - Class Action Suite lead by Sony mainly for the PS bugs and the fact that Cyber is unplayable on consoles:)

  • domeckquan
    2 posts

    Assassin’s Creed Valhalla indeed is a beautiful game, but the bugs are frustrating. I’ve spent 100+ hours into the game, completed everything what I could, but unfortunately the game itself just doesn’t let me finish it. I already acquired the Thor’s equipment, which should not happen like Hytham is still in his bureau and the quest doesn’t trigger. I’ve finished the story line and killed all of the members of the Order but I still do have two more medallions. And the thing is that my last save is like 30hours back into the game so...this is just something that should not happen. gg Ubi

Suggested Topics