ubisoft forums

Quick Suggestions

  • eltnameerf
    5 posts

    PS5 patch did NOT fix this issue. Still can't speak to Halewyn because the interaction icon won't appear at the door. Tried doing other quests and coming back, dying, reinstalling the game, borrowing a friends copy of the game...nothing will fix it.

    This needs to be sorted!!!!

    One of the biggest gaming franchises and they sell a game that prevents you from completing it. It's like buying a brand new car that will go for 100 miles before breaking down and then can't be fixed by the manufacturer.

  • edelgiud
    13 posts
    This post is deleted!
  • edelgiud
    13 posts

    Running on PC here. I was so excited this morning, but alas, it doesn't work for me.
    The druid is dancing there waiting. I wear mask, light fire on straw men and find the green clues. He never further talks to me. Something is just not triggering.
    I have no other missions I can solve without moving forward with this.

    Such a long wait. I wish that someone from Ubisoft support would just contact one of us so we can show them (easy via PC).


    On to other games for next month I guess.

  • nailgun2theface
    3 posts

    @edelgiud this is exactly the same issue I’m having but on the Xbox. And I’ve done all that stuff too including uninstalling and reinstalling the game. Nothing changes. He just keeps dancing and doesn’t say a word.

  • skeli25
    3 posts

    After the patch nothing changed has changed for me. I still have the exact same bug. I set all 5 wickermen in flames but nothing gets trigger. The druid just dances on the rock weirdly. I can provide a video of my issue via Google Drive.

    https://drive.google.com/file/d/1DFl_7JyJzm0aScaBC1eLlgLO8UHjHYAb/view?usp=sharing: (https://drive.google.com/file/d/1DFl_7JyJzm0aScaBC1eLlgLO8UHjHYAb/view?usp=sharing)

    Platform: Xbox One S

  • FosterXboxGamer
    16 posts

    @skeli25 Same for me.

  • sbenyo
    22 posts

    Finally resolved. I can now continue the quest. Let's hope no new major bugs now.

  • glover87r
    12 posts

    Just checked an still messed up guess another few months wait hopefully it patched before the dlc drops

  • FosterXboxGamer
    16 posts

    @sbenyo Did you have to do anything specific? In a certain order for example? Also which part were you stuck at? Was the Druid stuck dancing or had he not even come out of the house?

    8 posts

    What can I say Ubisoft.
    I have been an Assassin's Creed fan from its launch, I am 50 years old with a room dedicated to the Creed a massive collection of merch.

    Last year when Valhalla was launched I thought the price of collectors edition was steep £179.99 never the less I bought it.
    Never did I consider there would be so many problems with a game. By now after making so many AC games Ubisoft should have it right! Valhalla's BUGS,GLITCHES AND PROBLEMS gives me the impression its no longer about the players and the game.

    I feel like many players that we have been robbed of a beautiful experience maybe one of the best to date.


    I have a piano with missing keys , a petrol cap I cant open.


    Nothing is true; Everything is permitted.


  • aatkin1962
    1 posts

    Clues and riddles quest wont start- after an initial conversation he wont open the door when i cloak....nothing happens even after 14th Jan patch..reall y frustrated

  • ynazarkin
    9 posts

    And Hard reset doesn’t help, don’t even try guys, waste of time. I hade whole my system wiped and initialized, doesn’t help. I still can’t interact with the Druid’s door.

  • swiftblade
    6 posts

    << link after update to [censored] going on lol
    after the update... patch 1.1.1
    After purchasing ultimate edition day one, also always buying Ubisoft games day one mostly a better than standard edition, i have been forced to stop playing/progressing for 2 months ( meanwhile people buying the game on sale and such) maybe a lesson to never buy day one. cool, got it.

    To be just told to wait for a patch again, this is not acceptable in my eyes for future games as you have supported me i will not support you in return.
    just fyi 😛 I shall be buying all Ubisoft games preowned from a retailer or something just for the next 5 or so years at least so you don't receive funding 🤷
    Thank you for your time

  • Remy.K
    13 posts

    The bigger game websites should pick this up. A lot of player can't finish a game they paid for. For months now. This is ridiculous.

  • caliban99
    4 posts

    I have the mask on, Halewyn keeps saying he will not speak to me. Have tried a earlier save still the same problem. Playing on PC unable to continue with the game. Very disappointed.

    @gymtan Have you put your hood up. I had mask on and he wouldn't speak to me. I put my hood up from the radial menu and it worked.

  • caliban99
    4 posts
    This post is deleted!
  • sbenyo
    22 posts

    @guest-3j072ykg I was stuck at the last part. I could talk to Halewyn but nothing happened. With the new patch I just tried again to talk to Halewyn. This time it completed. I of course collected all clues before. To talk to Halewyn I also used the mask.

  • caliban99
    4 posts

    @caliban99 I just got him to speak to me. I had the mask on but my hood was down. I put my hood up by the radial menu and he then he thought the disguise was working and spoke to me. Quest completed.

  • ImMadBroXBOX
    2 posts

    Still broken for me even after the 1.1.1 update. The druid just stands near the open door to his house. There still isn't any option to interact with him.

    This is ridiculous it has been two months and it still isn't fixed....

  • imjoshhemmings
    5 posts

    Haven’t been able to speak to Halewyn The Druid after setting the scarecrows alight. I have done it all with my cloak up, and nothing works. This was my 10th attempt and still nothing.

    @tylew79 me either, it’s incredibly frustrating. Anyone got any advice?

    @skeli25 this is the same for me

    @nailgun2theface same for me. Hugely frustrating

    EDIT: I had trouble with this quest too. I tried loading again from an earlier point, before I attempted the quest, tried again and it worked. That’s my advice to anyone struggling with it too.

Suggested Topics