ubisoft forums

Quick Suggestions

    15 posts

    @ubi-woofer Cannot interact with the door to speak to the Druid

  • SquirmyGoat
    2 posts

    @vlitvin1 hello do you have solution for this problem?

  • SoulmasterxX
    37 posts

    I was watching a video about this mission and I realized something, the druid asks me 3 questions he only asks the last question always, I think this is the problem with the mission it is incomplete so it does not advance

  • bl4ck_venom_666
    1 posts

    @f4tca7 awesome this worked thanks

  • CoGPIGEON6969
    1 posts

    My game won't let halewyn answer the door ive reset and reloaded my save i can progress in the story help

  • allied1982
    1 posts

    @wv_wild_1 I have seem problem won't let me finish the quest. Last area to do. Then I can finish game spent 110hrs on this. Really annoying.

  • SounderSpace710
    14 posts

    For Mine it's stuck with Halewyn asking to help prepare for the ritual. I have no clue what else to do. I'm in the mask, I light all the fires, from browsing I found out he's supposed to give you a riddle but it doesn't seem to be triggering. Reloading saves doesn't work and this is the last place I need to form an alliance in 😞

  • ligrn
    3 posts

    @soulmasterxx I hope this can be patched as a matter of urgency, since this is a game breaking bug for the main quest line.

  • kevinstites
    6 posts
    This post is deleted!
  • xSnakePlissken
    5 posts

    I’m on the Clues and Riddles quest. I’m at the part where you have to search in and around the cabin for clues to the riddle. I’ve gotten all the clues big when I go back to the guy to talk to him, I’m not able you. It doesn’t give me the prompt to hit Y. I’ve reloaded previous saves, and also reloaded the game from a fresh start. Is there a fix for this?

  • Ubi-Wan
    Community Representative 636 posts

    Hello there! I'd like to reiterate again that a solution for this issue has been reported to be found, and there should be a fix implemented in a future update. Of course, more information is always desired for these investigations. As such, for PlayStation and PC players, we ask that those affected provide our team save game files via the creation of a new ticket (or use of an existing one about the same issue, if applicable!) with our dedicated support team.

    Official Response
  • SoulmasterxX
    37 posts

    @ubiwan Any news on when this update will be released? Cyberpunk will be released and I will play, I would like to finish assasins creed before

  • kevinstites
    6 posts

    It will probably be mid-December after cyberpunk 2077 comes out and we've all forgotten about this game

  • CGTuC5202
    1 posts

    Can't get into the house and there's no knock or interact option appearing so I'm stuck on this quest and can't progress any further until this is resolved. Is there any way for me to fix it or will i have to wait for an update or something?

  • ze_pilar
    1 posts

    I´ve same problem as many of you are having
    when i arrive to the druid´s house, when i put de mask on, i cannot interact with the door

  • swiftblade
    6 posts

    SORT THIS [censored] BUG OUT Jesus lame [censored]... seriously tho stop released game that cant be finished my lordddd bugs and [censored] fine but this is absolutely appalling especially after your first "PATCH" ??????

  • TylerEmma2015
    76 posts
    This post is deleted!
  • ligrn
    3 posts

    Here's what I tried to resolve the issue:

    • Pledge to another region and do other quests, then return to this one after finishing.
    • Meditating and loading saves to try and reset the issue.
    • Approaching the door from different angles

    None of this fixed the issue. I also tried getting a refund, which I'm not entitled to since I'm playing this via the Ubisoft+ subscription service -- so this feels pretty ridiculous: paying a monthly fee for a game that is riddled with more or less game breaking bugs, no ETA on the fix and most likely having your monthly subscription expiring before the game actually works.

    I could understand that there wouldn't be a rush for bugs that are simply inconvenient, but making the main story progression unplayable seems like something bad enough that Ubisoft could consider at least refunding the cost of a subscription for playing a game that is broken out of the gate.

    Needless to say I'm not buying the Ubisoft+ service again and probably will avoid Ubisoft games like the plague in the future -- not that the reputation of the company shouldn't have warned me about this already.

    Also, for those of you that don't already know, this is listed as a known issue in the official thread (and it's amazing how many quests seem to have known issues).

  • EL__VIS
    1 posts

    mom on PS4 and have Ben stuck for two days and I about to ask for a full refund seeing as that I cannot finish the game. I am not happy because on top of this issue I get blue screened a minimum of 5 times a day. Please respond ASAP

  • sbenyo
    22 posts

    This is very frustrating. I continued very long after this quest, getting the famous Excalibur and now trying to opt for Thor's hammer.
    The problem is I need to kill all Order members and I am stuck with the last one "The Father". It requires me to complete the story. Hours of play and now I have nothing else to do and can't even complete what's left. 😢

    If so many people are complaining about it, with story progress stuck, this should be addressed in highest priority or at least deserves better transparency when we should expect a fix. I see people start to be really annoyed.

Suggested Topics