ubisoft forums

Quick Suggestions

  • IGOR2098
    3 posts

    @overduefart911 I have the same problem m8. That's annoying cause it is my last region to conquest

  • Ubi-Baron
    Ubisoft Support Staff 798 posts

    Hey guys,

    This issue has a fix identified for it, but as you noticed it wasn't included in the last update.

    At the moment we don't have an exact date for when this will be resolved, we'd advise keeping an eye on the Patch notes.

    Official Response
  • xXJohnnyboiiXx
    2 posts

    @alake314 Omg It actually worked!!!!! The community is trying harder than the actually game company that developed the game to fix its many bugs.

  • Adamcosta1988
    1 posts

    I have the same problem , used a bow , fire , restarting and loading old saves.. he isn’t moving from the bridge.. off the start of the quest..

    any more ideas ??

  • Seffcool
    1 posts

    How do i report a issue to the fourm?

  • GeneralCody053
    2 posts

    @ubi-spud having this issue 8 days later how is there not a fix for a game ending glitch. Making the game unplayable. Very disappointed in this game and all of its glitches.

  • Docta_Dee
    3 posts

    @whatsadanny I don't even see the camp on my map, can you provide further detail?

  • Aceagles00
    1 posts

    Same issue here, he’s just standing in front of a little bit about 200m from the starting point. I tried every single fix in this thread and every other thing I can think of, but nothing’s worked. The only thing I have left to do in the game is finishing each area 100% and I will occasionally go back to see if this has gotten fixed. Very frustrating after almost 60hrs of play time.

  • Ubi-Baron
    Ubisoft Support Staff 798 posts

    @gn0m388 This was not planned on being addressed in the last update, we'd advise keeping an eye on the Patch Notes for when this will be resolved.

    Official Response
  • LuckyJokerPL
    1 posts

    Can you just add restart or cancel quest option to the game? It will solve some problems, I don't think that's a lot of work for you guys, and I would help a lot, I have 2 quest glitched and I cannot do anything.

  • SlickyRicky4269
    7 posts

    @lypitiern300 Unfortunately this isn't possible for me. He's stuck halfway between the camp and where you begin to follow him. Initially he was inside the camp, then when I went back another time he was way outside the camp.

  • renegadewolf101
    1 posts

    Need help

    Hey guys, I’m about 50 hours in on my save file and I have an issue where my main objective is to follow Aelfgar. The problem is that they are not moving and I cannot speak to him or follow him, he just stands in place.

    The main issue is it is a main quest and I cannot continue farther into the story without it being fixed. As I said I’m 50 hours in and I am unable to revert to a save file prior to this quest issue.

    Is there anyone just to restart/reset a mission? I have done other story arcs, gone to Vinland and done any possible fix I have seen on forms but with no luck. Playing on Xbox Series X mission is A Sword-Shower In Anecastre.

    Thanks for any help.

  • jacobirish123
    2 posts

    Hello, I'm on what appears to be one of the final missions in the Lincolnshire segment. After choosing Aulfgard as the new Ealdorman, I see him and his crew waiting across the bridge for me so we can go and raid the traitor Bishop, but actually speaking with the new ealdorman is not possible. I run all around him, prompt fights with passing guards that he will engage in, kill civilians to resynchronize - and am still unable to get him to speak with me. I have tried everything. Including completing entirely different pledge sections to return to Lincolnshire, unable to continue beyond this point "Speak to new Ealdorman". I also tried traveling to the mission's monastery to assassinate the Bishop on my own, but he is unable to be harmed. I'm unable to beat this section and therefore the game... Please help!

  • Sietze030
    2 posts

    Hi there,
    I play ac valhalla on the Xbox one. In this mission I need to follow Aelfgar but the attack on Anecastre didn’t start at all. I can’t continu the story. I tried everything, please help!

  • slimshadyzzzzz
    2 posts

    Having the same problem both of them won’t move no matter what and I tried the push. However, I would have to spend an entire day to get both of them to the camp.

  • drFilipovic
    1 posts

    Had the same problem, and did not have an earlier manual save to load. However, among the autosaves I had one from an earlier quest with him (bear cave and burning estate), so I’ve finished them and went to complete the next main quest. The problem persisted when I decided to stick with Aelfgar, so I reloaded again and chose Hunwald. After defeating the order’s forces and continuing into the next quest, there was no glitch and I’ve completed the quest and the Lincolnshire questline smoothly. Hope this helps, and I know it’s not the same when an AAA game forces you to change your choices because of the devs poor work, but still beats quitting or starting anew after dozens of hours of play. Hope Ubisoft solves this quickly, albeit they are a bit late as the problem hasn’t been solved for nearly a month now, which is unacceptable for one of the next-gen launch triple-A titles.

  • KiwiKokaTV
    1 posts


    It has already been posted but i saw no answer from the devs so here i am trying to make some noise.

    The quest "Sword-Shower in Anecastre Quest" is bugged.
    After crossing the bridge to join Aelfgar and talked to him, he will not move at all.
    Hope this will be fixed soon.

    thank you

  • Lypitiern300
    11 posts

    @slickyricky4269 that is what happened to me originally, we were in the camp but it kept saying I had to be anonymous so I left the game and came back the next day to find him half way to the camp at a little fork in the path with one going straight through the camp where you're suppose to go and the other going slightly right, around the camp it was give or take 100m from where he was standing to where he had to be

  • A08533
    1 posts

    Cannot continue game after picking AELFGAR to rule..
    After fighting in the church it asks you to follow Aelfgar and was able to follow him for a few hundred meters and he proceeds to stop and does not move.. Have tried pushing him, have tried restarting the PS5, tried closing out of the game, the game restarts with him standing in the same spot every time!
    Have seen posts on other websites with others having the same issue!
    Thanks for your time!

  • khris_d
    1 posts

    Aelfgar won't move. The mission is to follow him. He walked 10 m down the road then stopped. Tried everything, previous saves reload, do other missions to try and reset. I've seen for others he freezes much closer, but I am 300m away and sometimes he walks backwards after I've pushed him so far. Tried to lure guards to fight them which he does, them stands in place afterwards. Can't progress further since he is the last set of missions I need for the order.

Suggested Topics