ubisoft forums

Quick Suggestions

  • yeti4life
    14 posts

    @ubi-woofer no quest marker... its ridiculous we have to prove this to you...its clear the whole quest is messed up like come on... its been over 3 weeks now... please do SOMETHING!
    you guys [censored] suck


  • sheiebs
    2 posts

    @officerlego thank you this worked for me too!

  • Ubi-MrM
    Ubisoft Support Staff 4541 posts

    @yeti4life Rest assured that our investigation has not stopped despite a workaround being found - we're still looking into this and will share more as soon as we can on the subject. Thank you for providing images of the issue - I'll pass these onto the developers now.

    @jrod614 As I mentioned previously the issue is known to us and we are investigating. We will share more as soon as we can. Thank you.

    @OfficerLego You have shared this same video multiple times in the thread already, and I'd like to request that you refer back to one of your previous posts as opposed to reposting the video repeatedly from now on. 🙂 You can link to your previous post by visiting it, and copying the URL (as the post number updates as you scroll to reflect the post you're currently reading). Thank you!

    Official Response
  • FluShot99
    2 posts

    There is a work around on YouTube where you can save a prisoner in a world mission and they will follow you back to the Long House to activate the cut scene. It worked for me and saved me several hours of game play!

  • BigJSmith16
    2 posts

    Looted Leah villa before doing the main quest. After defeating longhouse it says to find and rescue the thegns, but no marker shows up so I go to the villa to see if something will happen and there is no one to rescue so I can’t finish the mission. Anyone else have this issue or bug?

  • elladeer
    1 posts

    I have been stuck on this same thing for weeks. Can't get through the doors and half the time I go to the village to try again Sigurd is missing. No where to be seen....I would like to finish the game as well but I'm def not starting over.

    I already helped that prisoner mentioned in the work around so it doesn't work for me as it's been too long since I helped them.

  • mike561960
    1 posts

    My game is patched to 1.04.
    I committed myself to the Oxenefordscire alliance. I get to part of the Brewing Rebellion topic of "find and speak to sigurd". I get to the section with the lady at the alehouse. I pick choice two of the dialogue discussed further down this post. I have no other choices available for me. I am stuck at option 2 at finding "sigurd hid southwest of buckingham's alehouse. I have looked with Eivor as well as the raven for 500 meters to search for Sigurd as far as Meldeburne. No blue circle with Raven view found either.

    See this pics for references.

    Three choices available: 1) Pay the silver (130) 2) Solders won't help you. 3) I know you are an honest woman
    I do not have enough silver. I could not charm her since I did not have enough charisma. I have spent hours researching on youtube and google searches with no luck,. too. Various independent websites have stated that no matter what option you pick, then the next quest will be "meet sigurd at the fish house" The fish house never appears in the areas described to be 500 meters within Grantebridge as a part of the quest.

    I can not provide a video or picture attachments to before picking option 2 I have deleted 50 saves since then. For now, I am working around the glitch or trying another alliance attempt within a few days via Randvi by the alliance map. I do not want to start the game from beginning all over again because of this glitch.

  • agentcoulson_1
    1 posts

    @gorechi gives this person a saint hood

  • Probably_A_LS
    2 posts

    Patch 1.04 did not fix Brewing Rebellion bug can not get into longhouse please fix.

  • yeti4life
    14 posts


    so 3+ weeks almost 4 weeks stuck on this whole broken quest.... i cant do anything else in the game come on man...

  • Heinricht96
    7 posts

    (there should be a pic here showing an EMPTY quest in the done quest logs, and the current quest of buckingham in the other one)
    @Ubi-Baron I srtrongly assume this might be the issue here- the quest might be completed, but also not, at the same time. As described, the questmarkers are gone. I will also upload the savegame, hope this helps

  • HuskyDaz
    1 posts

    Same game stopping bug.

    tried going to other missions and coming back - they were still not engaged in the mission and wouldn’t follow.

    at one point I warped into the Longhouse without them and killed them all inside apart from the Lady who wouldn’t die despite repeated Assassins kills.

    I eventually dumped her in the river where she remained alive yet laid down under water.

    I eventually had to reload a save from 3 days before with enough progress lost (including 3 legendary beast deaths) to make me weep.

  • cygale
    6 posts

    @ubi-woofer No news or ETA for the next patch ? One month and huge patch which correted nothing ? wow ...

  • Petteflet88
    348 posts

    @cygale nope, crazy right? In most countries it is illegal to release an unfinished product without repairing it. Been stuck on Sons of Ragnar for 28 days now. This game is the biggest letdown of my life.

  • OfficerLego
    13 posts
    This post is deleted!
  • Ubi-MrM
    Ubisoft Support Staff 4541 posts

    @Heinricht96 Thank you for submitting your save files in your support case 13523767 - I've sent those off to the developers now! I'm afraid I can't reply to your full message as I'm not a German speaker however one of my colleagues who does speak German will reply to you as soon as possible 🙂

    @cygale Our next patch for Valhalla is due in mid-December however as this issue remains under investigation at the moment, I cannot promise that it will be fixed in this. 😞 I'll keep everyone updated with the latest information I have when I hear more.

    @OfficerLego As I advised you in a previous post, your repeated posts containing your video are bordering on self-promotion and spam. Therefore I have removed your post. Please do not repeatedly post the video - refer back to your previous post if you'd like. Thank you.

    Official Response
  • OfficerLego
    13 posts

    @ubi-woofer Sorry mate, I logged back in and scrolled down and seen your post without realising I already replied to you 😂. Please delete the comment as I am unable too. Only trying to help 🙂

  • Corbae
    12 posts

    @ubi-woofer Just go away. You provide no useful information just lecturing people on forum rules, asking for us to help your incompetent developers, and to let us know you are bad at your job. Come back when you have something to tell us not just to let us know you have nothing to tell us.

  • oz10w
    7 posts

    @ubi-woofer I bought my son a Nintendo Switch for Christmas. Naturally, I went to buy him a few games and came across Immortals Fenyx Rising. I bailed out last second when I saw the Ubisoft logo. End of story... Just thought you should know it is because of the handling of this issue.

  • DHangelfan16
    24 posts

    So, just an update guys.

    I've been having a BLAST with Metro Exodus!

    Super fun game! The best part about it? It actually works!

    I don't take that for granted anymore when I play games.

Suggested Topics