ubisoft forums

Quick Suggestions

  • Scoundrel_FM
    1 posts

    I am actually enjoying a ubi game for once but this bug is making it so hard. remeber when they used to polish games and have a decent reputation 😬

  • Corbae
    12 posts

    Six days since a ubi response. Eleven days since ubi updated known issues. This is not a known issue.

  • TylaaS
    1 posts

    i’ve been dealing with this same problem for going on 2 weeks now and i can’t progress any further. i’ve went back to the alliance map did the other missions but this one won’t even pop up. i’m very much looking to finish the game but i’m not able to w the as is version and it’s quite saddening because i love assassins creed, ive played every console game. i just need this fixed. i thought the new patch would fix it and i’ve been watching this thread for a week as well and i thought it had been confirmed for a fix. very disappointed as of right now because i just wanted to do the mission before i go see my family for thanksgiving😕

  • Chento.D
    2 posts

    I have rescued all the thegns but the next quest step won't pop up, it still says I have to rescue them. They followed me everywhere but now only 1 NPC follows me and the other are lost.
    for almost 2 weeks i cant continue the game!!
    The update did nothing!!

  • Carlt0nG
    1 posts

    Completely stuck on world missions now, had this Buckingham Longhouse glitch for over a week now (XBOX One), and now in the Snotitinghamshire Quest line has stopped, the Seer got assaulted by a hog that was chasing me and has died - so although there is a quest marker on her, I can't follow her to her destination. Tried carrying her there in the hope it may have kicked into the dialogue, but still nothing. It's broken. So can't do Oxford or Nottingham quests now, and no more new ones will open up whilst they are pending, so due to the glitches I can no longer continue the game. Time for a refund I think, pity as. the concept and gameplay are great. But can't have a game I can't actually play or progress with. Hoped the patch would help today, but sadly it didn't.

  • cygale
    6 posts

    Do something !
    The only reason I bought this game is because of the cyberpunk report!
    How do I get my money back? 100€ for a beta game...!
    If at least you communicate but it's been 2 weeks and this bug is not even in the known bugs it's unforgivable !

  • RogueCheyne
    2 posts

    Downloaded the patch that said it fixed this, but went into town and they still will not help opening the door.

    What is it going to take for us to have an option to simply redo a quest or something?

  • Kurtiz717
    1 posts

    Same issue here. Longhouse door with no help. Almost 70 hours in, no main line missions left. Getting bored of treasure hunting.

  • Darkcheddar
    3 posts

    Still broken as of patch 1.0.4. The guys just act like guards when not fighting. You can whistle to get them to come investigate the bushes but they are otherwise unresponsive.

  • Schottgun006
    7 posts

    The case I filed on the 13th for this bug has a case status of "ESCALATED" now.

    It is very clear to Ubisoft that this is a serious problem....finally.

    Stay on top of them about this guys. Compensation is mandatory at this point. Also, I'll never pre order a game from Ubi ever again. Facts.

  • tjhg1996
    1 posts
    This post is deleted!
  • begonebihh
    1 posts

    Still bug is not fixed! Now I am just waiting for cyberpunk to release so I can yeet this [censored] game. Tired of Ubisoft. Never going to purchase any of thier product. Why wont these devs just put a [censored] restart [censored] mission in this [censored] game.

  • guest-xN6GZsyK
    2 posts

    A very good day i am trying to get into the Buckinghams’s long house but no one will help me knock down the door they are just standing around. Also Vinland in a stange land does not work. I play on a playstation 4 please help

  • AlUcArD42
    1 posts

    Another bug....it's not a funny one because it's hinders the progress of my principal quest. It's begin with the quest " Roaring rebellion": i come in the camp and rescue the PNJ but i didn't go through the objective point...and since the game had this bug!! Eivor freezing during mystery quest so i can't finish them and he freeze during opening chest in raid. The problem is: i can't finish the quest roaring rebellion with this bug, so i can't advance in the main frame!! Please make the possibility to restart the quest...i have more 60 hours of game and don't have backup! Thx

  • TheFlash0412019
    18 posts

    @schottgun006 yea I was really keen for far cry 6 if they haven't fixed this issue in two weeks I'm done this is stupid now idk what they mean by "can't recreate the issue" they've had save files and videos sent I bet even youtube has a video of this issue. Dam wouldn't be surprised if there's a video of someone trying to get inside the LONGHOUSE for a few hours.

  • stonestorm765
    3 posts

    I would like to report a glitch for the Brewing Rebellion quest on Xbox One. Whenever I try and attempt to approach the Leah Villa Garrison in order to rescue the Theigns the screen freezes and sometimes eventually crashes. To get the game working again I have to delete all local save games, reinstall and load an older save. From this point I can continue to do the rest of the game but this quest still doesn't work.

    I have tried this quest with both male and female Eivor with the glitch still occurring. There was one time when it didn't freeze and I was able to get to the prisoners but there was no button prompt to untie them. I have watched a walkthrough of this level and I believe my game has a problem with loading the cutscene which shows the prisoners. I have tried to link a youtube video of my problem but it won't allow me to.

  • El-Diablo670
    2 posts

    I bought this game day one with the xbox series x and was really excite to play this game, ive loved every minute of the game. Until this quest came up. I satreted and got all the way to the longhouse. Cant get in. Tried everything. I even tried going to an old save but for some reason i could access the last save i made 20 minutes before starting this quest, instead it wanted to take me back 10 hours, which k wasnt gonna do. So i decided to play on for a bit and wait for an update. Its now got to a point i cant do anymore, and im getting [censored] off now, over 2 weeks since this was reported and nothing has been done. Ive put alot of time into this game and also bought extra cosmetic items because i was enjoying it so much. Please can you get this sorted ubi i just want to play this amazing game.

  • Brutal_Legacy83
    4 posts

    Still can't advance in the Brewing Rebellion quest. NPCs still stand around doing nothing unless engaged in battle and no quest marker to advance at the Buckingham long house. So not all bugs preventing story progression has been fixed.

  • SCG.Qrampage
    2 posts

    Still can’t complete brewing rebellion can’t open the doors to the buckingham longhouse

  • Brutal_Legacy83
    4 posts

    Still can't advance in the Brewing Rebellion quest. NPCs still stand around doing nothing unless engaged in battle and no quest marker to advance at the Buckingham long house. So not all bugs preventing story progression has been fixed.

Suggested Topics