ubisoft forums

Quick Suggestions

  • Mcnair17
    2 posts

    @assassin4life80 i am in the same boat

  • russbrooks
    1 posts

    SOLUTION: Same thing happened to me. I had to do a few quests in Asgard first. I think the last one I did was the Dwarf one. Then when you come back, you tell the Seer about your experience, via some new dialog options. Then it marked that quest as complete, and the dwarf one I just completed, giving me 4 Skill points at the same time.

    If you don't do anything in Asgard first, then there's nothing to tell her about. So of course those Dialog options are hidden.

  • Ubi-MrM
    Ubisoft Support Staff 4540 posts

    Hello everyone, thank you for your continued reports of this issue. So far I've only received the one video to submit to the devs, and it would be best if I could collect a few more for them to review and compare to each other. Could anyone else provide one, showing that after drinking the potion, you're stuck with the same objective?

    Also, can anyone verify if russbrooks' suggested solution above works for you? If you complete a few wealth/world events and then return to England, are you then able to speak to the seer and have the questline complete? Thank you for your help and time. 🙂

    Official Response
  • FNKH94
    11 posts

    I worked for me too, I had to do all the quest in Asgard tho. The last one was The big finish and after that my character woke up and started the dialogue with the seer.

    Thank you @russbrooks.

  • Athanasius
    14 posts

    @ibn__ If this is what I just experienced, with you on the 'go deeper' quest I didn't realise the first time that after gathering the second set of herbs and handing them in there are now TWO potions. The one on the left takes you to Asgard with nothing else to do (if you entirely cleared it the first time like I did), and one on the right that takes you to Jotunheim for a new arc.

    Silly me expecting I'd go back to Asgard and then through a gate there to get to Jotunheim ....

  • Schattenwaran
    2 posts

    I have a similar issue. I finished the quest line in Asgard (the big finish) and the objektive was: Go to Jotunheim. So I leaved the dream and then the seer did not speak to me and she sits only on a bank and in her house is a bowl: Return to Asgard. So no new Quest (Digging Deeper) and as I returned to Asgard (by consuming the mixture) I landed in Asgard and the quest objective says: Drink the potion to return to Asgard.

    As I said, I have already finished all quests in Asgard.

    Would be very nice if that could be fixed in a next patch, but without the need to start a new game. That is a no go for me, I have already spent around 50h in the game.

  • Schattenwaran
    2 posts

    @schattenwaran (Update): Ok, this time I used the eye symbol to return to england. Now the talk with the seer has triggered and she said, she has to think. Maybe the problem was that I used the gate and not the wake up symbol on the world map.

  • dragenzero
    1 posts

    I made it most of the way through Asgard, but when I clear the room with the paint out with Lori, he disappeared, and is now standing back in the tower with the builder disguised as Freya again. He won't move and when I run the paint back, it does nothing. I can leave asgard and re enter at will but the boss fight will not proceed and Loki is glitched and returning the paint from the cave is also glitched

  • Roadhouse90
    7 posts

    I have the same issue, I have completed the entire story quest line, to include defeating the beast, all Order members, and the 3 sisters. 106hr played and still once I go back to Asgard I instantly take damage and die. Is there a way to put in the option to restart a quest or put a teleportation portal in the area near the bubble? Its the only quest line I have to complete.

  • Kormac67
    1144 posts

    I had the same issue today that after returning to Asgard the quest was still "drink potion to return to Asgard".
    Easy solution: I just switched to the current Asgard quest from the quest menu.

  • Keen12
    1 posts


    This worked for me. I couldn't progress "Drink the potion" while the quest was tracked. I just switched my tracked quest to a random quest and tried drinking the potion again. Once I was in Asgard, the main quest for Asgard (The Big Finish, in my case) showed up in my quest log.

    I'm on PC.

  • speeeg
    1 posts

    Disappear NPC and quest list during playing quest

  • slashtor00
    7 posts

    @ibn__ I have the same problem. I cant close the door. This is the third error in Asgard I get.

  • Rock5tar77
    14 posts

    I play on PS4 and my Asgard glitch is very similar. I haven't completed the barrier quest bc when it said, "Survive the Attack" something happened.. The gate turned back green from red, but the enemies could breach the barrier as well as they stopped coming for me. I've killed all enemies in the area and still nothing. I woke up, drank the potion to return and still...nothing. Hopefully new fix in update 1.0.5 🙏👍

  • standoffjosh
    78 posts
    This post is deleted!
  • braceletblock
    1 posts

    @assassin4life80 I'm on PS4 and the same thing is happening to me

  • jebedbolly44
    4 posts

  • jebedbolly44
    4 posts


    this is a video of the exact issue I am having with Asgard builder mission. I was too low leveled, left and went back to England, went back at recommended power level and now I cannot complete. Very frustrating because I want to finish the Asgard area and I’m over 90 hours into the game but can’t complete asgard

  • Rock5tar77
    14 posts

    @borax_swallower. Wow looks like this issue has been going on for awhile now. I too, on PS4 am having that same issue. My issue is with the builder and the barrier. Obj is to "Survive the Attack" however when I do, the builder doesnt say anything. And when I leave and come back, the mission is still active, the blue ppl can breach the green barrier as tho it's not there and the builder just stands there saying nothing! I'm almost power 200 and still no Asgard completion.
    Here's a link to recorded gameplay of my issue. Fast forward cuz its 15mins, sorry lol

  • hausofchad
    1 posts

    @ubi-woofer “In Dreams...” finally completed after I finished “The Big Finish” which automatically teleports you back to Ravensthorpe. Until then, it would still continue to display “Drink the potion to return to Asgard” as the quest objective for “In Dreams...” and wouldn’t complete even after completing many other quests in Asgard. It seems that you have to have some information from “The Big Finish” quest to tell the Seer about your experiences in Asgard in order to complete “In Dreams...”. Glad it’s finally complete!

Suggested Topics