ubisoft forums

Quick Suggestions

  • tinypicker
    23 posts


    I have completed all other mysteries in Grantebridgescire

    I did leave the area before the glitch occurred. I went to repton.

    I have interacted with both Regan and Cordelia fights and completed both

    I completed the Ledecesticire pledge before returning

    Ps. Thank you so much for this update! I hope you receive saves from the community (im on Xbox), And I cant wait for a fix! Happy holidays Ubi, and Thx for the hard work!

  • HEST_Hasse12K
    2 posts

    I can't interact with the corpse in Spalda Fens.

    I've done all but 4 mysteries in Grantenbridgescire.
    I've left the area and returned several times.
    I've played a lot of the main quests after that.
    I've killed the other two daughters.

  • Franks360
    13 posts

    I really really don't understand why after waiting two weeks for any patch at all, this wasn't fixed with the other stuff. I'm so disappointed

  • tinypicker
    23 posts

    Yeah, at least they made an update post. So we know it'll be fixed soon. Maybe with the Yuletide event?

  • saucytomatoes
    2 posts

    Please fix bug. I lost to Goneril 3 times and cannot fight again. I need her sword to get the armor. Had this issue since day 2 of release please fix.

  • fallzing
    9 posts

    I'm experiencing the Daughters of Lerion bug where I can't start the fight after reloading. It is the daughter located in the Spalda Fens that has glitched for me. I defeated the other two daughters without issue. I'm playing on PS4. Any fix for this yet or coming soon?

  • naknapastorn
    5 posts

    @kadwen_ Everything is still broken after that patch. The update was only released so they could put some more items into the helix store for us to buy. Yey..

  • BigJSmith16
    2 posts

    Has this been fixed or has someone gotten it to work. Finally got enough power and can’t even interact with it.

  • Diegoez16
    12 posts

    HEY GUYS I FIXED IT FOR ME. It wasn't appearing on the map so I went and put the other sisters swords into the stone. After doing that I marked where it should be on the map. When I started walking to it I saw the mystery marker appear on my compass

  • allisonra
    1 posts

    Defeated the first two and simply can't start the fight with Cordelia - the map does not even update itself with the icon when I get to the location.

  • DeathlyPoetic
    13 posts

    i died fighting her and tried again and there was no prompt to interact with the corpse anymore. It’s been 3 days. Nothing I do will bring back the prompt. She’s the last witch I need to kill too

  • Hunt_Ells
    2 posts

    Exact same issue. Triangle button prompt does not show up anymore to initiate the fight.

  • MrBluXD
    2 posts

    I can't fight with the fire one, i just can't interact with the corpse to start the fight

  • MrBluXD
    2 posts

    @ubi-baron In my case i already fight with the one with the power of venom and lighting with a really low level so they killed me many times but in the end I make it but with the fire one I died 2 times and after that I can't start the fight again

  • Lewloulewlou
    3 posts

    Someone above made a really good point that nobody else seems to have picked up on, and that was that the last time they died it was in phase two of the fight after the mid-battle cut scene. I was the same, and if everyone else is then maybe it's specifically triggered by dying during phase two?

  • tinypicker
    23 posts

    yes, tell the support staff

  • shaiwan43
    54 posts


    This is by far the worst most frustrating bug in the entire game IMO and something that can't be solved on the players end. Should be priority #1.

  • iAmmFlawless
    1 posts

    So i wanted to try and get the Thor armor set but when i go to the location where the Goneril boss fight is i can’t interact with the body tied up. I already reloaded a previous save, restarted my game and even reinstalled the game. it’s a bug, will it be fixed?

  • Altiar639
    5 posts

    I came back to one of the witch fights after loosing so many times I am at a very high skill power now but I can’t seem to interact with dead body to iníciate the fight need help please!( Goneril is the witch to be specific)

  • ZoroFBG
    4 posts

    Ubisoft, get your [censored] together. I paid £90 for a game that is infected with bugs. What the [censored] is going on? I cannot interact with Goneril, or my Tanner or the shipwrights.

    I have over 120 hours played and this game is bug infested. Do you guys even test the game before releasing it finally!

Suggested Topics