ubisoft forums

Quick Suggestions

  • Ubi-Swaggins
    Community Manager 439 posts

    Hey there,

    I am sorry to hear that you are encountering this issue.

    Can you provide us with a short video showing that you cannot interact with Valka and have no quest in your log?

    Official Response
  • Ubi-Baron
    Ubisoft Support Staff 798 posts

    @sbdre22 Thank you for reporting this to us.

    Which NPCs are you seeing this with, is it all of them or just specific ones? For instance can you speak with the Blacksmith and Store?

    Official Response
  • smithy10GB
    Original poster 70 posts

    @Ubi-Woofer Have we got any news yet from the dev team mate?

    I was just wondering because this issue seems pretty high priority compared to a lot of the other bugs atm since it severely limits gameplay.

  • BossBigBang
    4 posts

    so I think I may have found a temporary fix for this. I reloaded an earlier save right before the settlement gets attacked. Note that in this save, you must have the ability to speak to the NPCs (three dots). Once I re-did the mission to report to Randvi, I am still able to talk to the NPCs. Hope this helps someone.

  • chriskean86
    11 posts

    Can you talk to the NPCs on your main save or only on the earlier one?

    I no longer have a suitable save to restart playing. Its continue or start again 😞

  • Rakkertje08
    15 posts

    Hi thnx for this amazing bame first of all. I got more or less the same problem, playing on xbox series x. After unlocking my hunter i did the huntress quest with petra and it was shown in my quest completed overview. I loaded a previous save file (did some stupid stuff) and saw no intercation option with petra anymore (to start missing man quest and later on romance i read). My completed quest 'the huntress ' is gone so i cant find it anymore in my quest completed overview. And no intercation available with her. Tried to progrees intothe story, did lots os quest, no result, i can interact with all other npc though. So please make an option to interact with petra

  • Ubi_ryann
    1 posts

    Hey im having the same problem, can't interact with multiple NPC's within the village, has there been a fix for this yet?

  • Luiseachfr
    1 posts


    [X-box One]

    Hi, I confirm that I can't interact with:

    • Wallace (no legendary trophies then)
    • anybody in the fisher hut,
    • the shipyard, the barracks, stable man since level 3

    Thank you

  • BossBigBang
    4 posts

    @chriskean86 I can talk to the NPCs on my main save now. I re-did the part where you have to report to Randvi and your settlement gets attacked. After you settlement is attacked and you defend it, please walk around and make sure you have the option to talk to the NPCs. Once I had that, I created another save and I haven’t had a problem since. The breaking point for the big seems to be when the settlement gets attacked so make a save right before it. Hope this helps. I did not have a save right before it so I had to do almost 5 hours of gameplay myself but it fixed it so I am happy that I do not have to restart the whole game.

  • shannnnh
    1 posts

    I cannot speak to anyone in my settlement. I have followed many troubleshooting suggestions I have seen on other forums and nothing seems to be fixing the issue. I can only speak to two people, the blacksmith and my brothers girlfriend. no one else. I don't see how I am supposed to progress with this issue. I have also checked the known bugs Ubisoft list and this fault doesn't seem to be on there. Can someone give me any suggestions? paying £70+ for a game that I have logged 40+ hours on to only be able to do the main missions at best because of all the bugs is a waste. I did move the game from ps4 to ps5 if that makes a difference.

  • claud1o-
    50 posts


    I am 60 hours into the game and the attack occurred after 5/10 hours I think.

    Are you saying that replaying the settlement attack and talking to all npcs would solve the bug also in my 60 hours save? Cuz there is no way I replay 50 hours of this 😕

    @Ubi-Woofer Hi there, is there any tentative timetable we can expect for a patch on this matter?

  • BobbyFioretti
    11 posts


    Same issue for me, but the NPC's I can access are different than most, it seems. It started when I completed the "Viking For Hire" quest. I was unable to speak with Reda to turn in the quest and get my reward. At this point, I was around power level 150-160, my settlement was level 4, and I had no issues speaking with any NPC's up until this point - all of the ones I had were accessible. I looked online, and many other people were having this issue. The common response was to finish the Cent arc so you can do the Dag side quest and "reset" your NPC's. I was not far along enough in the main story to complete this quickly enough, so I took the suggestion of another poster and found all the codex pages. During the codex page searching, I noticed that I was also suddenly unable to speak with the Shipyard, Tattoo guy, or the Barracks Master. I found all the codex pages, turned them in, and Hytham told me to talk to Reda. THIS ACTUALLY WORKED - momentarily - as Reda was accessible again, the "Viking For Hire" was turned in, and he allowed me to view his page in his tent. I ran around to the other NPC's, noticed they were still inaccessible, then went back to Reda and they were now, once again, inaccessible. At this point, I had these settlement buildings:

    • Blacksmith (accessible)
    • Merchant (accessible)
    • Hunter (both accessible)
    • Fisher (accessible)
    • Museum (accessible)
    • Hidden One's Bureau (accessible)
    • Bakery (accessible)
    • Stable (inaccessible)
    • Barracks (inaccessible)
    • Cartographer (inaccessible)
    • Tattoo (inaccessible) - became accessible again when the wife took over.
    • Shipyard (inaccessible)
    • Seer (inaccessible) - I completed the first Asgard storyline, and "Going Deeper" was available as a quest, but she was never in her hut, nor had the quotes above her head anywhere on the map.

    I started to progress the story (I had been focusing heavily on wealth and side quests) so I could complete Cent and hopefully reset all the NPC's as others were saying. Along the way, I heard Reda speaking to the children, so I leaned against the post and listened, and he's been accessible ever since, but all of the other inaccessible NPC's remained inaccessible. Then I did some raids and started to build the feast boost buildings.... Each and every time I constructed a new building, the NPC was automatically inaccessible, and wouldn't even speak to me or thank me for building their structure. Not a single one, and I've now constructed all but two of the possible buildings (brewery and cowl farm) in the settlement. I'm not sure if these characters are supposed to be able to be spoken to, but I would assume they all would be, just like the others. So now, there are more inaccessible NPC's:

    • Mayda
    • Cattle Farm
    • Grain Farm
    • Avis and Holger
    • Woodshop

    On top of this, I've upgraded both the cattle and grain farms 2 or 3 times each, and the note in Eivor's room still says they need the second and final expansion. It still allows me to expand on each of these places even though it should only be two expansions for both. Today, I finished the Cent arc, and got some more random madness. The cutscene for speaking to Randvi after completing Cent seemed to be cut short (later proven and I'll explain) and my NPC's were still inaccessible. There was no option to continue the main quest, but I got a prompt to speak to Randvi about going to Vinland. I pledged Vinland, completed that portion, and when I came back to tell her what I did in Vinland, I got the cutscene (this time the full one) from completing Cent. On my first attempt to speak to Randvi after completing Cent, I wasn't stopped in the Longhouse by Dag, but this time I was, and I didn't realize it was the same cutscene (looked new to me because of Dag) until I spoke to Randvi and I was talking about Cent again. It gave me the completion message for Cent after that cutscene (for the second time), then immediately went into the cutscene for speaking to Randvi about finishing Vinland. I checked my NPC's, and nothing had changed, all the same ones were accessible, all the same ones were inaccessible. I slept in the bed after checking my note (still saying I needed the 2nd expansions for cattle/cowl/grain) then the Dag quest started. I thought "Finally". Finished the Dag quest and NOTHING HAD CHANGED regarding who I could and couldn't speak to. I've tried reinstalling, restarting, changing genders, sleeping, meditating, going to Norway and back, going to Vinland and back, handing in all 6 codex, and completing the Cent arc to "reset".

    RECAP: I am now power level 247, settlement level 5, and have 8 arcs completed. I had only 4 or 5 arcs completed when it began, and was settlement level 4.

    These are the NPC's I can currently speak to and interact with:

    • Neda
    • Blacksmith
    • Hunter (both)
    • Fisher
    • Museum
    • Hidden One's Bureau
    • Bakery
    • Tattoo (once the wife took over)

    These are the NPC's I cannot speak to:

    • Stable
    • Barracks
    • Cartographer
    • Shipyard
    • Seer
    • Mayda
    • Cattle farm
    • Grain farm
    • Alvis and Holger
    • Woodshop

    It all started when "Viking For Hire" was completed, and I have NOT completed the Berserker quest yet! This is why I think my list of accessible/inaccessible is different, and I'm now scared to even attempt this quest because I'll apparently lose access to more NPC's. There are two other weird, glitch-like things that occurred around this time as well, and maybe they might have something to do with it, so I'll list them in case it helps:

    • Tried to play dice with Petra and it immediately cut to a weird first person view in the Hunter's hut, with the loading icon displayed in the lower right hand corner of the screen, for an unusually long period of time. Then it cut to Petra and Eivor standing by the Orlog table outside of longhouse, yet we couldn't play Orlog. In fact, I couldn't do anything at all, but walk around. I couldn't fast travel or speak to ANY NPC's at all, so I was forced to load my most recent save. This has happened every single time I've tried to play dice with Petra (5 times now), and I always have to load the most recent save, as it won't allow me to do anything in the game. After the first time it happened and I reloaded the game, everything seemed normal, but it's possible I didn't notice that a few NPC's became inaccessible.

    • Shortly after that, I completed a Thousand Eyes contract that showed the target being in Raventhorpe. The target turned out to be one of the dummy targets surrounding the Hidden One's Bureau, and when I assassinated it, I got the completion for the quest/contract. I went and completed the second contract, and that's when I was able to turn in the "Viking For Hire" quest of 10 contracts completed. I didn't immediately go to Reda to turn the quest in, but when I eventually did, he was inaccessible.

    I hope this is enough info for whoever needs the info. Please fix this, folks, as the game is pretty dope when things work properly. Cheers!

  • gokerto
    8 posts

    Please tell us something about that problem.

  • BossBigBang
    4 posts

    @claud1o unfortunately no. I stopped playing as soon as I realized that my NPCs were bugged right after the settlement attack. So I re-did the report to Randvi and settlement attack and after the attack, my NPCs were fine.

  • Rakkertje08
    15 posts

    Only cant interact with Petra and my completed huntress Quest is removed from the completed Quest overview.. no way to interact with Petra. I could reload a file which i did to test, build again Hunter Hut again and i could interact with Petra, but i lost 16 hours of game time...not worth it.

  • gokerto
    8 posts


    Here is the video you have askd for:

    My Platform is PS4

    I have faced this problem this week. Some people are talking about Bjorn quest is the source of this bug. First time i thought this may be the problem but i think this is about server connection. People can not connect to server some times if this connection and NPC's are some way realted each other something broke something idk... It is your job anyway 🙂

    I did my part..

  • Boom_tat_tat
    1 posts

    My quartermaster doesnt have a talk bubble, i cannot access jomsviking and such. i bought it used it once and havnt had access since. Ive gone to far to reload a old save.

  • trisNL_
    10 posts

    I built the hidden ones bureau and did the "serve the light" quest but after that i did not get anymore quests from Hytham. I Heard from friends they could talk with him and get the quest "a brief history of the hidden ones" plus abilities and still interact. I didn't notice until my friends told about it and i had nothing there. I had progressed to much to reset and build it again. is there a other way to fix this

  • Rakkertje08
    15 posts
    This post is deleted!
  • Rakkertje08
    15 posts

    i hope so! All got variants here of npc bugs. Some cant talk to lots of them, some only not to a specific npc (trisieboy to Hyatham, me to Petra) devs should implement a perma interaction option to all npc in settlement which are relevant to the game (Quests, trading, romance, customisation and so on)

Suggested Topics