ubisoft forums

Quick Suggestions

  • Pas_Cook
    1 posts

    When is the patch about the shops in settlement not working going to be released ? Also is the patch going to fix things in existing save file or this save is ruined ?

  • Sinewolf
    1 posts

    Hello, so I haven’t had MANY issues at all luckily, but the one thing I have had trouble with is the NPCs in my camp. The shipmaster, Barracks master, and (he isn’t even there) Hair stylist and tattoo artist, can’t be interacted with any longer, I had no trouble up until a certain point in the game, is there any work around this as of now?

  • A Former User
    0 posts

    As the title says I can not speak with anyone other than quest givers, general store, fish shop, and the hunting shop. It was after I built the longshipmans cabin and went to Asgard. I don't know which one triggered the issue. This makes it where I cant get any side dialog as well as I can not change the appearance of Eivor nor my ship. I am unable to change my crew either.

  • yelllowel
    1 posts

    @cypher767 I’m having the exact same issue, really frustrating!

  • Cristeenamq
    1 posts

    I have upgraded my tattoo shop, stables, and barracks and can not speak to anyone at these places to customize. I am also unable to speak to the opal merchant after the initial conversation when he showed up.

  • N0va56
    3 posts

    After having built the boatyard and the barracks, I was able to talk to the ship master and quartermaster once. Now each character is in my game but I cannot interact with them to customize the long ship or the crew.

  • Neversetdrums
    5 posts

    At some point in the game, I have lost the ability to interact with my ship builder and my barracks manager. I don't know what caused it. I can speak and interact with all other npcs in my settlement but these two. I used to be able to. Also, the berserker crew member you pick up from Way of the Berserker, is at my barracks, but the option to recruit him is grayed out.

  • rryder810
    2 posts

    This also happened to me and it includes the boy at the fish hut as well. For me it happened while I was doing the East Anglia quest line. When I returned from East Anglia the woman at the barracks and the fish hut boy no longer had a speak option and when I built the ship yard I cannot interact with the people their either.

  • smithy10GB
    Original poster 70 posts

    I'm 54 hours in so I can not restart.

    I returned to my settlement to find that most of my npc's, like the shipwright and barracks nps etc had lost their text bubbles, I can not interact with any of them.

    I also keep losing connection to ubisoft online services.


  • Dclark5891
    5 posts

    @smithy10gb I too can not interact with several of my npcs. The Hunter (Wallace), the Cartographer (Olsen) and at the Barracks(Eydis). I'm 71H into the game and really don't want to restart.

  • rryder810
    2 posts

    Same, happened earlier with me maybe 25 hours in but I was doing the East Anglia story and hadn't been back to my settlement in a few hours. Its the barracks woman, the fish hut boy, the ship wright, and the cartographer for me. So far annoying but not terrible. If it spreads to the Blacksmith I am going to be [censored].

  • Venimeux34
    2 posts


    I am a french PS4 player. My settlement is level 4 plus and since start i have found impossible to interact with quite a few people though the buildings have been built. No option to interact with Cartographer, fisherman or shipyard.

    Is this a known bug ?

    Tks in advance for the answer

  • Atlas1_
    1 posts

    @darthcannabis1 I’m having the same issue. I noticed I couldn’t access the barracks after starting “The Ritual Of The Berserker”. After completing that mission I built the tattoo parlor and shipyard, but can’t interact with the latter. I’ve tried restarting my ps4, jumping out of the Animus, and fast traveling, but nothing has fixed the problem.

  • claud1o-
    50 posts

    Welcome to the club - I have the same exact issue and have been posting since 4 days now but managed to get no answer.

    It is clearly a bug, a serious one, which prevents playing the game as intented, and I hope there will be a patch soon...

  • samuel-jackson2
    4 posts

    I'm having this exact issue. I can't access the Barracks, Tattooist, Reda or the Shipyard. Really frustrating!

  • smithy10GB
    Original poster 70 posts

    @rryder810 yeah it really needs sorting, I just done a bunch of hunting/ fishing and can't hand in the items 😕

  • evilapplemoose
    8 posts

    Same here. Almost 50 hours into the game and still can’t speak to half of the village.
    Especially the Barracks and Cartographer are annoying. I really want to try these before I finish the game. Seems unlikely at this point.

  • smithy10GB
    Original poster 70 posts

    Same here (xbox one s)

    Most of my npc's are no longer functional, this includes shipyard, barracks, hunter, Fisher and cartographer.

    I think it might be to do with the online services constantly going down, I only started experiencing these issues last night when I kept getting a notifications about not being able to connect to the ubisoft online services.

    Here's to hoping ubisoft will actually reply to these threads and give us some insight.

  • guest-b9Uydy0I
    5 posts

    Having the same problem on PS4.. Stopped working a few day's ago, couldn't fix it with reloading a save. Had the same problem with the tattoo shop, but that problem fixed itself.


    Barracks are still not working though.. Also not in the list of known issues of Ubisoft.

  • smithy10GB
    Original poster 70 posts

    @smithy10gb OK so I tried contacting ubisoft live chat about the issues, the agent i spoke to said he would inform the dev team but in terms of the connection issues I am having in game, the agent tried to play this off as my Internet connection......

    Bearing in mind I have a fast upload and download speed and my Nat type is open.....

    I literally have no connection issues with other games, this is the only service I have connectivity issues with..... Shoddy customer support ubisoft.


Suggested Topics