ubisoft forums

Quick Suggestions

  • Vexilatio.
    3 posts

    Same isue here. since yule festival i see the talk bubbel but cant interact

    Xbox one S

  • girthta
    1 posts

    I also can't complete the Wise Friend quest, nor can I talk to any of the NPCs. I can't upgrade my armor. I can't turn in the MANY artifacts I've found. At this point, I'm just going around synching the map up and doing stuff I can sneakily get away with but I sure would like to actually play the GAME!
    I'm on a PC.
    I've even verified the game files and nothing helped.

    (Oh yea, I'm drunk every single time I log into the game)
    What's a shield maiden to do???

  • Arylius05
    5 posts

    @smithy10gb I also cant interact with all NPC's in the settlement.

  • deathwolf1313
    2 posts

    I have also now ran in the bug, where I can't talk to my settlement NPCs, specifically: barracks, shipwright, fish and animal delivery guys, and Rowan (I think that's the the name of the stables guy).

    It is unsettling to see this bug has been going on since November at least, but hopefully it will be fixed soon at some point, until then does anyone have some solutions they've tried that've fixed it?

  • LukeeeSkywalker
    7 posts

    I have upgrade my village upto 2 or 3 steps befor LVL 6. Now most of the NPCs started talking again AND Valka climbed of her horse back into her hut. I'm a little bit optimistic... but it came for a higher price. Experiencing more and more freezes on Series X during the bigger raids 😑

  • bas22sam.Oden
    2 posts

    i have the same issue in the PC with NPC in the settlement where i can't interact with them and can't do any mission which is in the settlement itself

  • guest-kS0TdI0o
    1 posts

    Can’t access the alliance table, blacksmith, thousand eyes, hidden ones, trading post, and can’t go any further in the story line. It all started after I did the fighting game for the Yule Festival (all Yule Festival quests work). Now when I get out of a load like into the game or after a death I am always drunk as well. I just can’t talk to the anyone or start a quest at all (except for Yule festival people).

  • ibivan
    9 posts

    lol we are Ubisoft mushrooms, kept in the dark and fed [censored]. any update on when i will be able to talk to my, shipwright, barracks, cartographer, and hunter ?

  • kodare97
    10 posts

    They clearly don't care, and I'm not talking about the customer support as they can only do so much without any information from the ubisoft team so I appreciate @Ubi-Woofer for trying to provide as much information as they can. However it's clear ubisoft does not plan on fixing this bug at all. Again really appreciate the support staff for trying to keep us updated but it's clear ubisoft do not plan on fixing this bug. I have been experiencing this issue since mid November and there is still no fix in sight.

  • KyraDrachenlady
    5 posts

    Hi, im playing since a week or so via Ubiosoft+ (PC) to see if the Game is good, bevor i pay for the ultimate edition.

    My Settlement was at Stage 3=

    • The seer is also bugged with stuck in the place at some point.
    • i couldn´t talk to reda too i can only do redas quest through visiting the other Cities and talk to the "little eyes" of him. (well at least saving good amount of Opal for shopping later on)
    • I build new buildings, but now i can´t talk to anyone. Exception was the 2 quests with the Hunter Lodge. (finding the Brother )
    • since julfest is there, i start the savegame as a drunken

    i had the feeling it startet wih the Julfest. Befor it startet i was able to upgrade my Weapons and co. and then when the Feast came i could only talk to the feast Ppl.

    Now im Settlement Level 4 and still not better, maybe i try to go to Sigurd, although i wantet to go after i cleared the Map *lol (Strengt 105)

  • heartpunches
    13 posts

    Can you please give us an update on when this fix will be deployed? This remains intensely frustrating; your assurances aside, it feels like this issue is being ignored.

  • HojoJames22
    2 posts

    Can only live chat to report this issue. Not got time to wait for chat staff to be available.

    I think overall some form of recompense should be on offer here. This issue has ruined my experience of playing the game, a game that I have really enjoyed as well.

    Get off your arses and get a fix, please.

  • CoolDragonex
    1 posts

    There is no chat bubbles appearing for any of the NPCs in ravensthorpe... Seems like the valka settlement mission with randvi is bugging the whole settlement 😔 any solutions for this?

  • TheIcemanXX4
    1 posts

    Can't talk to anyone in settlement since Yule started.

  • KyraDrachenlady
    5 posts

    PS: i hope i get a full load of Silver for my recruited Komswarrior over te days, since i can´t talk to the Lady who manages them.....

  • TotesNotADoge
    2 posts

    It won’t let me interact with that kid you trade your opal with (also the “a wise friend” quest is bugged for me she just stops moving once she gets up the incline)

  • Y2john84
    48 posts
    This post is deleted!
  • guest-U5YXVXom
    1 posts

    I am unable to interact with Gunnar and Randvi

  • rylssa
    1 posts

    I got to settlement level 3, ran around doing quests, then went back and unlocked the hunter house. I did the hunter quest with the wolves, and when I went back down the hill I couldn't interact with the NPCs anymore. Cannot interact with the hunter, with the smith, the fisherman, the barracks woman, the stable guy, the hidden ones, the ship builder, or even the head lady by the map in the longhouse. I can still pet the dogs, the cat, ride the horse, and recruit a jors-whatever that showed up at the dock. I can still interact with the Yule NPCs. The NPCs at the tents I haven't built yet just seem to be missing.

    I also cannot complete the quest with Valka - she just goes up the hill and stops and won't move, but that happened right after I hit settlement level 3. And I'm drunk every time I log in or travel after doing the yule fight thing.

  • Kaxtie
    1 posts

    I just read through this full thread because I’m getting this problem repeatedly today... reloaded my save, happened again in the same spot. Game crashed before I saved again, happened again in the same spot... that’s when I decided to look and see if others were having the same problem.

    I just finished the quest line with the brothers Ubba and Ivarr, and when I go back to my settlement, I have the dialogue with Randvi, then can’t talk to her or anyone else in my settlement. In addition to that, it appears all the challengers from the Yule brawl (I could be wrong, but it looks like them) have turned hostile and are just fighting in that area of the settlement. Killing them all so no one is in combat doesn’t fix it, either.

    The first time this happened I did get a notification about not being able to connect to the Ubisoft network, but then my game crashed and I appear to be connected now, yet still had this bug hit again. I can still fish, hunt, and go do raids- but since I can’t talk to any of my NPCs I can’t make actual progress in the game.

    My settlement just hit level 4, I’m at 110 power, and playing on XB1.

Suggested Topics