ubisoft forums

Quick Suggestions

  • PottumWasTaken
    17 posts

    @ubi-raziel Negative. I didn't teleport/fast travel and finished the last quest (Closing the Vault) in Jorvik and got the bracelet, but never got a quest to report back to Randvi.

    I tried to repledge Jorvik and got nothing, I did so many other little things and nothing. Travelled, started the game and loaded up again, to no avail.
    Interesting enough, the save says "Closing the Vault" is still the active quest. Does that help?

    I'll try to finish the quest again. So reloading and redoing it gives me the quest to go back to Randvi. But there's so much time between that save and my current save 😧

  • Zadkiel_
    4 posts

    @vincentlej Exact same scenario for me as well. The main quest AND the guard w/ the key.

    I have 87hrs of playing and I cannot load a previous save as I did Jorvik when I was around 60hrs of playing.

  • PottumWasTaken
    17 posts

    So I tried a few different things, for example fast travelling before acquiring the quest to talk to Randvi - I got the quest even tho I fast travelled, so that's not the issue.

    As I stated before, I didn't fast travel or anything in my actual game, but I might have had a small "infight" bug? Where the tense fighting music keeps playing? Could that've been the problem?
    (That bug usually goes away after save/reload, so I don't have it anymore, but never got the quest to talk Randvi regardless).

  • Ubi-Raziel
    197 posts

    Thank you all for adding to this thread. Everything you comment will help us try to reproduce the issue ourselves.

    Regarding your questions whether a certain event could cause the issue - The answer is yes. Any event that is happening that leads up to this issue is a potential factor; it could be something as small as swinging your weapon as a cinematic starts for example.

    Considering this is quite an obstructive issue, I would recommend loading a previous save and trying again if at all possible. I understand this may not be ideal for some and we'll try to get it fixed on our side, however it may take some time to develop a fix and push it into a future update.

  • PottumWasTaken
    17 posts

    Here's another thread btw: https://discussions.ubisoft.com/topic/82922/jorvik-alliance-map-bug/4

    Also an edit to what I was saying before: I can't reproduce the bug at all right now.
    However I can remember that, before I outed the Vault, I tried to do a quest for Rada, a bounty hunter quest. It was some random guard near the theatre, where you have to out the Vault.
    I couldn't attack the guard, because everyone and the target himself were 'friendly' (?), swinging a sword onto him didn't do anything, but pushing him away. Shooting an arrow onto him made him threaten me, but he didn't receive damage or turned hostile. I think, it's because during the quest ('Closing the Vault') you cannot attack anyone before you havn't outed the vault. In any case, I couldn't draw my sword there.
    Since the bounty hunting quest didn't work, I did a world event (the one in Jorvik with the goat selling little kid) and then proceeded to do the main quest ('Closing the Vault')

  • Zadkiel_
    4 posts

    On my side I tried de-installing and re-installing the game... Didn't work.
    Trying to pledge another territory and coming back to pledging on Jorvik ... Didn't work.
    Trying to switch gameplay difficulty to trigger a loading ... Didn't work.
    Trying to meditate straight after to see if the alliance map went from "eligible" to "completed"... Didn't work.

    As far as I remember, the only problem that occured just before finishing the "closing the vault" quest was a bug regarding a side quest in Jorvik. I don't know the name of the quest, but it is about grabbing a guy who's got his ankle broken and help him going back on the bridge. I tried 3/4 times (reloading the save each time) and every single time, when Eivor was putting the guy back on the floor on the bridge, he kept being stuck and couldn't do anything. Eivor was fully stuck. I had access to everything (hud, map, inventory etc...) but couldn't move at all (keyboard and/or xbox pad)...
    That's the only problem I encountered in Jorvik before the completion of the territory problem.

  • PottumWasTaken
    17 posts

    Oh, I did that quest before 'Closing the Vault' as well, but that was quite a bit before, I think.
    But I had no problems with this quest.

  • K3nnythe13ed
    3 posts

    Reloading from a previous save worked but is still not ideal. I was able to skip through pretty much everything. Since i knew where to find all 3 order members i didn't do any of the quest but rather went straight to the locations. I didn't speak to anyone about the wine and did accuse Audun straight away.

  • Hnvct_
    1 posts

    Hi !

    Same problem here, except I did get to talk to Randvi. The little pawn on the map changed to a raven, so I went on to another territory and when I came back to Randvi later, Jorvik was back as unpledged. Tried to repledge it but I don't get any quests and the game tells me to kill the Vault, except, well, he's already dead... I have 60 hours of gameplay and no other save, so I can't go back before Jorvik.

  • Magic_Unicorn_6
    1 posts

    Hello !

    I have the same probleme but for east anglia, rigth after the wedding, i got the bracelet but i never got the quest to report back to randvi.
    Est Anglia is not blocking my progression but i'd like to validate it to get the colony buff.

    Furthermore the support form on the site keep saying that i can't open any issue.

  • Zadkiel_
    4 posts

    Yes, reloading a older save works but ... I didn't really pay attention at first about the pawn so as I got the "Jorvik arc completed" when I reported back to Randvi, I went full for Vinland, then Essex, then Sussex ... So basically 22h more. No way for me to go back with an older save that represent losing basically 4 full days of playing ...

  • dr_project
    1 posts

    Same problem, I notice when I went to take the Jorvik Quest Dag was behind me following me inside the long house and he Glitched out as soon I got in the room with randvi , I completed the quest went back to Randvi and I had the Fight with you know who. After that I talked to randvi and Jorvik wasn't on the map as a alliance but in the next alliance quest I took the people of Jorvik came to my aid? Completed that quest and went back to randvi and pledged to jorvik AGAIN but no quest update in start menu saying what I was suppose to do. now I'm stuck

  • AraAra_Ricardo
    1 posts

    We need an help other than ( reload a save ) because i have like 30 hours of gameplay destroy by doing this ansd should do a lot of area to succeed jorvik

  • Its619SLiM
    1 posts


  • Tharxs
    5 posts

    This has now been fixed for me with version 1.0.4

  • Meda02
    2 posts

    It's fixed! Good job and tysm Ubi Montreal 🙂 I'm excited for the ending.

  • Zadkiel_
    4 posts

    Yes it's fixed !
    Straight after reloging in, I had the message to talk to Randvi to close Jorvik !

    Good job guys, thanks !

  • Signup518
    2 posts

    Is anybody else having the same issue with Eurvicscire? I went and completed the arcs up until Wincestre and didn't notice until all other territories has been completed that Randvi never accepted the Eurvicscire quest being completed. Maybe this had something to do with having to talk with her after Hytham tells you about Wincestre? I can't progress with the main storyline since I am committed to Eurvicscire again but already finished the arc and completed all other territories.

  • RussianstylePL
    2 posts

    I have similiar problem in Jorvik with first story quest. I spoke with boy in the port, the Guy next to barrel and dockmaster but than the quest dissaperd from screen. It exists only on The map but without the marker. I tried reinstal The game, fast Travel and meditation but nothing Helps . Now i am doing other regions but eventually i will have to go back to Jorvik.
    Please help.

  • poo_t1
    1 posts

    Definitely isn't fixed, I'm on 1.04 and the bug still remains, rolling back the save isn't doing anything either.

Suggested Topics