ubisoft forums

Quick Suggestions

  • XenomorphRNA
    2 posts

    Eivor is saying the same three sentences over and over, I can't get it to stop, really annoying, and overdesign II seems glitched, i wasted hours on this trophy , did everything required and trophy won't pop, i'm going to have to walk away from this game until its functional.

  • Saphira-97
    1 posts

    In the Jotunheim quest, "A Feast to Remember" you're supposed to follow Gunlodr from her home but she won't move any further. I tried reloading a save and nothing works

  • Deadmennwalking
    21 posts

    @samuel_aung Not sure if this is will help, but... I did a raid today and the raid didn't complete when I collected the last "force open" cargo chest. Instead the raid completed later, when I was walking around the monastry and came across, then killed, the last enemy.
    Could your raid location still have an enemy not killed?
    Have fun and may RNG be in your favor.

  • Deadmennwalking
    21 posts

    Bakers Plaint quest bugged.
    I have also got a Bakers Plaint quest bug. Built the bakery, spoke to Tarben, he asked me to help retrieve some grain, agreed I could help, got error CE 34878 e, quest is no longer available and Tarben does not wish to talk to me.
    posted this eleswhere but figured I might as well add it to the list of bugs noted in this thread.
    Have fun and may RNG be forever in your favor.

  • Shirokurou
    2 posts

    When you have a spear equipped, it hilariously shrinks down when holstered... But if you tilt the camera down or up (as long as you get closer to the character model, the spear extends to the in-hand model.

  • XenomorphRNA
    2 posts

    @xenomorphrna This is triggered by returning from Jotunheim and using left D-Pad to call horse, Eivor then says "it works, the sheep can hear my whistle".. and after that Eivor repeats 3 sentences ad nauseum.

    Using the contextual menu to call in the horse avoids this bug but you must not use the D-Pad to call in the horse at all.

  • guest-GfQED0mF
    1 posts

    I cannot collect the flying paper located in sciropescire near the world event "Paola's Dream." The floating leaves are animated but the paper is not; it is totally static; and the artifact icon on the compass hud doesn't shine like it's supposed to when in proximity to an artifact. When I approach the flying paper it remains static and I cannot collect it. This is preventing me from completing Sciropescire. Please fix.

  • GhoulKiddo
    4 posts

    Can't play dice or do activities with Tarben after romancing him. I just have a long load screen and then Evior just pops back up and is able to move around and I cant interact with Tarben anymore. After running around I get thrown into another load screen and im at the dice table and it freezes and I cant do anything.

    1 posts

    Hi I'm playing on xbox. I love to fish in the game. I have put so many hours into exploration of the map to find different places to fish.
    I am finding a lot of the rivers and ponds are randomly generating a reoccurring bug where some fish hooked appear above the water line when resisiting against the line. If this happens, the fish can not be caught.
    Its happened about 10 times now out of about 2 to 300 times of fishing, maybe more?
    Also still having so many issues not being able to collect Opals in certain place's and some collected are still showing on the map afterwards
    This has to be addressed very soon please.

    Why does Eagle vision not detect a killed animal?

    When you open one of the large loot raid chests in the monestarys, climbing above it if its against a wall causes an issue if you drop down on top of it opened. You will fall constantly and be stuck until you die from the fall.

    The old man looking for his daughter Rose mystery is also very bugged.

    Counting stones mystery has a black screen issue after the last stone count.

    I have loads of instances where a fallen enemy has loot to collect and yet collecting that loot shows nothing collected on screen. This is very random, but often throughout the map.

    So happy with this game though despite the many teething issues. I have currently been playing for 191 hours and I'm no where near done yet! Lol.

    GT xPEx _JUDGE


  • raz_nahmias
    3 posts

    @dirtyyy103 i have the same problem ... cant lunch/find/something with the "holy day" mession
    dont know what to do...

  • Pataco15
    2 posts

    Has anyone encountered an issue with the quest to capture Lady Aethelswith at Templeborough Fort? I completed Rumors of Ledecestre but now I have nothing in my quest log to go to Templeborough. Its just simply empty and says I have no quests available. I did however make the journey to Templeborough Fort and located Sigurd and talked to them triggering the cutscene but still nothing. I have no idea where to go next and no quest available to track. I tried completing other quests around ravensthorpe, exiting the animus, reloading a save, and even uninstalled the game. Still nothing. Can anyone help?

    Playing a digital copy on PS4

  • N-KaLel
    1 posts

    I’m at essexe and there’s one mystery I can’t talk to the concerned person is the one on south between maeldun and wulfaswic ... is there a patch coming I faced so much bug ... or I had another one in Vinland there’s a guard in possession of a wealth and when I spawn there is already dead ( maybe I killed him before) but no possibility to loot the wealth on him. I tried to save and load my game. Doesn’t work. It’s just so frustrating when u try to complete the game at 100% and u can’t because of glitches .... please help

  • amorgan62
    1 posts

    I try to give my medallions and codex pages to Hytham but it won't let me select either just have to go and what you do here

  • rawrvaciousrae
    2 posts

    Can't purchase anything with opals. The selection key locks to the bottom left and won't let me scroll through options. Really discourages me from taking any contracts since I cant redeem them.

  • matti_lea
    1 posts

    Hey there!
    The quest to bring thorbjörn to the market isn't working because thorbjörn is always returning to the sheer of hraefnathorp and doesn't follow me (by ship, horse or other ways). What should I do?

  • nicknaum
    4 posts

    @amorgan62 you have to have the exact amount he is looking for to give them to him, you can't just give them to him one at a time.

  • isjbmejbisme
    1 posts

    After saving Fulke I choose not to go see the runes right away now I no longer can talk to Fulke (She is standing with Sigurd but there is not option to speak)

  • ArielSakura
    3 posts

    Playing "Childhood Sweetheart" as male!Eivor, When Birstan asks Alfrida if "Eivor has told you all" Alfrida replies "Aye, she has." Nothing major, just a dialogue typo.

  • Gmoore1992
    1 posts

    I cannot activate a game of Orlog, this is game breaking as I need this is order to find an order of ancients clue

  • DRaKoSuLe
    1 posts

    Hi everyone,

    Is there anybody else having problems with the feast? What is the point of upgrading the settlement if I can't use the feast option to buff my character, it's quite annoying.
    After I launch the feast, I wait a bit for the event to load up, after the loading is done, I just see Eivor in front of the longhouse, in the same spot, unable to move, together with some random npc's from the village which are gathered beside him.undefined

Suggested Topics