ubisoft forums

Quick Suggestions

  • Pikazard2005
    1 posts

    I have this issue with Suthexe chest that should be in the north west corner of the map, under that large tree.

  • CapturedInk5274
    1 posts

    I can't pickup the ingot treasure that is on a body in vinland (hvallgrof outpost), the person with the treasure is dead but I can not get the ingot. It's my last piece of treasure in the game. Is there something I can do to fix it without uninstalling the game? (ps4)

  • Rafe_Harwood
    2 posts

    @capturedink5274 find the body that the treasure is on and burn it. It needs to completely disappear. Now go to a fast travel location and come back to the camp. The guy should be alive again 'Hail Odin!'. Kill him again and it should drop for you 🙂

  • Rafe_Harwood
    2 posts

    Having the issue of missing rewards on XBox, with the following maps:


    And the reward obtained but map not dissappearing thing at Oxenefordscire.

    I also notice this problem, although being around for a month, does not show up on any of the 'known issue' lists. It might be nice if it actually made an appearance.

  • VasilyZaitsev42
    19 posts

    Bump same problem here

  • nippy93
    2 posts

    Reading these threads solidifies my feelings. No more preordering from Ubisoft. I've seen indy games on Xbox preview with more active support and they dont cost $100.

  • RavenWJF
    2 posts

    I have both the Ledecestrescire and Oxenefordscire Hoard map bugs. Both of the maps are in my inventory and I have gone to both places, no treasure. I have done the above as well....quit the game, reload, tried different saves, no treasure showing up. I am sure I am in the right spot because I have googled both of them. Hopefully this gets fixed in an upcoming patch!!!!

  • Ubi-Baron
    Ubisoft Support Staff 798 posts

    Hi all,

    Just to confirm, there is a fix planned for these issues in an upcoming update, but at the moment we don't have an exact timing on that update.

    Official Response
  • Drizit79
    1 posts
    This post is deleted!
  • dusty6983
    1 posts

    @nippy93 agreed. So happy I didn't pick up any of their other ps5 titles. Shame on me for thinking they would put out a finished product.

  • RedeyeJedi3
    8 posts

    @ubi-baron That statement speaks volumes to the strategy Ubisoft has for their big title releases. It’s quite a shame that even in today’s day and age, your loyal customers still have to suffer through negative experiences when taking time out of their days to come and report issues to your devs.

    Why should we do the work of testers, for free? Why would the game release with these issues, without a very defined timeline for fixes if it were properly tested and vetted prior to release? I’m lobbying for Helix credits in light of the multiple issues I and so many others have reported.

    Glitched out opals
    Big Mackerel and Big Flatfish spawns
    hoard maps

    PS - I thinks it’s bogus that if you did not get the Overdesign II achievement in game early enough, when there are still “hard” enemies on the map (denoted by a red skull), you can’t do it when you’re max rank. Why? Because this game doesn’t offer any enemies beyond 400 power. What a joke. I’ll tell you this, I won’t be spending any of my $ to purchase the season pass if the additional content doesn’t offer enemies beyond 490 (which is the true max power once you have all 90 mastery points). the Beowulf story arc is rated power 55. Grendel can be assassinated easily and later there’s a fist fight with his mother? Pffft

  • ImaginaryRuins
    418 posts

    @redeyejedi3 Agreed. I am not saying the game itself is bad; in fact I love it even more than Origins and Odysseys, but the no. of glitches and bugs are simply unacceptable.

    1. Opals still seeable by the Raven in the air despite they are not present
    2. Legendary animal trophies
    3. Duplicated Asguardian ship cosmetics (due to fishing store reward) and duplicated armors (due to tattoo shop)
    4. Treasures not spawning for several hoard maps (Ledecestrescire, Oxenefordscire, Eurvicscire)
    5. Fish despawning and big mackerel, flatfish, eel not spawning at all
    6. Multiple items wrongly remain in the Inventory despite having used them

    Please Ubisoft get them fixed ASAP.

  • streethawkfan
    14 posts

    @imaginaryruins Also fix Reda, can't do Viking for Hire or trade opals for gear...

  • NutellaToastNer
    1 posts

    The treasure hoard doesn't appear even though I found and looked at the map. I reloaded my save file and checked the same spot later but it doesn't appear.

  • ImaginaryRuins
    418 posts

    This issue has been reported multiple times, for a long time as well. Happened to my save as well; reload does not help.

    From what I know, Ubisoft is aware of the issue, but when it will be properly addressed is not yet officially revealed.

  • Vanyar1
    10 posts

    It may be wise to make a "mega thread"/"post here thread" for the treasure hoard bugs as there are a lot of threads regarding these kind of bugs. That mega thread should then be posted in the "Reported Issues" thread so people know that it's being investigated.
    The reason I'm suggesting this is because I was wondering if those bugs have been noted at all, and I only stumbled upon the answer from the Ubisoft guys here by accident. I'm pretty sure a lot of people are wondering the same because in most threads they can't find an answer.

  • TheChaosEffect_
    1 posts

    @mattacus94 I’m also having this exact problem in Ledecestrescire. I hope they come out with a fix soon!

  • RedeyeJedi3
    8 posts

    UPDATE: After the recent 1.1.0 update, 1 of 3 reported treasure hoard reward locations has been resolved. My affected locations were:

    Grantebridgescire - Was able to loot this treasure, and also have the treasure hoard map leave inventory. Received Snakebite Scheme (hull) 🙂

    Oxenefordscire - Was able to loot this treasure and get the rewarded XP. Treasure map still in inventory. No reward received. 😕

    Eurvicscire - No treasure at destination. 😠

    On another forum thread, it’s also confirmed this 1.1.0 update did NOTHING to address the issues with Big Flatfish and Big Mackerel spawns.

    At least all the slain legendary animals do properly show mounted in the great hall of the longhouse in your settlement.

    I’m done with ACV until Spring 2021. I shall then wait to peruse reviews on the additional content for Francia to see if it’s going to be worth the $39.99 that the Beowulf arc is presently clearly just a joke. Enemies in the new content must be beyond 490 power or I’m not buying.

  • Sterben_Nacht
    69 posts

    @redeyejedi3 just don't bother buying it. let it sit until it's half off.

  • ErickAshlock19
    1 posts

    @caponeor2 I am having the same issue as well on PC tweeted them several times and no response. only reason i ran into this thread is because i was having a issue with him acting drunk now and figured i would look for some more bugs.

Suggested Topics