ubisoft forums

Quick Suggestions

  • Stonemile123
    2 posts

    I am having issues with bleed the leech. I killed the arrow but unfortunately bleed the leech mission prompt does not showing up near the docks. Can anyone help?

  • Stonemile123
    2 posts

    I'm in Lundon. I killed the arrow. Now it is time for me to move to the leech. For my research I can see that the leach mission starts near the docks. There was nothing there. I was done to the docs. There is no mission prompt. I am 47 hours into this game and now I cannot move forward because I could not complete London. Please provide me with the work around.

  • Gawdamahty
    2 posts

    I killed the Leech, and did not get a cutscene. The order tree shows that she's deceased, but the game will not let me proceed in Lunden. I'm on Xbox One. Please help, this is super inconvenient.

  • xlegionx33
    5 posts

    I'm 65 hours in. I'm hesitant to restart everything because I don't want to replay everything just to have it happen again. So I sit here and wait for the day they may fix it. It's really frustrating.

  • Calmrg
    1 posts

    I am unavailable to start the quests in Ledecestre. Nothing is showing when you choose Quests. I got to see Ivarr on top of the tower but there are no markers. What should I be doing? I really don't want to start over. Thank you

  • KiliLovesFili
    1 posts

    Same as everyone else. I got the cut scene originally then went to save and accidentally reloaded a old save and then the objective never triggered for me. And in fighting with it I no longer have a older save. I’m super upset and like near tears. I haven’t had an issue with the game yet ans now this one small thing is stopping me from progressing. Is there a way to restart the mission? Something? Anything????? I paid 100+ for this game and not even half way through it.

  • UncleNurzum
    1 posts

    @ubisoft @amchan88 I am having the same issue. I kill the arrow and talk to Stowe, he tells me that Elle is waiting at the docks. He is nowhere to be seen. The Bleeding the Leech mission doesn’t appear on the mission board

  • PikaMewPix
    5 posts

    @medved_nbg I managed to open a support ticket and all I got back was "we are aware of this issue".

  • Maciotti
    16 posts

    I have a similar problem: after completing "Bleeding the Leech" and then "Firing the Arrow", the last mission "Smashing the Compass" doesn't appear on the map.

  • FrozenQueen1988
    3 posts

    I have the same huge problem with the mission in Lunden, when you need to find and kill the Leech/ While I check mission tracking in quests, the marker on the map does not appear, and even after killing the target, the quest remains active and incomplete. Therefore, I cannot continue this storyline. I tried to kill the target many times and in different ways - only the information about the discovery and murder of a member of the order appears, while the mission remains incomplete, the task is still active and there is no further marker of the next stage of the mission. How can this be fixed? I would like to continue the storyline in Lunden, and with a broken mission it is impossible. Neither loading of other saves nor temporary changing of plot to another alliance helped. The game is just broken. And while I'm able to accept and tolerate minor glitches or cosmetic bugs that don't affect the plot, this huge game error is unacceptable. Dear Ubisoft, please fix it ASAP and don't upset your fans ...
    I would like to add that the problem appears on both PS4 and PS5 console.
    If someone managed to deal with this problem or has a solution, I will be grateful for your help.

  • Medved_Nbg
    18 posts

    @frozenqueen1988 there is no solution for this and the devs just keep silence since two weeks already

  • PotatoDuDe02
    12 posts

    @medved_nbg They are working on it, it is a long process, and fixing bugs isn't as easy as "hocous pocus fix this issue". It can take months if the bug is big enough. Besides the developers have tons more bugs to go through, and half the time they can't recreate the issues. It's a shame the issues are there to begin with, but that is precicely how games are upon release. Some are worse than others, but all you need is patience. I too have waited 2 weeks for my issue to be fixed, and I will just simply wait. let it take a month, two months, I'll even wait till summer next year. The game is amazing, and even though I payed for it and basically lost it not even a week in, I had so much fun, and I can't wait to have some more fun soon enough!

    It's all about patience. There are people behind this, who genuinly try to fix these issues, but all I see are people shouting at them, just because people do not understand how hard this really is.

  • WaxMandible
    3 posts

    They posted on Twitter about a patch coming this week. Hopefully it addresses this.

  • callumreuben
    2 posts

    I have now killed the Leech and cannot find Erke to finish the mission - I can't complete Lunden because of this. Any help would also be appreciated (playing on Xbox 1).

  • Coolasme
    1 posts

    @ubi-baron Have problems with the same quest. Im on "report to Erke" after I've killed the leech, but he doesent do anything. tried multiple times now but still bugged....

  • vKomplex
    3 posts

    I've encountered several issues in Lunden, both with the main story arc as well as several mysteries.

    During Bleeding the Leech, after tailing and defeating the blacksmith, my next prompt was to Find and Assassinate The Leech, but there was no map marker. I ended up finding The Leech on my own and killed her, but there was no Confirm Kill option and no subsequent cutscene with Odin. So even though the Leech was dead (and showed up as eliminated in The Order menu), the quest never updated and I was unable to progress and complete it. I ended up having to reinstall the game on my XBox Series X, and reload a save 3 hours earlier before I killed The Arrow. When I reinstalled and reloaded, I was able to progress through Bleeding the Leech and complete the Lunden arc with no issues. It sounds like you were able to assassinate The Leech and Confirm Kill in order for your next task to report back to Erke updating. Considering your issue of Erke not appearing, I would try meditating to pass some time, reloading a previous save, or reinstalling the game on your PC or console as a last resort.

    I believe what triggered the issue for me was the fact that I got distracted by some world events, artifacts, and wealth opportunities while mid-quest, and this messed up the flow of the quest. I acquired the wealth in the northeast corner of Lunden and completed The Last Flight of the Gyldan Sparrow and Falling Stars in between defeating the blacksmith and assassinating The Leech. I have seen other people (myself included) have issues where the world event NPCs do not appear until the Lunden main story arc is completed. I think this is due to the fact that while you are eliminating members of The Order during the Lunden main story arc, the town goes into a sort of disarray where commoner NPCs are distrustful/fearful towards you because they initially believe The Order members to be good guys.

    After successfully completing the whole Lunden arc, post reinstallation and on a previous save, I was able to complete Falling Stars, Flyting, and War of the Collectors world events without any issues. I am now having issues with the Demon Odor of the Tithe (the guy stuck in the warehouse doesn't register that I created a clear path for him; this issue also occurred during the main story arc), and Last Flight of the Gyldan Sparrow (the Norse Woman is only in her normal spot at certain times and when I kill a fish with my bow, the fish despawns so I can't loot it, and when I try fishing normally I get no bites, even after sitting with my fishing line in the water for over 5 minutes; I was able to complete this one on the save that I ultimately had to overwrite in order to progress in the main story).

    Sorry for the long explanation, but I hope it helps. Long story short, I am going to avoid triggering any bugs by completing main story quests in full before going off on any wealth/word event tangents (unless I have a clear map marker for my next task), and I am going to create a new save before initiating any main story quests/world events in case I run into any bugs and I won't lose 3-4 hours of progress like I did yesterday.

    If you have any tips regarding Demon Odor of the Tithe and/or Last Flight of the Gyldan Sparrow, I'd really appreciate it.


  • Nike3379
    4 posts

    I killed the leech but still says find and assassinate the leech PS4 I have over 52 hours played

  • TheBirdManHQ
    Original poster 20 posts


    The game shouldnt release with a bug the doesn't even let you play the main story.

    I paid $120 for this game to be stuck at 20%

    I give zero fucks with how many other quest are broken.

  • Medved_Nbg
    18 posts

    @potatodude02 polishing the game before releasing it can't be harder than fixing bugs after. But I guess it's the management we have to blame.

  • Medved_Nbg
    18 posts

    @thebirdmanhq no need to get stuick, you simply can change to another alliance's arch while waiting for a patch.

Suggested Topics