ubisoft forums

Quick Suggestions

  • krvpt.
    63 posts

    @ava0723 they didnt fix anything, i still cant even launch the game despite being over recommended specs.

  • AVA0723
    5 posts

    Yep.. can't even play it. Putting it down for now, maybe even returning it. Might buy it back when they want to wake up and work.

  • krvpt.
    63 posts

    @armydoc7yrs yeah thought this patch would let me launch the game, nope. still cant launch the horrid mess despite being over recommended specs

  • AVA0723
    5 posts

    @krvpt the games trash bro...

    It's fun, but this sucks

  • krvpt.
    63 posts

    @ava0723 yup, gonna get my refund and buy cyberpunk. something actually worth waiting for

  • Dylave1
    1 posts

    Just requested a refund. Don’t hold your breath and waste your time waiting for a response, a fix, or trying troubleshooting tips on forums.

  • Petteflet88
    348 posts

    @dylave1 i already requested some days ago. F this game

  • jdfdemocracy
    11 posts

    They also tried an old save and still had same results just fyi on your theory 👍

  • DGM1992
    9 posts

    yeah absolutely no fix on patch 1.04. None of the crappy “work arounds” work either if anything it’s made things worse!! Random dead horses, Ubba now just creeps around and the quest marker hardly shows up at all!! It’s beyond a joke now... come on how much longer have we got to wait!?

  • Spier1991
    15 posts

    I use to think unity was the biggest joke with its bugs but dam i was wrong. Atleast that game they were able to patch. Can we get a explanation on what exactly is causing this glitch? I saw somwhere on here if you "raid" tamworth before you do this quest thats what causes it. If thats the case they should include a warning outside the fort "do not enter unless completed sons of ragnar". If that is what causes it thats dumb o you explored a open world game saw treasure nd decided you should take it? This should teach you a thing or two.

  • Petteflet88
    348 posts

    Unity release was a masterpiece compared to this rubbish

  • ripley1408
    3 posts

    Still can't talk to ubba. The option just won't pop up.

  • DaltonB13
    2 posts

    Even after patch 1.04 for the ps4 “the sons of Ragnar” mission is still extremely bugged. I’m at the part where it wants me to talk to Ubba but the option to speak to him doesn’t come up. In the same area sometimes I’ll go to try and see if it’ll let me speak to him and there’ll be a boat spawned with the horses. With this being a main mission it’s pretty much a game breaking bug

  • skullr4fael
    3 posts

    Bug with 'King Killer' mission, Ivarr is stuck before Cutscene

    Ivarr is frozen right before the cutscene, which will start the attack, if it starts. (Regicide) (Follow Ivarr)

    Has anyone else had this problem? does anyone know how to solve? @ubisoftsupport support hasn't responded to me in days.

    Ps. The game is already updated for today's update.

  • Agony567
    16 posts

    Delete game and reinstall again i told you guys on the post before,it worked for me , try it all your Saves are SAFE cuz cloud saves are in ubisoft launcher folder,game is just in Ubisoft folder try it for me it worked

    I finish The Ragnar Sons quest all okay now

  • guest-lImTdICF
    3 posts

    Fantastic news! A new update that fixes quest bugs...

    but not the Sons of Ragnar one 🥴

    but at least my whistle can be heard further away now - 10/10

    haven’t played the game for a week whilst waiting and finally something happens and it fixes nothing.

    Refund needed

  • Maggotmel
    8 posts

    This has been talkes about on different forums.
    When you're at the docks and had an interaction with Ubba (had the cutscene to talk about the sons ready for battle) nothing happens.

    First there were boats on land, thats fixed(?)
    Suggestions are:
    Turn off and on again(realy😒?!)
    Travel to Norway and back (do this with and without quest marked)
    Exit/enter animus
    Change gender(and repeat the above)
    Finish different quest
    Reinstal the whole game
    start a different game(i'm 80 hours in +10are from trying to fix the bug, im not going to start again)
    Nothing works for me, i was waiting on the 1.04 patch update, but that only solved the boats.

    Ubisoft what now?

    Sorry for the bad grammer, i'm dutch👍🏽

  • Petteflet88
    348 posts

    @agony567 on PC maybe. I am on ps4

  • Petteflet88
    348 posts

    @guest-limtdicf the patch fixed nothing. Not only for us but for nobody it seems

  • Petteflet88
    348 posts

    @skullr4fael support reacts to nobody. Worst company i experienced.

Suggested Topics