ubisoft forums

Quick Suggestions

    94 posts

    @rathma86 same here dude, I hope they fix this soon.

  • Dark-Coco
    17 posts

    I have encountered a game-breaking bug a fair few hours into my game (as of now, I'm at 14 hours, which has been roughly 2 days worth for me). I've noticed a few people are stuck where I am as well when I tried to look for help, but there doesn't seem to be a fix yet, or even an address of the issue, so I'm not sure they are aware of it yet, but it is defintely real, and also a huge pain to deal with. I don't know what to do other than start a new file, but I want to see if there is a fix first before I lose all my progress.

    There is a mission called 'Sons of Ragnar' where it tells you to 'Speak with Ubba'. I was successful in speaking with him, but the next part of the quest did not activate, like it hadn't acknowledged that I had spoken with him. The quest is forever stuck on 'Speak with Ubba', and needless to say, I cannot proceed with the main story at all.

    I'm also unable to load to an earlier save file before I tried to quest, as I have none left.

    I would love a response from Ubisoft. I tried reaching them on Twitter but no response (probably missed it).

  • BigHarv87
    1 posts

    I had this problem, mission bugged for me and couldn't get ubba back. I went to Randvi and pledged to a different clan on the alliance map.

    After completing the missions in Grantebridgescire I went back to Randvi, opened up the alliance map and repledged to Ledecestrescire. That's when it the quest objective icon popped back up for me. And I could speak to ubba again.

    Hope this helps, p.s I have a feeling if you don't go along with the missions as they go your likely to encounter some bugs...

  • GHOST000016
    2 posts

    Won’t let me speak to Ubba. Saw the cut seen with Ceowulfs son, and that’s as far as I’ve gotten. When will this bug be fixed? I’ve basically got everything that’s available at the moment, just want to continue on with the story.

  • Nicotaco87
    24 posts


    Already Found a solution?

    I've deleted and reinstalled game... So after work today i'm hoping it's fixed

  • Apsalara84
    16 posts

    Having same issue, have tried all of your work around and none have worked. Closes save that is not glitched is 8 hours back. Need a fix ASAP, which now just deleted itself and saved over with the glitched save, when I tried to load it. So now it's even further back. Ubisoft fix this wasted days for nothing.

  • PaulDelestrac
    14 posts

    Same problem here started on One X and I hoped it'd go away when I receive my Series X... I received it and launched the game... I'm stuck in the exact same situation... Cannot talk to Udda... Completely stuck in the game, please find a fix...

  • xX_Tiger_Xx33
    2 posts

    Same, the scequence with Ivar started and after that everybody just stood there but nothing happened, and now I can´t talk to ubba anymore. The only thing you can do is go back to Randvi and make a different alliance in Ledecestrescire. I hope that they will fix it in the meantime.

  • xX_Tiger_Xx33
    2 posts

    @bigharv87 Did you talk to ubba beforehand, so did the scene start but nothing happened and then you did go back and repledged to Ledecestrescire or did you not even speak to ubba. Cause i think your solution only works if you did not even speak to ubba before.

  • Shadowpenguin-8
    1 posts

    I’m 18 hours in, and can’t complete “The sons of Ragnar” quest. Im stuck trying to speak with ubba near the docks but the speak icon won’t pop up or work. A random long ship has also spawned in the path he will lead me if it were to work. I assume this glitch has occurred because I went and did other things before trying to do this step.
    Secondly, in the anonymous anomaly the light beams lose their interact button so I’m unable to complete it. I’m playing on ps4

  • DavidRLBC02
    2 posts

    The ragnars son quest won't appear for me at all. I choose the other quest first. It just disappeared after a few missions. I've already spent a lot of time grinding too not knowing that it's a glitch

  • Nicotaco87
    24 posts

    @rathma86 same problem here. Even tried with reinstalling game and playing offline. Nothing works...and I have the feeling Ubisoft doesn't give a f*CK about it

    1 posts

    I’m having the same problem is there anyway I can pasted it please

  • Mateipaduraru
    1 posts

    Same thing here, tried pledging to the other 2 regions and after completing them still doesn't let me talk to Ubba. Boat is not on the ground anymore however the blue pin appears and disappears everytime I sync in a new location. With more than 25h in the game I would hope Ubisoft does something to fix it so I don't have to lose all this time for nothing

  • DGM1992
    9 posts


    I am having the exact same issue! Tried reloading saves and pledging to other areas and still not working! Also have the issue with a longboat just stuck in the land! It’s really annoying I expected better!

  • guest-U1XKQUqG
    1 posts

    Cant speak to Ubba, Quest not working, boat was in the sky etc very fun but bugs need sorting out.

  • shop37B9CCF47
    4 posts

    Same problem. After the cut scene with Ubba/Ivar/Kid the kid just walks off and Ubba/Ivar stand around like NPCs. No interactions available. I tried traveling back and forth between Norway/England, reloading the game, changing genders and nothing worked. I loaded an older save and the same thing happens on top of a [censored] boat popping up in the middle of the road where the horses should be. I'm kind of concerned regarding the QA for this game if these kind of game breaking bugs exist. I saw in another thread where they said to start a new game but I'm quite a ways in as it is. I'd rather refund at this point and get this in a year for a fraction of the price and in working order....

    6 posts

    @progamerzlolz same it’s annoying as that’s the main mission to do and carnt move on with out it never has my game done this before hope they fix it soon

  • MFrancois136
    1 posts

    @progamerzlolz same problem here. Seen a few threads on Ubi’s website and appears it’s a rampant issue. I’d be shocked if they don’t have it fixed within the next update or two.

    Also, I’m getting a lot of glitches on raids with the large chests. Oftentimes I’ll call another raider over and nothing happens, or I get the little !-box that a raider is there, but when I hold 🔼 nothing happens. Each time I’ve been able to leave the area a few times and it eventually works, but it’s taken up tk a dozen retries.

    2 posts

    @ghost000016 same they need to do some actual work and fix the game been stuck here 2 days already.

Suggested Topics