ubisoft forums

Quick Suggestions

  • Petteflet88
    348 posts

    Like many others, I encountered problems with the 'Sons of Ragnar' quest.
    I cannot progress with the story since Ubba refuses to talk to me...

    I tried:

    1. Dying to restart the mission
    2. Meditation.
    3. Travel back to Norway & back.
    4. Restarting the game.
    5. Pushing Ubba & others with my horse.
    6. Switching to other quests
    7. No, I cannot go back to older saves. I accepted the mission and go do other things (+/- 30 hours).

    Nothing worked. And it seems like it doesnt work for a lot of players...
    I am so saddened because this is gamebreaking. I refuse to start over & I am thinking about quitting...

  • Jublet_inc
    3 posts

    Just going to have to wait for a fix I guess there's no way they can expect people to restart...

  • mjane79
    3 posts

    My boyfriend has this bug and can't progress. He tried going back to an earlier save but it still didn't work. He has a boat in the road but can't speak to Ubba.

    I was able to speak to him and had no boat in the road. We are both playing on the same PS4.

  • lucass1985
    1 posts

    It's being 6 days now without any kind of help. Some ETR would be useful.

  • xnicxbaileysx
    3 posts

    Still waiting for this to be fixed

  • DirtySwaggEr93
    25 posts

    @lucass1985 they really dont give a f**k just left us here all debating to refund this game and get it cheaper in a few months. They have done everyone over. No update to when its fixed.

  • DirtySwaggEr93
    25 posts

    @lucass1985 been waiting since launch day. Starting to think ubisoft dont actually care. No reply from twitter and no update on when this will be fixed. Ive uninstalled it on xbox one and re-installing. If it still doesn't work i will be getting my money back.

  • StinkyRichard
    2 posts

    Same issue, happened Saturday night. Had the conversation with the Kings son, then spoke to Ubba, or tried to as nothing happened. Left the animus, went back, went to Norway, went back...nothing. Ubba stands there with mission icon over his head and no option to speak or do anything. Pretty big bug considering this is directly affecting the storyline...

  • DirtySwaggEr93
    25 posts

    @stinkyrichard its made me so mad. I know its just a game but people have spent good money for AAA game and not getting the experience because of things like this. They should not have brought it out until it was fine. Look at cyber punk theyve held that back a long time now but theyre making sure things like this do not happen im guessing.

  • broyak
    8 posts

    It's been almost a week since launch and still no word on a fix for this ridiculous bug.... I'm in the verge of asking for a freaking refund.... I bought the Ultimate Version because I am a huge AC fan and what's worst is that I was enjoying the game. That is changing quickly.

  • SyndicateRain92
    1 posts

    @petteflet88 i feel the same way in regards to this bug, ive gone through this game and clocked almost 35 hours and when i try and follow the questline something happens, be it theres a beached boat ontop of Ubba or simply his quest icon is not there to even continue, like you i have tried everything and refuse outright to start over, its appalling that Ubisoft have yet to address these issues after almost a full week of release

  • lamanticora
    2 posts


    I have the same problem from day 2 and now so does my neighbor... This is not just a bug, seems like the game is broken. I start REALLY liking the game but this is too much. PLEASE BE SERIOUS... FIX IT NOW !!!

  • Apsalara84
    16 posts

    @broyak agreed, as well ubisoft has not responded to support tickets I have sent last week. I get you guys are busy, fixing this glaring bugs. But how are so many game breaking bugs allowed to get through at launch. I get a few, but this is sad for a AAA game. Anyway please fix, or refund our money, and let us know when you get it actually working

  • chfb271990
    7 posts

    I think we've more chance of talking to Ubba than hearing a decent reply from Ubisoft.

  • DanteKingM.O.W
    4 posts

    And now there is boat on land!! Still cant speak to Ubba, even tried to go to the next point in the mission, everything is set up it looks like but i cant interact with anyone there either. Annoyed!!

  • DirtySwaggEr93
    25 posts

    @chfb271990 hahaha

  • JJB_Josh
    1 posts

    I have the same issue. Cannot speak to Ubba despite having an icon over his head. No chance im reloading a save - got a level 4 settlement and made loads of progress away from the main questline. Really needs fixing!!!

  • timpaupau
    1 posts

    Quest ragnars Söhne buggt beim uggar sprechen quest kann nicht mehr verfolgt werden

  • Petteflet88
    348 posts

    Another day goes by without a solition. Cool game. -_-

  • rebelhunter15
    3 posts

    @xx_tiger_xx33 did the patch fix this for you or anyone else? Im still stuck

Suggested Topics