ubisoft forums

Quick Suggestions

  • Zerosentry
    1 posts

    I have done 2 playthroughs up until UNWELCOME and I get stuck after saving the to captives in the longhouse.. after the cutscene there is an extended load / save and then I get stuck in the longhouse with Sigurd and Dag and am unable to move (had a 2 hours wait) played through the game again and stuck in the same spot

  • lenx2000
    10 posts

    Hi there i had the same problem,
    In the forum i found the solution.

    1 change your graphics to ultra high on the main menu options(your game will restard)
    2 go to the longhouse(if you are not there yet)
    3 play the cutscene but don't touch any button.
    4 wait until the cutscene ends(until you can move,after the part of the longhouse there is still the cutscene
    5 change back to your original graphics(this restard your game again

    Hopefully this works also for you guys.

  • Nihahs
    2 posts


    I'm sorry that nothing seems to work. Didn't my instruction help you?
    Yesterday I had another idea for a work around. Ubi says the bug depends on the world details but maybe on your computer specs as well, because on many computers the work around works but on many others it don't. Try and ask a friend if you can play on their computer / laptop with your save game. Maybe that could help. Don't forget to save after the bug.

  • Zosin69
    2 posts

    I have issues after the Sequence in the House where the Hostages get found by Eivor and Sigurd.
    After they talked and the sequence ends, the Characters freez and will stay still.
    I played the Mission 3 Times and restarted the Game over and over with the same result.
    I am waiting now since 3 Days. I can't go on with the main - or any side Quest's because i am stuck in the Place.

    PLEASE help.

  • Haak56789
    1 posts

    After going to engalnd and the very start of the game, my characatar keeps getting stuck after the scene whit the two people in the longhouse. i can use mye camera, but all characatars are stuck and nothing i can do, i have tried to uninstall the game and start a new world twice, nothing has worked.

  • Mustafawastaken
    2 posts

    For the people that play on Geforce now! Launch the game from the Ubisoft Launcher one! Even tho you bought it on Epic games Or steam It don’t matter go to the Ubi launcher version (the one that doesn’t have any icons on the bottom right corner) and once you are in the main menu change world details to Ultra high and once it’s at Ultra high Apply and restart! Yes Restart unlike the epic games launcher one or Steam this one actually restarts the game and gets you back in it with the world details at ultra high. Go to the cut scene and just skip (not pressing any bottoms doesn’t actually do anything I have no idea why people say do it! Btw I’m I the only one who thinks that they didn’t betray siguard by going with him and agreeing with him like that old lady said) I forgot her name Good GAming to you folks!

  • Dex2080
    1 posts


    Any news about when the fix for the bug "Cinematic is not triggered after dialogue with Yanli & Rowan" will go live? Really frustrating since the workaround with increasing your graphic settings aint working for me so i cant continue playing the game. Been like this for almost 2 days now and would really love to continue playing.

  • dantrex
    8 posts

    What Do you Mean by
    Launch the game from the Ubisoft Launcher one!
    I dont launch IT by the Valhalla icon in GeForce Now?

  • Hannibal2609
    1 posts

    @nihahs tnx this was the only thing that help me

  • Mustafawastaken
    2 posts

    @dantrex yes used the Valhalla icon but when chosing the Valhalla icon use the one that’s from Ubisoft not epic or steam, it might ask for an activation code just close it and restart the game it should work then

  • Ubi-Raziel
    197 posts

    Hello everyone!

    I have merged you all together as you're discussing the same issue.

    Oour team is aware of this issue and we will have a fix implemented. In the meantime, the workaround is to change your graphics setting from Low to Ultra then try again.

    Other graphics settings may also work, I don't have that confirmed at this time.

    @harrypotter1 You are not the only one my friend. This should fix it though:

    Thank you for your help!

  • freakyyy345
    1 posts

    hello. please whenever i get to the unwelcome mission and i free the captives, the game triggers a cutscene after which the game loads for a long time. after that all the characters seem to be stuck together. i saw a post that i should bump the settings to ultra and itll fix it but when i switch the graphics to ultra, my pc freezes and the game crashes. please help me

  • dantrex
    8 posts


    I didnt install it on my HD. I can only launch it by the GFN app on my Android TV.

  • Aidan99884
    1 posts

    There’s a loading screen that seems to last forever and then you will witness Eivor, Sigurd and Dag huddled together, stuck to the floor. Notably, you would not be able to move and open the map, the game is still running but you will have to open the menu and quit the game.

    I have tried the changing graphic settings and it does not work, and i'm not starting from scratch. I got ubisoft+ just so i could play this game and everyday this glitch is not fixed you are wasting my money....... this has been brought to your attention for a while now but no fix for a game breaking bug?????

    please get me on answer on this so i can play the game or a refund for ubisoft+

  • UbiExcellent
    756 posts

    @aidan99884 Hi there! If possible, would you be able to send over a video of this bug, so I can add it to our report?

  • johnboy202020
    2 posts

    hi thanks i put my graphics to ultra and it worked soon as it saved i had to put it back to low

  • Kuratoro
    97 posts

    @xxdocpaulxx No problemo!

  • Kuratoro
    97 posts

    @toasteroven47 Just got a new thing that someone changed his / her gender as well (besides only graphics). Worth trying out maybe

  • soultrader231
    2 posts

    in the quest unwelcom when you go into the longhouse and you talk to the 2 npc's the character's get stuck and can do nothing at all

    needs a lot of help

  • dantrex
    8 posts

    Its ok it worked for me. But the game is unplyable tonight it is so laggy. It is only me? Is there a way to fix it? i am playing with Bell fibe. My internet speed is 1 gb.

Suggested Topics