ubisoft forums

Quick Suggestions

  • kevzyubi
    32 posts

    @kuratoro can confirm changing resulution worked for me and countless others. enjoy

  • Sharkalisharri
    1 posts

    I have just Eivor and Dag stuck after the conversation is over. Gosunoob's solution does not work for me. I tried several times, hope they fix this bug real soon. It is a game-breaking bug!

  • Teddie.Rex
    1 posts

    I Have the exact same problem. Takes a long black screen time after the cutscene and then i can not move as well. standing in a circle with sigurd and the other dude.. I play on PC

  • JoeReynolds420
    1 posts

    No matter what i try, i still cant get out the longhouse.
    Ive tried everything suggested here. I just wanted to do some raiding after a long day at work
    Will there be a patch coming soon for this Ubisoft?

  • M1nDTr1cK2020
    21 posts

    I managed to fix it by setting world detail on medium, another try if the above doesn't work for soem1
    Not thst we should in the begging get glitches, crashes and all other kinds of bugs and ect, hope at least a new patch fix for a lot of issues will come soon

  • dengthao
    1 posts

    I can’t proceed through the mission

  • K3TE
    1 posts

    hallo ich habe so ein klitze kleines Problemchen bei AC Valhalla und zwar wird bei mir die Cutscene bei der Mission Ungebeten nicht getriggert. Dies läuft darauf hinaus das ich in 2 npcs bugge und mich nicht von der stelle wegbewegen kann. Ich habe schon versucht den Spielstand neu zu lade, hab sogar das spiel neu installiert jedoch ohne Erfolg. jetzt bin ich die Ganze Zeit in dieser Mission gefangen und weiss nicht weiter.

  • markovicivap
    1 posts

    The game will no longer load upon the release of two slaves in the Unwelcome quest.
    Just stay and wont procide to the next sequence
    What to do?
    I give
    100€ for game and now i cannot play.

  • QuackAttack57
    1 posts

    ****NEW FIX TO TRY****
    So it seems to be a common occurrence for people to get stuck on this mission and I have been trying for three hours to get this cutscene to activate.
    Fixes I have tried that may work for you...
    -Changing settings to ultra (If your PC can't handle ultra, you should be able to switch it to the highest settings that you can)
    -Changing everything to the lowest possible setting and putting V-sync as "adaptive".
    -Not hitting any buttons when talking to the two prisoners and watching the full cutscene.
    So far, none of these have worked and all of the posts tell us to wait for an ubisoft fix if non of these work.
    In my case, I use an Xbox one controller on PC to play AC Valhalla and as soon as I unplugged my controller with my settings on Ultra, the cutscene activated
    I know getting stuck here is extremely frustrating so hopefully this works for others as well.

  • kfeaginsiii
    8 posts

    I literally cannot get past the first gameplay area.. I am freezing just running around after the dock. Sadly I guess I will just sit until the next set of patches release.

  • disbkoolin
    1 posts

    All 3 main characters are bunch in together and can't move. All other buttons are accessible besides the dodge or any action buttons. This gets bunch together after the conversation with Yanli the trader on the "unwelcome" quest. I have tried to exit game and come back in but didn't change anything.

  • xXDocPaulXx
    2 posts

    @small0606 I'm having the same problem! any word on a fix? sure would like to play this $119 game 😞

  • Baro235
    2 posts

    I have the same issue

  • Baro235
    2 posts

    it works for me too!! thanks

  • Kwalan
    4 posts

    I have read through the forums and tried all the workarounds. I have set the Global setting to every possible setting and restarted and reloaded and its all the same.. after talking to the 2 prisoners I either load in with Sigurd and Dag standing with Eivor or I load in with Eivor standing with the poet looking guy off to his right.

    NOTHING is getting me past this point... the "official workaround" doesn't work.

  • Arkweave06
    2 posts

    After going into the longhouse and the dialog, the rest of the clan shows up after the horn and the game glitches out, where you cannot move or do anything but enter skills window or put your assassins hood on. However I restart and do it over and still glitches.

  • OlGoat
    2 posts

    Having same problem.

  • BrAinEater_89
    7 posts

    @x_man1202 same thing here .. and im afraid at some point in the game it will happen again

  • Beta_Nation
    3 posts

    @bred-supergingr same thing for me right now.

  • CrystalBovine
    8 posts

    Same thing..Long black loading, screen then charactors are standing in middle of room..unresponsive to any keyboard inputs except <escape>

Suggested Topics