ubisoft forums

Quick Suggestions

    1 posts

    I'm having the exact same issue.

  • GallicShrug
    1 posts

    I have the same problem, what do we do?

  • overXposed
    3 posts

    @gallicshrug stuck for the time being until Ubisoft addresses it. Such bs!

  • overXposed
    3 posts


    So I figured it out guys. Check your game file options under manage content. Make sure all languages are downloaded and installed. Once they all installed the prompt went away and I'm able to continue on.

  • Nemesis135799
    2 posts

    @ubi-spud i can confirm. I get in the boat during seas of fate to go the laylas first section after seeing title screen. It goes to Layla loading screen and infinitely stays there. The game has been out a week and still no resolution to going to England. I can play Norway fine. But cannot proceed to England.

  • DeR7X
    1 posts

    I have a bug in mission Sea of fate when i sit in boat of Sigurnd and they didnt swim to England, boat stucked they stopped to talk and nothing else.
    PC, Digital version from ubi+

    Reset game or change mission to one before didnt work

  • revelstatt
    5 posts

    hi can I ask what platform you are on please

  • Raigo32
    1 posts

    As i go to Sigurd to sail to England, the Cutscene is black for like 3 seconds, they start talking then but the Cutscene Remains Black. After 10 Seconds in sit in the Boat, but nothing happnes and the Boat stays in the "port". So the only thing i can do is walking around in Fornburg, because after sitting in the boat nothing happens.

    I Hope there is a fix or Tips for fixing it , because now its just pain in the a... 😞

  • Poleinvader1939
    4 posts
  • chrisolaus
    6 posts


    Okay so I've had some issues with this quest aswell. 10h total played.
    I refuse to restart and create a new game!

    I've tried a lot of fixes as described above in the comments.

    But I recommend you to try this, it helped me:

    Load a game save before the quest "the seas of fate" when ur supposed to talk to Sigurd at the docks.
    When you talk to him he asks if ur ready to depart to England -
    Press the 2nd option that you're not ready, then run around for a few seconds.
    Then go and talk to him again and press the 1st option.

    Then I got new items, probably the riches from the raids to carry along to England.

    When I got to the ship to sit down the cut scene occurs correctly and the ship went sailin

    I rly hope it works for u guys


    / Chris

  • SuperPower1900
    3 posts
  • TheNotorious574
    2 posts

    Im on xbox and unable to launch the boat off the dock. ive tried doing all the tricks that everyone else has done and nothing. its almost to the point where i want to just get rid of the game due to not even being able to play it. @Ubi-Swaggins do you guys have any updates or anything going on to try and fix this?

  • SuperPower1900
    3 posts

    @chrisolaus He does! I wait 5-10 min and that i get in the boat!

    Thanks mate!

  • Ubi-Litten
    Ubisoft Support Staff 179 posts

    Sorry to hear you are experiencing this, if you are still unable to progress past this point could you please provide a short video clip showing this loop and we will be sure to get this looked into for you.

    Official Response
  • i3lackhaze
    1 posts

    Not working for me, submitted a case. I get to the middle of the water and boat stops.

    I've tried

    • Letting the game sit for up to 2 hours to see if the boat would move.
    • Found an earlier save
    • Loaded an earlier save and waited 30 mins before doing the mission
    • Tried doing other things before getting on the boat
    • Catching the random guy swimming and talking to him before boarding the boat.
    • Restarted the game completely - still ended up with the bug again.
    • uninstalled ACV. moved the game to my primary SSD and deleted all saves/all files.
    • Verified game integrity.

    I'm out of ideas

  • Gemmell
    2 posts

    Having the same issue sit on the boat and nothing happens.
    I have tried a number of ideas people have mentioned and nothing has worked.
    I really dont what to start again (although saw someone say they did that and still happened).
    I am getting to the point of wishing I hadn't brought it. (Can you ask for refunds on digital products), i was really looking forward to this as well.
    If it wasn't ready dont release it.!!!

  • Nach-VO
    2 posts

    @fred_p Thanks for the tip, I'll try it and share the results.
    Have anyone tried this too and had successful result?

  • revelstatt
    5 posts

    Hi I got same problem Ubisoft don’t seem to care did you manage to sort it ..?

  • revelstatt
    5 posts

    @axeljbbb hi did you manage to sort out how to continue

  • G-MONEY100k
    1 posts

    In the seas of fate quest, my boat leaves the dock, then stops sailing in the middle of the quest. I’ve tried everything, will there be a patch or something soon?

Suggested Topics