ubisoft forums

Quick Suggestions

  • xX-Olbataaard-X
    13 posts

    @ubi-spud Please guys do something !

    The ticket support is unavalaible because of the Covid and the chat is not online...

    So, we are a lot a poeple who cant continue to play a game we buy full price, fix this bug !

  • LuciusDecimus
    3 posts

    @ubi-spud do you understand that what you are requesting is impossible, because it is not currently possible to create a ticket? We literally cannot provide you a save game file, because you will not let us.

  • Rubixcubix93
    2 posts

    @ubi-raziel I have managed to resolve mine (PS5) - in the downloads screen it showed that it had installed enough to 'start playing', but the rest had not downloaded. After downloading the last 30-odd GB it plays fine. Unsure why it happily downloaded updates but not the game itself.

  • xX-Olbataaard-X
    13 posts


    And its impossible (or difficult ) to give a PS4/XBOX save to Ubi !

  • alexcookies
    1 posts

    @shinesun ugh sadly it says that all my files are verified but thanks for the tip!

  • Houtochop
    1 posts

    unbelievable, and still the bug is not fixt!
    Where’re we waiting for?

  • LuciusDecimus
    3 posts

    Update: Support opened again and I submitted a ticket with savegame yesterday (ticket number 13265229). So far, no reaction in the ticket at all.

  • blazoleee1982
    1 posts

    Same for me on Xbox One X and physical disc. Boat stops in the middle of the sea and there is nothing that can done. Gunnar is either in the water by the boats or swim somewhere completely random. Tried talk to him, upgraded some items,killed soldiers as others suggested and nothing helps. Uninstalling and reinstalling doesn't solve it either. Game is pretty much unplayable and it's riddicolous.

  • guest-Gd7lKCCI
    1 posts

    Seas of fate still broken!!!!! Absolutely shocking to have a game that only plays so far then says it hasn’t been fully installed when it clearly has. Version 1.02 isn’t working!!

  • master_ring
    41 posts

    Same here. Boat doesnt move. PC version.

    Custscene doesnt load at start, and after it loads boat just stays on dock...

    So if your cutscene doesnt starts right away it wont leave England.
    Second cutscene is boat starts moving.

    So its like this
    First cutscene - black window with conversation on
    Second cutscene - stationary boat

    First cutscene - stationary boat
    Second cutscene - boat starts moving

    This is MAJOR issue. Paying premium for AAA game and cant progress quest after few days is pathetic really

  • SuperPower1900
    3 posts

    I have also the same problem 😕 im playing on PC

  • T-Bone772020
    3 posts

    Same thing!! I get on Sigurds longship, we go out of the bay, then the sail comes down, the oars come out, and we sit there.... can’t do anything but quit to the main menu. No map, no inventory, can’t move, can’t do anything!!! I’m assuming this is where it is supposed to cut out to modern day for a bit. That’s what the walkthroughs say is supposed to happen. But my game isn’t making the transition. We just sit there bobbing up and down on the waves!! I’ve tried multiple older saves, every different story choice leading up to this point, and even tried buying stuff from the blacksmith while he is in the boat. I’ve tried this part over twenty times, trying to get it to work. Sometimes the blacksmith gets out of the boat and swims out to sea, sometimes the assassin guy does. Sometimes they all stay in the boat. Sometimes the blacksmith isn’t there at all, and when I went into town and talked to him, then came back, one of the longboats was laying on its side on the shore! People still in it!! There is obviously a major bug, keeping this part from working correctly and progressing the story!! It’s infuriating!! PLEASE FIX THIS SOON UBISOFT!!!! I payed a lot of money for this digital download, and I’ve put over 16 hours into it already! I took my time getting all the treasures and wealth, then spent another $50 on cool weapons and skins! I DO NOT want to start over!! I planned on playing this all weekend, and was absolutely loving the game until this happened!! Kinda ruins the experience when you CANT PROGRESS THE STORY!! PLEASE FIX THIS ASAP UBISOFT!!! Quit telling us to try adjusting the settings, and other nonsense. Just PLEASE GET A TEAM ON THIS, FIX IT, AND RELEASE THE UPDATE PATCH ASAP!! You are starting to get A LOT of negative reviews and comments because of this issue. On what, in my opinion, is an otherwise spectacular game! Don’t wait until everyone is [censored] off and disgusted, and puts the game down, never to play it again because of this! Fix it quickly please!!!!

  • Deathisgod
    3 posts
    @deathisgod i am having the samae issue game is totally broken ive tried every way to get past it managed to glitches the boat to rangnarssons and cant proceed any further then there

    The only workaround I found was to start a new game.
    In doing so I realized how broken the game is. There was a ton of npc audio missing from my original game.

  • siggif1996
    1 posts

    @ubi-spud it's not working

  • xX-Olbataaard-X
    13 posts

    @deathisgod Me too !

    Ubisoft doesnt care about the player who spend a lot of money in their AAA, so i decide to start a new a save.

    I rush the main quest until the SEAS OF FATE , and guess what, it works and i go to England !

    On my first run, i had a lot of mysteries and NPC who doesnt work, and guess what, on my secon run i return from England to Norway and every mysteries works, every NPC works, i clean 100% of the map and return in England. It takes me 6h when my first run take 9h.

    So, if you want to play, try a new game and rush the main quest, go to england, and go back to Norway to clean it up ! I think the patch from Ubi will arrived as soon as a vaccin for the Covid19...

  • Glenski22
    1 posts

    @Ubi-Baron I am having the same problem of the individuals who are boarding the boat without getting Sigurd's dialogue and getting stranded about a mile off the shore. The boat trailing either follows until the main boat stops or if I try to upgrade equipment from the blacksmith (like some suggested), the boat floats and gets stuck on a pole in the air. I am playing on Xbox one x and would like to have this bug fixed. Thank you.

  • RawKalsen
    1 posts

    SOLUTION - if the games cutscene is activated before other assets are not loaded It will break the cutscene. Run to the ship and stay next to it for ~10 minutes before sitting down to activate the cutscene.

    Before doing this I attempted every other variation of changing settings, so this appears to be the only fix. I was stuck here for 3 days.

    Good luck everyone.

  • Poleinvader1939
    4 posts

    Another solution to this quest is to sit by the boat for about 10-15 minutes and the animation should load in, it worked for me as I tried almost every other solution out there. Hope this helps people/

  • ClusterFack
    1 posts

    Still no fix for this gamebreaking bug that stop me from playing the game, are you not finished with the game? Did you sell people a demo? Why does ubisoft spit in the face of their customers again and again? When can a fix be expected like we want a date not a "its being worked on" but just telling us when we can play the game, just tell us when the game you have already sold us will be done.

  • overXposed
    3 posts

    Cannot progress in the main storyline when asked to speak to Sigurd.

    Game states that I cannot advance because game is still installing but in reality it's %100 installed. Please advise Ubisoft. Ty.

Suggested Topics